Cannot install packages that require initrd re-generation on touch devices without proper flash-kernel support and kernel package

Bug #1384450 reported by Max Brustkern on 2014-10-22
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bootchart (Ubuntu)
Critical
Oliver Grawert
phablet-tools (Ubuntu)
Critical
Oliver Grawert

Bug Description

I reported a bug regarding inability to install bootchart on a specific device. This report removes the private details.

When I try to install bootchart on a krillin, I get this:
phablet@ubuntu-phablet:~$ sudo apt-get install bootchart
Reading package lists... Done
Building dependency tree
Reading state information... Done
bootchart is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up bootchart (0.90.2-8ubuntu2) ...
update-initramfs: Generating /boot/initrd.img-touch
dpkg: warning: version 'touch' has bad syntax: version number does not start with digit
grep: /boot/config-touch: No such file or directory
WARNING: missing /lib/modules/touch
Device driver support needs thus be built-in linux image!
depmod: FATAL: touch: not absolute path.
depmod: ERROR: could not open directory /tmp/mkinitramfs_lMBWKy/lib/modules/3.4.67: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
E: No boot partition found !
run-parts: /etc/initramfs/post-update.d//zz-flash-touch-initrd exited with return code 1
dpkg: error processing package bootchart (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 bootchart
E: Sub-process /usr/bin/dpkg returned an error code (1)

Related branches

Oliver Grawert (ogra) on 2014-11-03
Changed in bootchart (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Oliver Grawert (ogra)
Oliver Grawert (ogra) on 2014-11-04
summary: - Cannot install bootchart on touch
+ Cannot install packages that require initrd re-generation on touch
+ devices without proper flash-kernel support and kernel package
Revision history for this message
Oliver Grawert (ogra) wrote :

the issue here is that bootchart asks for initrd re-generation during package install, but krillin has neither a supported kernel package nor any support in flash-kernel to install the same (which would be a requirement for a kernel package)

what we can do here, since the initrd bootchart collection does not seem to work with android kernels anyway is to export FLASH_KERNEL_SKIP=true before installing it, to simply ignore the flashing of the intrd ... phablet-bootchart will also take this into account in the next iteration ... if you dont use phablet-bootchart (like agreed for testing during trusty timeframe when phablet-bootchart was developed with CI to cover this test case), please make sure your installation script does run this export before apt install the package.

Revision history for this message
Oliver Grawert (ogra) wrote :

nothing we can do about this in bootchart itself, marking invalid
fix/workaround is developed in phablet-bootchart, adding phablet-tools task

Changed in phablet-tools (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Oliver Grawert (ogra)
Changed in bootchart (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package phablet-tools - 1.1+15.04.20141107.1-0ubuntu1

---------------
phablet-tools (1.1+15.04.20141107.1-0ubuntu1) vivid; urgency=low

  [ Ubuntu daily release ]
  * New rebuild forced

  [ Oliver Grawert ]
  * update phablet-bootchart for new developer mode and password
    handling (LP: #1384450) (LP: #1384450)

  [ Robert Bruce Park ]
  * Fix pep8 test causing trunk build failures.
 -- Ubuntu daily release <email address hidden> Fri, 07 Nov 2014 16:15:45 +0000

Changed in phablet-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers