Default boost v1.54 has broken asio while available 1.55 is fixed

Bug #1319338 reported by Tobias Föhst on 2014-05-14
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Boost
New
Unknown
boost-mpi-source1.54 (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
boost1.54 (Ubuntu)
High
Unassigned
Trusty
High
Brian Murray

Bug Description

[Test Case]
1) g++ chat_client.cpp -std=gnu++11 -lboost_system -lpthread -o chat_client

You will need the header chat I will attach in the following comment in order to make it to compile.

Bug in current boost Trusty libraries, while trying to connect to non existing server.

* Bug:
./chat_client localhost 2423424
Success

* Expected:
./chat_client localhost 2423424
Connection refused

Original Description
--------------------
Release: 14.04 LTS
Version: 1.54.0.1ubuntu1
Expected: Depend on working version of boost
Happened: Depends on boost 1.54

Here is a bug that was fixed in boost 7 months ago: https://svn.boost.org/trac/boost/ticket/8795
Due to that, working with boost/asio seems impossible.

The bug is still present in boost1.54 but fixed in boost1.55. Therefore I consider it a bug to use version 1.54 as default, as other libraries' dev-packages depend on boost-default and hence cannot be installed together with libboost1.55-dev without being rebuild.

Of course, other possibilities would be to ask upstream if version 1.54 could be patched or add this patch to boost1.54.
But there might be more benefits in boost1.55 and as both versions are not perfect I see no reason to stick with the older one.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in boost-defaults (Ubuntu):
status: New → Confirmed
tags: added: trusty
Changed in boost:
status: Unknown → Fix Released
Jose Luis Rivero (j-rivero) wrote :

Is there any way to provide help, patches or testing in order to get this bug fixed in the current LTS Trusty? Should I file a new SRU bug or this is enough?

Brian Murray (brian-murray) wrote :

Utopic, which will become 14.10, has boost version 1.55 so I am marking this as Fix Released, but will open a 14.04 (Trusty) task for it.

Changed in boost-defaults (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Changed in boost-defaults (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → High
milestone: none → ubuntu-14.04.1
Brian Murray (brian-murray) wrote :

Comment #15 in the upstream bug report links to a couple of commits which should fix the issue with asio. For Stable Release Updates we prefer to make minimal changes to packages (https://wiki.ubuntu.com/StableReleaseUpdates), so it would be best if those changes were added to 1.54.

Jose Luis Rivero (j-rivero) wrote :

For the SRU, the test case to try is attached, please compile using:

 - g++ chat_client.cpp -std=gnu++11 -lboost_system -lpthread -o chat_client

You will need the header chat I will attach in the following comment in order to make it to compile.

Bug in current boost Trusty libraries, while trying to conect to non existing server.

* Bug:
./chat_client localhost 2423424
Success

* Expected:
./chat_client localhost 2423424
Connection refused

Jose Luis Rivero (j-rivero) wrote :
Jose Luis Rivero (j-rivero) wrote :

Here is the patch against current libboost1.54-dev in Trusty that fix the regression that makes impossible to use the ASIO library.

Brian Murray (brian-murray) wrote :

Thanks for the patch, I'll take care of sponsoring this to the trusty-proposed queue. I've modified the debian/changelog slightly though.

The syntax to reference a bug report in Launchpad in a debian/changelog file so that the Launchpad Bug Janitor and scripts can modify the Launchpad bug is to use the format LP: #1319338. I also copied the description from the patch to the changelog as that seemed more informative. The changelog entry now looks like this:

boost1.54 (1.54.0-4ubuntu4) trusty; urgency=medium

  * Fix a regression where, on some platforms, errors from async_connect are
    not correctly propagated through to the completion handler. (LP: #1319338)

Changed in boost-defaults (Ubuntu Trusty):
assignee: nobody → Brian Murray (brian-murray)
status: Triaged → In Progress
description: updated

Hello Tobias, or anyone else affected,

Accepted boost1.54 into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/boost1.54/1.54.0-4ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
affects: boost-defaults (Ubuntu) → boost1.54 (Ubuntu)
Changed in boost-mpi-source1.54 (Ubuntu):
status: New → Fix Released
Steve Langasek (vorlon) wrote :

Hello Tobias, or anyone else affected,

Accepted boost-mpi-source1.54 into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/boost-mpi-source1.54/1.54.0-4ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in boost-mpi-source1.54 (Ubuntu Trusty):
status: New → Fix Committed
Jose Luis Rivero (j-rivero) wrote :

Thanks Brian, Steve, Scott and Dimitri.

I've tested the new boost1.54-dev package in my trusty amd64 system and is fixing the problem. Silvio Traversaro was kind enough to give it a try also and reported good results in OSRF Gazebo issue tracker:
https://bitbucket.org/osrf/gazebo/issue/1204/trusty-remote_endpoint-transport-endpoint#comment-10857403

More testers are always welcome.

tags: added: verification-done
removed: verification-needed
Silvio Traversaro (pegua1) wrote :

Yes, I can confirm that the proposed package fixed the problem that we had.

The verification of the Stable Release Update for boost1.54 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in boost1.54 (Ubuntu Trusty):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boost-mpi-source1.54 - 1.54.0-4ubuntu3.1

---------------
boost-mpi-source1.54 (1.54.0-4ubuntu3.1) trusty; urgency=medium

  * Universe build of MPI boost components, to match LP: #1319338 upload
    of boost1.54.

boost1.54 (1.54.0-4ubuntu3.1) trusty; urgency=medium

  * Fix a regression where, on some platforms, errors from async_connect are
    not correctly propagated through to the completion handler. (LP: #1319338)
 -- Dimitri John Ledkov <email address hidden> Sat, 21 Jun 2014 05:17:47 +0100

Changed in boost-mpi-source1.54 (Ubuntu Trusty):
status: Fix Committed → Fix Released
Chris J Arges (arges) on 2014-07-01
Changed in boost1.54 (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in boost:
status: Fix Released → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.