Ubuntu

gcc-4.2/g++-4.2 build dependency should be dropped

Reported by Matthias Klose on 2008-10-08
6
Affects Status Importance Assigned to Milestone
boost (Ubuntu)
High
Unassigned
enigmail (Ubuntu)
High
Unassigned
libept (Ubuntu)
High
Unassigned
ocaml (Ubuntu)
High
Unassigned
texlive-bin (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: enigmail

This package build-depends on an old gcc version; please fix the package so that it does build with the default version of gcc.

Related branches

Matthias Klose (doko) on 2008-10-08
Changed in enigmail:
importance: Undecided → High
status: New → Confirmed
Changed in ocaml:
importance: Undecided → High
status: New → Confirmed
Changed in boost:
importance: Undecided → High
status: New → Confirmed
Changed in texlive-bin:
importance: Undecided → High
status: New → Confirmed
Changed in libept:
importance: Undecided → High
status: New → Confirmed
Jonathan Thomas (echidnaman) wrote :

libept seems to build fine with the default gcc in Intrepid. (And it doesn't explicitly build-depend on gcc++-4.2, so nothing to change there.)

Changed in libept:
status: Confirmed → Fix Released
Rolf Leggewie (r0lf) wrote :
Changed in enigmail:
assignee: nobody → r0lf
status: Confirmed → Fix Released
Stéphane Glondu (glondu) wrote :

The build dependency has been dropped in ocaml 3.11.0 (in unstable)

Changed in ocaml:
status: Confirmed → In Progress
Michael Terry (mterry) on 2009-05-11
Changed in boost (Ubuntu):
assignee: nobody → Michael Terry (mterry)
status: Confirmed → In Progress
Michael Terry (mterry) wrote :

I looked into boost. It has serious issues compiling with even gcc 4.3. These are the upstream bugs about it: http://svn.boost.org/trac/boost/query?status=new&status=assigned&status=reopened&summary=~4.3&order=priority

There is a patch in the debian sources to work with gcc 4.3, but the debian/Notes file indicates it is incomplete. And of course, 4.3 is not 4.4.

But let's say boost did compile perfectly with 4.4. The changes you'd have to make: You'd have to change the Build-Depends, the rules file, and and all the installed libraries have 'gcc42' in their name, so you'd have to adjust all the .install files.

Changed in boost (Ubuntu):
assignee: Michael Terry (mterry) → nobody
status: In Progress → Confirmed
Fabrice Coutadeur (fabricesp) wrote :

changed in version 2007.dfsg.2-6ubuntu1 in karmic

Changed in texlive-bin (Ubuntu):
status: Confirmed → Fix Released
Changed in ocaml (Ubuntu):
status: In Progress → Won't Fix
status: Won't Fix → Fix Released
Rolf Leggewie (r0lf) on 2009-07-17
Changed in enigmail (Ubuntu):
assignee: Rolf Leggewie (r0lf) → nobody
Craig Hrabal (crhrabal) on 2013-11-19
Changed in boost (Ubuntu):
status: Confirmed → Fix Committed
Michael Terry (mterry) wrote :

boost source package is no longer in archive, in favor of version-specific names like boost-mpi-source1.53. These boost packages now use the system g++.

Changed in boost (Ubuntu):
status: Fix Committed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers