boltd1719]: probing: timeout, done - timeouts every few seconds from boltd

Bug #1892657 reported by David Oswald on 2020-08-23
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
bolt (Ubuntu)
Low
Unassigned
Focal
High
Sebastien Bacher

Bug Description

* Impact

The bolt service response to new kernel uevents creating uneeded work and log warnings

* Test case

Use a tb3 compatible machine with a dock (TB16 for example), check the journal, no 'probing: timeout, done' entry should be listed

* Regression potential

The change is simple to filter out wakeup events, those are known to not be useful nor needed but confirm that tb3 devices are still correctly detected when connected

-----------------------------

This may relate to https://gitlab.freedesktop.org/bolt/bolt/-/issues/156

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: bolt 0.8-4
ProcVersionSignature: Ubuntu 5.4.0-42.46-generic 5.4.44
Uname: Linux 5.4.0-42-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.8
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: ubuntu:GNOME
Date: Sun Aug 23 17:32:55 2020
InstallationDate: Installed on 2019-05-02 (479 days ago)
InstallationMedia: Ubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: bolt
UpgradeStatus: Upgraded to focal on 2020-04-23 (121 days ago)

David Oswald (daoswald) wrote :
David Oswald (daoswald) wrote :

Aug 23 17:33:41 davido-thinkpad boltd[1719]: probing: started [1000]
Aug 23 17:33:46 davido-thinkpad boltd[1719]: probing: timeout, done: [2114586] (2000000)
Aug 23 17:33:47 davido-thinkpad boltd[1719]: probing: started [1000]
Aug 23 17:33:49 davido-thinkpad boltd[1719]: probing: timeout, done: [2003449] (2000000)
Aug 23 17:34:20 davido-thinkpad boltd[1719]: probing: started [1000]
Aug 23 17:34:24 davido-thinkpad boltd[1719]: probing: timeout, done: [2141302] (2000000)
Aug 23 17:34:37 davido-thinkpad boltd[1719]: probing: started [1000]

Christian Kellner (gicmo) wrote :

Probably issue https://gitlab.freedesktop.org/bolt/bolt/-/issues/156 indeed, kernel/udev started to emit additional events ("bind" evens, IIRC) every few seconds for the network adaptor inside the dock. Easiest way to confirm is to check via "udevadm monitor" and compare with bolt logs.

Sebastien Bacher (seb128) wrote :

Sounds like it was fixed upstream with https://gitlab.freedesktop.org/bolt/bolt/-/merge_requests/209.patch which is in 0.9 https://launchpad.net/ubuntu/+source/bolt/0.9-1

We should probably SRU that fix to focal

Changed in bolt (Ubuntu):
importance: Undecided → Low
status: New → Fix Released
Cas (calumlind) wrote :

This is quite an irritating bug with the boltd 'snake' icon regularly appearing in the UI: https://askubuntu.com/questions/1239006/what-does-the-indicator-icon-with-three-dots-over-a-power-plug-mean-in-ubuntu-20

@seb128 Any progress on a SRU for focal?

David Oswald (daoswald) wrote :

I can confirm that as of 2020-09-07 this bug persisted, despite the issue being marked "Fix Released" on 2020-08-24. The biggest annoyance with it is the fact that the connection snake icon appearing and disappearing from the top of the Gnome desktop causes any other icon to the left of it to shift over and back every few seconds. The annoyance is just a symptom of the problem described above, though. But it impacts the user experience significantly enough that I mostly avoid docking my laptop until it's fixed.

Cas (calumlind) wrote :

@daoswald I posted a workaround on AskUbuntu that you might find helpful: https://askubuntu.com/a/1273847/8570

Cas (calumlind) wrote :

I have attached a debdiff for Focal bolt 0.8-4 package. It was built with pbuilder successfully, installed and patch works as intended.

David Oswald (daoswald) wrote :

I'm unfamiliar with the process. Now that a debdiff has been attached, what is the process for it being adopted and finding its way out to the end user?

Cas (calumlind) on 2020-09-14
Changed in bolt (Ubuntu Focal):
status: New → Confirmed
Changed in bolt (Ubuntu Focal):
importance: Undecided → High
assignee: nobody → Sebastien Bacher (seb128)
Sebastien Bacher (seb128) wrote :

> I'm unfamiliar with the process. Now that a debdiff has been attached, what is the process for it being adopted and finding its way out to the end user?

Someone with upload rights to Ubuntu needs to sponsor the change, which I did now. Next the SRU team is going to review the update and post instructions here on the bug on how to verify the fix. Once the fix is verify it's going to move to official updates

Changed in bolt (Ubuntu Focal):
status: Confirmed → Fix Committed
description: updated

Hello David, or anyone else affected,

Accepted bolt into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bolt/0.8-4ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-focal
Cas (calumlind) wrote :

I have tested with bolt (0.8-4ubuntu1) that boltctl monitor no longer shows 'Probing...' messages and the notification icon does not constantly appear

tags: added: verification-done-focal
removed: verification-needed-focal
David Oswald (daoswald) wrote :

I have tested with bolt (0.8-4ubuntu1) and can confirm that on my system the 'Probing...' messages are no longer being spewed, and the notification icon no longer pops up every couple of seconds. It seems resolved to me.
(Lenovo Thinkpad X1 Carbon, 6th Gen with Lenovo Thinkpad Thunderbolt 3 dock)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bolt - 0.8-4ubuntu1

---------------
bolt (0.8-4ubuntu1) focal; urgency=medium

  * debian/patches/ignore-wakeup-device-uevents.patch:
    - backport an upstream gitlab patch (70bdb25c) to fix boltd probing
      timeouts every few seconds (lp: #1892657)

 -- Calum Lind <email address hidden> Thu, 10 Sep 2020 09:53:51 +0100

Changed in bolt (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for bolt has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.