[SRU] Update to 0.4

Bug #1786265 reported by Sebastien Bacher on 2018-08-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bolt (Ubuntu)
Low
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact

That's a new component and a piece of hardware enablement. The update is having dbus API changes and is not a bugfix only version, but we believe it's better to follow improvements in that new stack than stay on an early version which is incomplete and unmaintained.

The service has no rdepends out of gnome-shell which already works fine with the new version

The summary of the changes can be found there
https://gitlab.freedesktop.org/bolt/bolt/tags/0.4

* Test case
- log into an Ubuntu session
- connect a new Thunderbolt device
- check that gnome-shell displays the request for authentication for the device and that the authentication can be validated/the device can be used

* Regression potential

There are quite some code changes but bolt is limited to authentication of Thunderbolt devices, we need to test that the boltctl command line and the GNOME integration keep working to auth/revoke devices.

Sebastien Bacher (seb128) wrote :
Changed in bolt (Ubuntu):
importance: Undecided → Low
status: New → Fix Released
graingert (tagrain) wrote :

@seb128 that's only cosmic - is there a bionic update?

Sebastien Bacher (seb128) wrote :

Yes, it's waiting for review in the SRU queue
https://launchpad.net/ubuntu/bionic/+queue?queue_state=1&queue_text=bolt

I think there has been some delays in SRU reviews recently due to .1 freeze and holidays though...

Łukasz Zemczak (sil2100) wrote :

The few new features are rather unfortunate, but seeing that there's a lot of unit-testing present that's being run built-time, I suppose we can put it under the MRE case.

Changed in bolt (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

Hello Sebastien, or anyone else affected,

Accepted bolt into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bolt/0.4-0ubuntu0.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

graingert (tagrain) wrote :

@sil2000 ok it works for me, from lightdm. However the mouse and keyboard don't work in UEFI, grub or plymouth without booting into windows first

Łukasz Zemczak (sil2100) wrote :

@tagrain hey! Thanks for giving it a spin - could you also report which version of bolt did you use for testing?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers