make_project crashed with ImportError in __main__: No module named boinc_path_config

Bug #920554 reported by Sasa Paporovic
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
boinc (Debian)
Fix Released
Unknown
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

I am on Ubuntu 12.04 64bit updated to 23.1.2012

I have tried to setup a BOINC-Server with the boinc-server-maker package 7.0.7+dfsg-1 and this workflow:

http://wiki.debian.org/BOINC/ServerGuide

and have just executed:

sudo PYTHONPATH=$PYTHONPATH:/usr/share/pyshared/Boinc/ \
 /usr/share/boinc-server/tools/make_project \
  --url_base "$hosturl" --db_name "$dbprojectname" \
  --db_user boincadm --db_passwd "$pw" \
  --drop_db_first \
  --project_root "$installroot"/"$fileprojectname" \
  --srcdir /usr/share/boinc-server/ \
   "$fileprojectname" "$niceprojectname"

which causes the error on terminal:

Traceback (most recent call last):
  File "/usr/share/boinc-server/tools/make_project", line 6, in <module>
    import boinc_path_config
ImportError: No module named boinc_path_config

A fix for that import error would be good.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: boinc-server-maker 7.0.7+dfsg-1
ProcVersionSignature: Ubuntu 3.2.0-10.17-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Mon Jan 23 17:55:21 2012
ExecutablePath: /usr/share/boinc-server/tools/make_project
ExecutableTimestamp: 1319180315
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: python /usr/share/boinc-server/tools/make_project --url_base http://127.0.0.1 --db_name boinctest --db_user boincadm --db_passwd 29widjfh --drop_db_first --project_root /var/tmp/boinc/boinctest --srcdir /usr/share/boinc-server/ boinctest BoincTestProject@Home
ProcCwd: /home/user
PythonArgs: ['/usr/share/boinc-server/tools/make_project', '--url_base', 'http://127.0.0.1', '--db_name', 'boinctest', '--db_user', 'boincadm', '--db_passwd', '29widjfh', '--drop_db_first', '--project_root', '/var/tmp/boinc/boinctest', '--srcdir', '/usr/share/boinc-server/', 'boinctest', 'BoincTestProject@Home']
SourcePackage: boinc
Title: make_project crashed with ImportError in __main__: No module named boinc_path_config
Traceback:
 Traceback (most recent call last):
   File "/usr/share/boinc-server/tools/make_project", line 6, in <module>
     import boinc_path_config
 ImportError: No module named boinc_path_config
UpgradeStatus: Upgraded to precise on 2011-12-31 (23 days ago)
UserGroups:

Revision history for this message
Sasa Paporovic (melchiaros) wrote :
visibility: private → public
tags: removed: need-duplicate-check
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

seems to be a config problem... did you try to look at this?
http://boinc.berkeley.edu/dev/forum_thread.php?id=7014

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

Yes, have seen this. It is what it is -> useless.

The talk is about triaging the problem and giving it to a vm malfunction. And the rest is not much better.

I am on metal not on a vm.

What this here affect: boinc-server-maker is from the last GSOC and tries to encapsulate most of the configuration steps. Especially those which makes problems here, so it is not a case of misconfiguration by a user, it is a problem with the configuration scripts that are in the boinc-server-maker package.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I'm building boinc 7.0.15 development release in my ppa...

could you please give it a try?
https://launchpad.net/~costamagnagianfranco/+archive/boinc

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

I have looked into your ppa.

The only packages I see there are named boinc.

So?

This report is on boinc-server-maker.

How should I understand? Have you included all in your boinc packages?Also the boinc-server-maker scripts?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I'm currently building the 64bit boinc packages...

so please wait until they get built...

I'm building boinc-server-maker too, but you have to wait until it gets published...
http://ppa.launchpad.net/costamagnagianfranco/boinc/ubuntu/pool/main/b/boinc/

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

they should be published...

please try again after a "sudo apt-get update" ;)

Revision history for this message
Sasa Paporovic (melchiaros) wrote :

In moment I am on Ubuntu11.10. I would test the packages for that version on the next sunday.

Earlier is not possible to me.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

(no problem, just a suggestion: I built this boinc version for oneiric too)

Revision history for this message
Steffen Möller (moeller-debian) wrote : Re: [Bug 920554] Re: make_project crashed with ImportError in __main__: No module named boinc_path_config

On 02/16/2012 07:19 PM, LocutusOfBorg wrote:
> (no problem, just a suggestion: I built this boinc version for oneiric
> too)

I admit not to have addressed that issue. It can be circumvented by setting the PYPATH environment variable, just like shown on
the ServerGuide page on the wiki ... at least so I recall. What exactly needs to be done to get this all configured correctly ab
initio I cannot tell.

Cheers,

Steffen

Changed in boinc (Debian):
status: Unknown → Confirmed
Changed in boinc (Debian):
status: Confirmed → Fix Released
Changed in boinc (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.