boinc-client bad signature for URL

Bug #878571 reported by Benjamin Kerensa
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
BOINC
Fix Released
Unknown
boinc (Ubuntu)
Undecided
Unassigned
Oneiric
Medium
Unassigned

Bug Description

Essentially this bug has occurred in previous releases and fixes have occurred and yet it is now coming back in 11.10. Whenever I try to attach to any boinc account manager it hangs and the logs show errors indicating "boinc-client bad signature for URL".

Similar to: https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/585547

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: boinc-client 6.12.33+dfsg-1.1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Wed Oct 19 16:21:43 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: boinc
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Benjamin Kerensa (bkerensa) wrote :
Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

Verified this is a valid 64bit specific boinc bug since it is not occuring on 32bit installs and I have tried it on two fresh amd64 11.10 installs and had two other people check on their 11.10 installs.

Changed in boinc (Ubuntu):
status: New → Confirmed
description: updated
Revision history for this message
Benjamin Kerensa (bkerensa) wrote :
Changed in boinc:
status: Unknown → New
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Could you please try 6.12.34 from there?

http://boinc.berkeley.edu/download.php

thanks

Changed in boinc (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

LocotusOfBorg: I will tomorrow morning... I downgraded back to i386 after spending two days trying to find a work around.... Notably 6.12.33 was installing default on amd64 11.10

Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

Upstream confirmed the bug and said the following "This should be fixed in 6.12.42 or better." however the problem is Ubuntu is using a version lower then that so the bug still exists.

Any possibility of bumping up to 6.12.42 or better.

Changed in boinc (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

According to [1] and [2] this version hasn't been released and built yet.

So the process will be a little long: release the version to boinc alpha tester, package the version in both debian and ubuntu, SRU it to at least oneiric and release it to everybody.
I'm sorry but it will take a while.

Setting to fix committed.

[1] http://boinc.berkeley.edu/dl/?C=M;O=D
[2] http://boinc.berkeley.edu/download.php

Changed in boinc (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Brian Murray (brian-murray) wrote :

This is an incorrect use of Fix Committed as the fix is not committed to the Ubuntu package at all. If there is a specific patch that fixes this particular issue it will be much easier to get fixed in Oneiric.

Changed in boinc (Ubuntu):
status: Fix Committed → Triaged
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

(Sorry, fix committed was intender for the upstream bug, I made a mistake in clicking)

Rom said it has a patch, but I'm checking in trac and the only changeset made by him is 24471
http://boinc.berkeley.edu/trac/changeset/24471
and 24470 (on trunk branch)

Changed in boinc:
status: New → Fix Released
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

@Brian I have uploaded a simple patch to fix this bug.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "changeset_r24471.diff" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Revision history for this message
Stefano Rivera (stefanor) wrote :

This patch appears to be applied in precise.

Changed in boinc (Ubuntu):
status: Triaged → Fix Released
Changed in boinc (Ubuntu Oneiric):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Could this patch be backported to oneiric?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Fixed in trunk in revision 23007

Revision history for this message
Stefano Rivera (stefanor) wrote :

Uploaded, pending SRU team review

Changed in boinc (Ubuntu Oneiric):
status: Triaged → Fix Committed
Revision history for this message
Chris Halse Rogers (raof) wrote : Please test proposed package

Hello Benjamin, or anyone else affected,

Accepted boinc into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Benjamin Kerensa (bkerensa) wrote :

Confirmed bug in 6.12.33+dfsg-1.1 and verified fix in proposed.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 6.12.33+dfsg-1.1ubuntu0.1

---------------
boinc (6.12.33+dfsg-1.1ubuntu0.1) oneiric-proposed; urgency=low

  * upstream_strcpy_overlap.patch: Apply upstream patch to not use strcpy() on
    overlapping regions. (LP: #878571)
 -- Stefano Rivera <email address hidden> Thu, 27 Oct 2011 02:11:14 +0200

Changed in boinc (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.