client outdated

Bug #87353 reported by T. Appelhagen
30
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

The actual version in dapper/universe is still 5.4.9 (edgy has at least 5.4.11?), but the recommended actual version is 5.8.11!

See here: http://boinc.berkeley.edu/download_all.php

As far as I can see, the newer cores add better support for CPUs and an improved memory management, so it'd be a "nice to have".

Revision history for this message
C de-Avillez (hggdh2) wrote :

boinc recommends user to run 5.8. Feisty right now offers 5.4.11

Changed in boinc:
status: Unconfirmed → Confirmed
Revision history for this message
Bryan Quigley (bryanquigley) wrote :

I would also like to see it added in Feisty. I believe it is in Debian's experimental branch, so if any developer wants to upload it to Feisty manually it would be much appreciated.

Revision history for this message
Frank S. Thomas (fst) wrote : Re: [Bug 87353] Re: client outdated

On Sunday 11 March 2007 01:37, gQuigs wrote:
> I believe it is in Debian's experimental branch [...]

That is not quite right, the package is ready in the experimental branch of
pkg-boinc's SVN repository:
http://svn.debian.org/wsvn/pkg-boinc/branches/experimental/boinc/

I intend to upload it to Debian/experimental next week.

Grüße,
Frank

Revision history for this message
Frank S. Thomas (fst) wrote :

BOINC 5.8.17 has been uploaded to Debian/unstable today and a sync for it can now be requested.

Revision history for this message
William Grant (wgrant) wrote :

This requires no action; it will be synced automatically within a few days.

Revision history for this message
BraveErudite (braveerudite) wrote :

Does it work for Ubuntu 7.04 (32 Bit version) and where is the link to it?

Thank you for updating BOINC

Revision history for this message
William Grant (wgrant) wrote :

This will be for 7.10. You can probably request a backport for 7.04 soon, though.

Revision history for this message
Frank S. Thomas (fst) wrote :

 affects ubuntu/boinc
 status fixreleased

BOINC 5.8.17-1 has been synced from Debian to Ubuntu Gutsy on 2007-05-01.
This version fixes this bug, see the changelog for more details:
https://launchpad.net/ubuntu/gutsy/+source/boinc/5.8.17-1

Changed in boinc:
status: Confirmed → Fix Released
Revision history for this message
T. Appelhagen (borsti67) wrote :

what about dapper?

As far as I can see, even the original apt(itude)-source (5.4.9) at pkg-boinc.alioth.debian.org is gone...? :(

Revision history for this message
William Grant (wgrant) wrote : Re: [ubuntu-science] [Bug 87353] Re: client outdated

T. Appelhagen wrote:
> what about dapper?
>
> As far as I can see, even the original apt(itude)-source (5.4.9) at pkg-
> boinc.alioth.debian.org is gone...? :(

You might be able to request a backport of the new version to previous
versions, but we don't do that stuff, and there's not really another option.

Revision history for this message
BraveErudite (braveerudite) wrote :

I installed the Debian BOINC 5.8.17-1 on Ubuntu 7.04 (32 Bit) and still hangs on "Ready to Report" everything else works.

Revision history for this message
Frank S. Thomas (fst) wrote :

On Monday 07 May 2007 23:46, William Grant wrote:
> T. Appelhagen wrote:
> > what about dapper?
> >
> > As far as I can see, even the original apt(itude)-source (5.4.9) at pkg-
> > boinc.alioth.debian.org is gone...? :(
>
> You might be able to request a backport of the new version to previous
> versions, but we don't do that stuff, and there's not really another
> option.

Sorry, but a backport to Dapper is not possible, because it hasn't all
required build dependencies. boinc_5.8.17-1 build-depends on
libcurl3-openssl-dev (>= 7.15.5) but Dapper only has 7.15.1-1ubuntu2. If you
want to run BOINC 5.8 you have to upgrade your machine at least to Feisty,
for which a backport is possible and already has been requested:
https://bugs.launchpad.net/feisty-backports/+bug/112570

Grüße,
Frank

Revision history for this message
William Grant (wgrant) wrote :

Frank S. Thomas wrote:
> On Monday 07 May 2007 23:46, William Grant wrote:
>> T. Appelhagen wrote:
>>> what about dapper?
>>>
>>> As far as I can see, even the original apt(itude)-source (5.4.9) at pkg-
>>> boinc.alioth.debian.org is gone...? :(
>> You might be able to request a backport of the new version to previous
>> versions, but we don't do that stuff, and there's not really another
>> option.
>
> Sorry, but a backport to Dapper is not possible, because it hasn't all
> required build dependencies. boinc_5.8.17-1 build-depends on
> libcurl3-openssl-dev (>= 7.15.5) but Dapper only has 7.15.1-1ubuntu2. If you
> want to run BOINC 5.8 you have to upgrade your machine at least to Feisty,
> for which a backport is possible and already has been requested:
> https://bugs.launchpad.net/feisty-backports/+bug/112570
>
> Grüße,
> Frank

That's why I added the `might' ;-)

Revision history for this message
T. Appelhagen (borsti67) wrote :

By now I *really* wonder what this "long term support" means...

I decided to use dapper because it should last for the lifetime of the server - five years seemed to be enough.

And what's up now?
- BOINC is outdated and it's just a matter of time until the projects will require a newer version, so I can't use it any more.
- MLDonkey is lightyears behind, rendering it unusable (I don't know if at least the installer-bug is fixed by now)
- Even worse, ClamAV (which always wasn't very up-to-date!) is still on 0.88.4 while 0.90.2 is current. Backport rejected, see here: https://bugs.launchpad.net/ubuntu/+source/clamav/+bug/53856
A mail server without actual virus scanner? Hah!

It's not even a year since the installation and I shall dist-upgrade??? Just like Windows, "if something is strange, FORMAT C: and reinstall"?

Sorry, but this is ridiculous!

Very dissatisfied greetings,
Torsten

Revision history for this message
William Grant (wgrant) wrote :

The fact that Dapper is an LTS release doesn't mean it should get a whole lot of new upstream versions after release; it's meant to be stable, not have new crack! The way BOINC works is inappropriate for a majority of distributions if it's useless after just a year. Same with MLDonkey and ClamAV (though the latter is being worked on in the bug you mentioned).

If you want all of this new stuff, you can help us make them work on Dapper, and perform the huge amount of testing necessary to remove the risk of regressions from these new versions. But that's unlikely to happen; it's just too risky!

(Note that Long Term Support only guarantees security updates for main and restricted. universe and multiverse have always been updated on a best-effort basis, and new versions of software are particularly low on the list. Our manpower is very limited.)

Revision history for this message
T. Appelhagen (borsti67) wrote :

Hi William,

ClamAV is being worked on? The status was "rejected" the last time I looked there. Would be great if you're right!

OK, I got the point.
Sadly I'm not very good in doing things by myself (aka compiling and installing). Surprisingly I was successful in MLDonkey (I'm using the actual version from CVS now, everythings works fine). On the other hand, I didn't manage to setup ClamAV this way. When compiled from CVS, it leaves me with some executables und wrappers only so I would have to replace those from the original installation; I don't like such. On the other hand, when I'm removing the ClamAV-package before, the daemon is missing and other problems arise. Anyway, this doesn't belong here.

Bearing this limited knowledge in mind, IS there a way for me helping you out? As I said in the other bugreport, if I can recover to a stable version in case of a crash, I'm willing to test! You can contact me by mail or jabber also, if you like.

best regards,
Torsten

Revision history for this message
Shirish Agarwal (shirishag75) wrote :

subscribed to the thread, have the .sh shell script going for now. Hope u guys also keep an eye on http://boinc.berkeley.edu/download_all.php the 5.9.10 version.

Boincmgr requires GTK++2.0 and glibc 2.4 (libc) or higher which are included in recent Linux distributions. Its been tested on:

BOINC version 5.9.5 for Linux/x86

    * Fedora Core 5 (with updates)
    * SUSE 10.1
    * Ubuntu 6.10

Release date: 1st May 2007

Revision history for this message
Shirish Agarwal (shirishag75) wrote :

The 5.8.16 gives this output when run :-

shirish@ubuntu ~/b/BOINC> ./boincmgr
Skin Manager: Failed to parse static line color. Using default.
Skin Manager: Application name was not defined. Using default.
Skin Manager: Failed to load application logo. Using default.
Skin Manager: Company name was not defined. Using default.
Skin Manager: Company web site was not defined. Using default.
Skin Manager: Project name was not defined. Using default.
Skin Manager: Default tab was not defined. Using default.
Skin Manager: Exit message was not defined. Using default.
Skin Manager: Failed to load attach to project wizard bitmap logo. Using default.
Skin Manager: Attach to project wizard title was not defined. Using default.
Skin Manager: Failed to load attach to project wizard bitmap logo. Using default.
Skin Manager: Attach to project wizard title was not defined. Using default.
connect: Connection refused
Skin Manager: Failed to load 'a' icon. Using default.
connect: Operation now in progress

(boincmgr:7528): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

(boincmgr:7528): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

(boincmgr:7528): Gtk-CRITICAL **: gtk_container_remove: assertion `GTK_IS_TOOLBAR (container) || widget->parent == GTK_WIDGET (container)' failed

 Have GNOME although running on XFCE atm .

Revision history for this message
T. Appelhagen (borsti67) wrote :

since I only use the "plain client" without manager, the following procedure worked for me (probably very unprofessional, but I wanted the work done!)

(prerequisite: BOINC was normally installed via apt-get/aptitude and is working)

- stop boinc
- download the actual linux/x86 version [url]http://boinc.berkeley.edu/download_all.php[/url]
because the "recommended version" without GUI is too old also, I tried the actual beta (5.10.0) - so far it's working fine.
- execute the downloaded file, this creates a folder "BOINC" in the current directory
- rename or move (or if you're really sure delete) "boinc", "boinc_cmd" and "boinc_client" from /usr/bin
- copy "boinc" and "boinc_cmd" from BOINC-folder to /usr/bin
- create a symlink named "boinc_client" pointing to "boinc"
- copy "ca-bundle.crt" to /var/lib/boinc-client
dont't forget the last step, otherwise connections to the project servers will fail!
- restart boinc

the other files in the BOINC folder seem to belong to the manager, so I don't need them.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions