No graphics ("Show graphics" grayed out or nothing happens)

Bug #72192 reported by Dean Loros
This bug affects 2 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Nominated for Hardy by jtl999
Nominated for Intrepid by jtl999

Bug Description

The "show graphics" button is grayed out for most projects, because there are no graphics available.
The button is only active, if the task provides a graphic _and_ is active.

Additionally, you need to call "xhost +si:localuser:boinc" to allow the local boinc user accessing your DISPLAY.

If those conditions are met, graphics get displayed. That's the case e.g. for the "FightAIDS@Home 5.42" application in the "World Community Grid" project.

It's not easily possible to provide feedback about failure of glutInit to the user (see comment below).

For BOINC 6, it's planned to revamp the whole subsystem to display graphics, so there's hope that the user experience gets improved (I've read about it at

Revision history for this message
Caroline Ford (secretlondon) wrote :

It's unchanged from Debian - it was created by the auto sync.

Debian don't have any bugs referring to this - however it's not a very popular package so that's not surprising (and that doesn't mean that it's not a bug).

Revision history for this message
Frank S. Thomas (fst) wrote : Re: [Bug 72192] No graphics in 5.4.11

Hi Dean,

On Friday 17 November 2006 16:43, Dean Loros wrote:
> I don't know if to call this a bug or not--the current boinc-manager's
> Tasks window has the "Show graphics" tab grayed out

This normally means that the project to which the selected task belongs to
does not support graphics. So it's not a bug in the BOINC Manager if the
button is grayed out.

> --I have gone to the
> Debian Wiki & done what is shown to "make" graphics work (xhost +local:)
> & this will not work.

This will "make" graphics work, only if the "Show graphics" button was not
grayed out before.

> Is it possible that the "current" version was
> compiled without the --show_graphics flag?

I've never heard of such a flag. Where did you?

Anmut bringen wir ins Leben;
 Leget Anmut in das Geben.

Revision history for this message
Dean Loros (autocrosser) wrote : Re: No graphics in 5.4.11

My bad---the flag is in the boinc_cmd options--also, I just tried using the "new" boinc 5.6.4--I just imported all my files from /var/lib/boinc-client into the new directory that was created in /home/*myusername*/BOINC. Boincmgr started right up with my current dataunits--still no graphics--could the "problem" be with the seti_enhanced app?(I imported it with all the other information) Graphics worked very well in my Dapper install using Boinc 5.4.9 & the seti app that was installed with it---

Revision history for this message
Marco Rodrigues (gothicx) wrote :

This is still an issue for you? do you use Gutsy ?

Changed in boinc:
assignee: nobody → gothicx
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Daniel Hahler (blueyed) wrote :

I can confirm this somehow, but it's expected: the button is only enabled, if the result supports it (clientgui/ViewWorkGrid.cpp).
Grepping the source for "supports_graphics" shows this from checkin_notes_2006:
David 30 June 2006
    - core client: ACTIVE_TASK::supports_graphics():
        return false if process isn't executing.
        (prevent GUI from showing "show graphics" button
        for results with no process, or suspended process)

So a result must have a graphic attached and the process must be active currently.
This is the case for me with the FightAIDS@Home 5.42 application (from the World Community Grid project): the button is not grayed out for it, but nothing happens when I click it.
I'll rebuild the packages with "--enable-debug" and see if there's any hint.

Changed in boinc:
assignee: gothicx → blueyed
status: Incomplete → In Progress
Revision history for this message
Daniel Hahler (blueyed) wrote :

After the button is enabled, executing "xhost +local:" or the more safe "xhost +si:localuser:boinc" makes the graphics display.

See also

I'll see if we can supply some patch, which will inform the user about the "xhost" issue when displaying the graphic failed.
According to the Debian wiki page mentioned above it's not a good idea security wise to execute this command by default (although I think that the second variant should be quite safe, as it only allows it for the local "boinc" user.

Revision history for this message
Daniel Hahler (blueyed) wrote :

It's not possible to inject at least a BOINCINFO macro, when initialization fails, because glutInit from freeglut does "exit(1)" in this case.
The code in boinc looks as follows:

static void boinc_glut_init() {
    if (debug) fprintf(stderr, "Calling glutInit()... \n");
    glutInit (&one, (char**)args);
    if (debug) fprintf(stderr, "survived glutInit(). \n");

Changed in boinc:
assignee: blueyed → nobody
status: In Progress → Triaged
Daniel Hahler (blueyed)
description: updated
Revision history for this message
Dean Loros (autocrosser) wrote : Re: [Bug 72192] Re: No graphics in 5.4.11

Sorry I haven't got back to you before now--I'm presently in
Hardy-testing. I downloaded the 5.10.28 directly from Seti site & am
using a custom app from

This app is compiled without graphics--I had gone without for long
enough that it no longer matters to me :)

Thank you for the E

Dean Loros

Marco Rodrigues wrote:
> This is still an issue for you? do you use Gutsy ?
> ** Changed in: boinc (Ubuntu)
> Importance: Undecided => Low
> Assignee: (unassigned) => Marco Rodrigues (gothicx)
> Status: New => Incomplete

Revision history for this message
Savvas Radevic (medigeek) wrote :

confirming on intrepid ibex.. but I think it would be better to concentrate on creating a screensaver that gets the status of the current working unit :)
Either way, both solutions would be accepted!

Revision history for this message
Nicolás Alvarez (nicolas-alvarez) wrote :

Isn't this fixed in 6.x? (The graphics get started by boincmgr, not boinc_client, so they run as the local user, not 'boinc').

Revision history for this message
Matthew Meyer (osarusan) wrote :

Still not fixed in 6.10.x

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

@Matthew could you try to reproduce with oneiric or a new boinc version from the official download site? thanks

Changed in boinc (Ubuntu):
status: Triaged → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for boinc (Ubuntu) because there has been no activity for 60 days.]

Changed in boinc (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers