package failed to remove itself completely from synaptic package manager.

Bug #654119 reported by Steve Sargent
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: boinc

Had installed boinc from website, but would not run properly. Deleted install script and BOINC subdirectory and installed from package manager. Then ran Boinc Manager from Gnome Menu, but got 'failed to connect' errors. Completely uninstalled all BOINC componenents from package manager, but was given error on boinc-client. Ran `ps aux |grep boinc` to see if user boinc had programs running still. 2 remained. Was about to reboot system when crash icon rose from taskbar. Plan to reinstall again, in hopes that previous attempt at manual install would be completely wiped out (I didn't modify anything outside of my home directory, such as /var/lib), so I can start fresh.

ERROR:
Purging configuration files for boinc-client ...
Removing user `boinc' ...
Warning: group `boinc' has no more members.
userdel: user boinc is currently logged in
/usr/sbin/deluser: `/usr/sbin/userdel boinc' returned error code 8. Exiting.
dpkg: error processing boinc-client (--purge):
 subprocess installed post-removal script returned error exit status 1

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: boinc-client (not installed)
ProcVersionSignature: Ubuntu 2.6.32-25.44-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic i686
Architecture: i386
Date: Sun Oct 3 07:43:29 2010
ErrorMessage: subprocess installed post-removal script returned error exit status 1
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
SourcePackage: boinc
Title: package boinc-client (not installed) failed to install/upgrade: subprocess installed post-removal script returned error exit status 1

Revision history for this message
Steve Sargent (gs-sarge) wrote :
Revision history for this message
Daniel Hahler (blueyed) wrote :

Thank you for your bug report.

This should be fixed for Maverick, see bug 583434.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers