BAM: "inconsistant signing key" with manual "sync" (only on 10.04 system, also with backported package)

Bug #629740 reported by Skip Guenter
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: boinc

Selected Sync with BAM Account Manager from GUI Tools menu:

Fri 03 Sep 2010 11:18:24 AM CDT Fetching configuration file from http://bam.boincstats.com/get_project_config.php
Fri 03 Sep 2010 11:18:28 AM CDT Contacting account manager at http://bam.boincstats.com/
Fri 03 Sep 2010 11:18:30 AM CDT Account manager: BAM! User-ID: 23126
Fri 03 Sep 2010 11:18:30 AM CDT Account manager: BAM! Host-ID: 227430
Fri 03 Sep 2010 11:18:30 AM CDT Account manager: Number of BAM! connections: 118
Fri 03 Sep 2010 11:18:30 AM CDT Account manager contact succeeded
Fri 03 Sep 2010 11:18:30 AM CDT [error] Inconsistent signing key from account manager

I can disconnect from BAM:

Fri 03 Sep 2010 11:18:46 AM CDT Removing account manager info

And then reconnect and all is fine, often until I do a manual "sync" again:

Fri 03 Sep 2010 11:18:53 AM CDT Fetching configuration file from http://bam.boincstats.com/get_project_config.php
Fri 03 Sep 2010 11:19:02 AM CDT Contacting account manager at http://bam.boincstats.com/
Fri 03 Sep 2010 11:19:04 AM CDT Account manager: BAM! User-ID: 23126
Fri 03 Sep 2010 11:19:04 AM CDT Account manager: BAM! Host-ID: 227430
Fri 03 Sep 2010 11:19:04 AM CDT Account manager: Number of BAM! connections: 119
Fri 03 Sep 2010 11:19:04 AM CDT Account manager contact succeeded
Fri 03 Sep 2010 11:19:04 AM CDT Attaching to http://www.freehal.net/freehal_at_home/

This occurs ONLY on my Ubuntu v10.04 machines, not on the v9.10, v9.04 or (this one was) v8.10.
Example above is from a Xubuntu x64, v10.04 machine with v6.10.58 installed from the PPA but this also occurred with the default repository v6.10.17 version of BOINC on this machine (and an Ubuntu v10.04 machine I have).

skip@crunch20:~$ lsb_release -rd
Description: Ubuntu 10.04.1 LTS
Release: 10.04

skip@crunch20:~$ apt-cache policy boinc
boinc:
  Installed: (none)
  Candidate: 6.10.58+dfsg-2~lucid1
  Version table:
     6.10.58+dfsg-2~lucid1 0
        500 http://ppa.launchpad.net/pkg-boinc/ppa/ubuntu/ lucid/main Packages
     6.10.17+dfsg-3ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/universe Packages

Was surprised to not find this bug already here as it's been reported to all the Account Managers w/ v10.04.

Daniel Hahler (blueyed)
Changed in boinc (Ubuntu):
status: New → Triaged
importance: Undecided → Low
summary: - BAM inconsistant signing key
+ BAM: "inconsistant signing key" with manual "sync" (only on 10.04
+ system, also with backported package)
Revision history for this message
Arthur Rilke (arthurrilke) wrote :

I'm still experiencing this problem in Maverick.

Revision history for this message
Giovanni Dall'Olio (dalloliogm-gmail) wrote :

I confirm this bug, on a 10.10 machine and BAM manager 6.10.58.

Revision history for this message
Skip Guenter (skip) wrote :

More details in this thread. Looks like it's a corrupted .xml file being sent from BOINC.

http://boincstats.com/forum/forum_thread.php?id=5198

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

This bug is sol old, could you please try to reproduce it with a new boinc/ubuntu version?

Changed in boinc (Ubuntu):
status: Triaged → Incomplete
Revision history for this message
Brandt B (benedikt-benbra) wrote :

I can confirm a more sever version of this bug with Oneiric, using 6.12.33 x64.

After a fresh install of Oneiric I tried to use BAM as an account manager. However it keeps failing with the error message:

29-Nov-2011 20:56:24 [---] Bad signature for URL http://setiathome.berkeley.edu/
29-Nov-2011 20:56:24 [---] Bad signature for URL http://lhcathomeclassic.cern.ch/sixtrack/
29-Nov-2011 20:56:24 [---] Bad signature for URL http://boinc.bakerlab.org/rosetta/
29-Nov-2011 20:56:24 [---] Bad signature for URL http://www.worldcommunitygrid.org/

I attached the log to this post.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

@b1 could you try with 6.12.33+dfsg-1.1ubuntu0.1 from oneiric-proposed?

I'm pretty sure that upstream_strcpy_overlap.patch fixes the problem.

Revision history for this message
Brandt B (benedikt-benbra) wrote :

Thanks so much, this did the trick. Boinc is runnig :-) I had to reattach the project manager, but now things are running smoothly. No problems so far.

Good work

Changed in boinc (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments