package boinc-client 6.10.58+dfsg-2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1: chrt failure ("no such process")

Bug #629649 reported by romeom
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
High
Daniel Hahler

Bug Description

Binary package hint: boinc

no idea just was trying to install BOINC

ERROR:
Setting up boinc-client (6.10.58+dfsg-2) ...
 * Starting BOINC core client: boinc ESC[80G ^MESC[74G[ OK ]
 * Setting up scheduling for BOINC core client and children: ESC[80G chrt: failed to set pid 799's policy: No such process
chrt: failed to set pid 799's policy: No such process
chrt: failed to set pid 799's policy: No such process
invoke-rc.d: initscript boinc-client, action "start" failed.
dpkg: error processing boinc-client (--configure):
 subprocess installed post-installation script returned error exit status 1

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: boinc-client 6.10.58+dfsg-2
ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic x86_64
AptOrdering:
 boinc-client: Install
 boinc-manager: Install
 boinc-client: Configure
 boinc-manager: Configure
Architecture: amd64
Date: Fri Sep 3 11:32:57 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64 (20100901.1)
SourcePackage: boinc
Title: package boinc-client 6.10.58+dfsg-2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Revision history for this message
romeom (romeomont) wrote :
Revision history for this message
Daniel Hahler (blueyed) wrote :

I cannot confirm this (just tried with removing and re-installing boinc-client).

Maybe BOINC exits right after starting up for you already.

Please look into /var/lib/boinc-client/stderrdae.txt and stdoutdae.txt in the same directory (you'll have to do so with sudo, e.g. "sudo less /var/lib/boinc-client/stderrdae.txt").

Also, you should be able to re-trigger this error when fixing the installation, via "sudo apt-get install -f" - can you try/verify this, please?

description: updated
Changed in boinc (Ubuntu):
status: New → Triaged
importance: Undecided → High
Revision history for this message
Daniel Hahler (blueyed) wrote :

(also, only one of the BOINC child processes may have vanished.. the scheduling is being setup for those, too)

summary: package boinc-client 6.10.58+dfsg-2 failed to install/upgrade:
subprocess installed post-installation script returned error exit status
- 1
+ 1: chrt failure ("no such process")
Changed in boinc (Ubuntu):
milestone: none → ubuntu-10.10
Revision history for this message
Kai Presler (kaipresler) wrote :

Same issue for me as well.

Revision history for this message
Steffen Möller (moeller-debian) wrote : Re: [Bug 629649] Re: package boinc-client 6.10.58+dfsg-2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1: chrt failure ("no such process")

Hello,

On 09/05/2010 01:18 AM, Kai Presler wrote:
> Same issue for me as well.

we should then just test for the success of chrt and issue some warning message.

Cheers,

Steffen

Revision history for this message
Kai Presler (kaipresler) wrote :

What would need to be done to go about doing this?

Revision history for this message
Daniel Hahler (blueyed) wrote :

Kai, can you provide additional information as requested by me in comment 2 ( https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/629649/comments/2 )?

The fix would probably be to not fail when chrt fails (e.g. by adding "|| true" to the commands), but I would like to understand the root cause of this first.
As said, I cannot reproduce it myself.

Revision history for this message
Kai Presler (kaipresler) wrote : Re: [Bug 629649] Re: package boinc-client 6.10.58+dfsg-2 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1: chrt failure ("no such process")

Running "less" on both of those files returned nothing. I'll try and
re-install BOINC in a bit

On Sun, Sep 12, 2010 at 7:07 AM, Daniel Hahler <email address hidden> wrote:

> Kai, can you provide additional information as requested by me in
> comment 2 (
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/629649/comments/2
> )?
>
> The fix would probably be to not fail when chrt fails (e.g. by adding "||
> true" to the commands), but I would like to understand the root cause of
> this first.
> As said, I cannot reproduce it myself.
>
> --
> package boinc-client 6.10.58+dfsg-2 failed to install/upgrade: subprocess
> installed post-installation script returned error exit status 1: chrt
> failure ("no such process")
> https://bugs.launchpad.net/bugs/629649
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (630267).
>
> Status in “boinc” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: boinc
>
> no idea just was trying to install BOINC
>
> ERROR:
> Setting up boinc-client (6.10.58+dfsg-2) ...
> * Starting BOINC core client: boinc ESC[80G ^MESC[74G[ OK ]
> * Setting up scheduling for BOINC core client and children: ESC[80G
> chrt: failed to set pid 799's policy: No such process
> chrt: failed to set pid 799's policy: No such process
> chrt: failed to set pid 799's policy: No such process
> invoke-rc.d: initscript boinc-client, action "start" failed.
> dpkg: error processing boinc-client (--configure):
> subprocess installed post-installation script returned error exit status 1
>
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.10
> Package: boinc-client 6.10.58+dfsg-2
> ProcVersionSignature: Ubuntu 2.6.35-19.28-generic 2.6.35.3
> Uname: Linux 2.6.35-19-generic x86_64
> AptOrdering:
> boinc-client: Install
> boinc-manager: Install
> boinc-client: Configure
> boinc-manager: Configure
> Architecture: amd64
> Date: Fri Sep 3 11:32:57 2010
> ErrorMessage: subprocess installed post-installation script returned error
> exit status 1
> InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Beta amd64
> (20100901.1)
> SourcePackage: boinc
> Title: package boinc-client 6.10.58+dfsg-2 failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
>
>
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/629649/+subscribe
>

Revision history for this message
maik stolle (ms090780) wrote :

hi daniel,

1. stderrdae.txt is empty
2. stdoutdae.txt is full

3. until now no more crash
4. reinstall with force : until now no crash

regards maik

Revision history for this message
Daniel Hahler (blueyed) wrote :

While experimenting I could reproduce this somehow.

There was a boinc process running in the background still (for whatever reason, I cannot say), and starting a new one failed quickly like this:
==> stderrdae.txt <==
gstate.init() failed
Error Code: -180

==> stdoutdae.txt <==
18-Sep-2010 23:58:42 [---] [error] GUI RPC bind to port 31416 failed: 98

"is_running" did not report BOINC to be running already - because the PID obviously was not the same as in the PIDFILE anymore.

I will fix this by adding a message (via log_progress_msg, which is ignored on Ubuntu btw (bug 282638)!).

There have been quite a log of duplicated for this, so there really must be something triggering this, but I could not reproduce it a second time (after "sudo pkill -u boinc").

btw: using "pgrep -u boinc" and "pkill -u boinc" to see if BOINC is running already, or to more reliably kill all running processed (even if PIDFILE is wrong) might make sense.

Changed in boinc (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Daniel Hahler (blueyed)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 6.10.58+dfsg-3

---------------
boinc (6.10.58+dfsg-3) unstable; urgency=low

  [ Steffen Moeller ]
  * Bumped policy to 3.9.1.0
  * Added the first graphical libraries as suggested
    dependencies of the boinc-manager package.

  [ Daniel Hahler ]
  * debian/boinc-client.init: wait until BOINC has ended for "stop"
    action. This fixes the post-removal script to be run too early,
    when the system user might be still logged in and cannot be
    deleted (LP: #583434). It also fixes the "restart" action.
  * debian/boinc-client.init: schedule: do not fail if chrt fails
    (LP: #629649).
 -- Daniel Hahler <email address hidden> Sun, 26 Sep 2010 13:56:51 +0000

Changed in boinc (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers