AMD64 version does not work as BOINC does not support.

Bug #51948 reported by Tony Middleton
10
Affects Status Importance Assigned to Milestone
BOINC
Fix Released
Unknown
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: boinc-client

I have installed the standard boinc-client package on AMD64 Dapper. When the package contacts BOINC it returns the message "Message from server: platform 'x86_64-pc-linux-gnu' not found". It then defers for 24 hours.

This appears to be a known problem in that BOINC does not support AMD64. I have downloaded the 32bit version and that works fine. Perhaps the AMD64 package should actually be a 32bit version.

Regards

Tony

Changed in boinc:
status: Unknown → Unconfirmed
Revision history for this message
Frank S. Thomas (fst) wrote : Re: [Bug 51948] AMD64 version does not work as BOINC does not support.

On Wednesday 05 July 2006 12:55, Tony Middleton wrote:
> This appears to be a known problem in that BOINC does not support AMD64.

This will sound pedantic but the real problem is that BOINC _projects_ do not
support AMD64. In Debian there is now a package of the SETI@home application
for BOINC called boinc-app-seti. If you install this on AMD64 the BOINC core
client will use the application included in this package to crunch SETI@home
work units. So you are finally able to use the AMD64 version of the client.

- Frank

Revision history for this message
Tessa (unit3) wrote :

Is there any plans to include boinc-app-seti in backports or similar?

Changed in boinc:
status: Unconfirmed → Confirmed
Revision history for this message
Tony Middleton (ximera) wrote :

This seems to have been fixed. I am currently running standard feisty and everything is working.

Revision history for this message
Frank S. Thomas (fst) wrote : Re: [Bug 51948] Re: AMD64 version does not work as BOINC does not support.

On Friday 16 March 2007 19:25, Tony Middleton wrote:
> This seems to have been fixed. I am currently running standard feisty
> and everything is working.

What do you mean by fixed? That the boinc-app-seti package is now included in
feisty or that there are now more projects which support AMD64 natively?

Revision history for this message
Tony Middleton (ximera) wrote :

Sorry - I wasn't very clear.

All I meant was that I now run a standard feisty installation and this is running three BOINC projects, including SETI without taking any special actions.

Quite how it is doing it, I don't know. I don't have boinc-app-seti installed.

Revision history for this message
Jérôme Guelfucci (jerome-guelfucci-deactivatedaccount) wrote :

Do you still have this issue with the latest version of Ubuntu ?

Changed in boinc:
status: Unconfirmed → Needs Info
Revision history for this message
Tony Middleton (ximera) wrote :

See responses above. This problem seems to have been fixed in feisty.

Revision history for this message
Jérôme Guelfucci (jerome-guelfucci-deactivatedaccount) wrote :

I just wanted to be sure, I'm marking this as Fix Released, feel free to reopen if it happens again.

Changed in boinc:
status: Needs Info → Fix Released
Changed in boinc:
status: Confirmed → Fix Committed
Changed in boinc:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.