boinc-manager startup program fails to log in

Bug #48768 reported by TheCat
18
Affects Status Importance Assigned to Milestone
BOINC
Won't Fix
Unknown
boinc (Debian)
Fix Released
Unknown
boinc (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: boinc-manager

I added "boincmgr" to "System - Preferences - Sessions - Startup Programs." When logging in to Ubuntu, BOINC Manager starts and pops up an error which says:

BOINC Manager - Connection Error
The password you have provided is incorrect, please try again.

The BOINC Manager does not connect to any projects.

Note that it runs fine when started with the launcher in the menu. It would be nice if this could be fixed, so I could run BOINC automatically on login.

Revision history for this message
Frank S. Thomas (fst) wrote :

On Wednesday 07 June 2006 02:49, TheCat wrote:
> I added "boincmgr" to "System - Preferences - Sessions - Startup
> Programs." When logging in to Ubuntu, BOINC Manager starts and pops up
> an error which says:
>
> BOINC Manager - Connection Error
> The password you have provided is incorrect, please try again.
>
> Note that it runs fine when started with the launcher in the menu. It
> would be nice if this could be fixed, so I could run BOINC automatically
> on login.

The problem with adding boincmgr to "Startup Programs" is that the program
is executed in your home directory. When the BOINC Manager is started with
the launcher from the menu, it is executed in Ubuntu's (Debian's) default
BOINC data directory /var/lib/boinc-client.

The difference between these two scenarios is that in the latter boincmgr can
read the password (that is needed for controlling the client) from the
gui_rpc_auth.cfg file. In the first scenario boincmgr don't know where to
find this file.

The real solution to this issue is patching boincmgr to store the password in
it's config file, which was also requested in http://bugs.debian.org/369698

However, there are tow interim solutions for your problem:
1. Remove the password from /etc/boinc-client/gui_rpc_auth.cfg

or

2. Create a file called run_boincmgr which contains these tow lines:

#!/bin/sh
cd /var/lib/boinc-client && exec boincmgr "$@"

put it in your home directory, make it executable and use "./run_boincmgr"
instead of "boincmgr" in "Startup Programs".

Grüße,
Frank
--
The best way to accelerate any computer running Windows is at 9,81 m/s^2.

Changed in boinc:
status: Unconfirmed → Confirmed
Changed in boinc:
status: Unknown → Unconfirmed
Changed in boinc:
status: New → Confirmed
Changed in boinc:
status: Confirmed → Fix Released
Changed in boinc:
status: Unknown → Won't Fix
Revision history for this message
Greg A (etulfetulf) wrote :

Upstream (BOINC and Debian) have both refused to fix this (see the attached bug reports).

Daniel T Chen (crimsun)
Changed in boinc:
status: Confirmed → Won't Fix
Revision history for this message
Nicolás Alvarez (nicolas-alvarez) wrote :

Related, but not quite (since I suggest quite a different solution): #347651

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.