Please include libcudart.so in the boinc package (non-free/multiverse?)

Bug #410809 reported by Deactivated User
58
This bug affects 11 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Wishlist
Debian BOINC Maintainers

Bug Description

Binary package hint: boinc

Since libcudart.so has been removed from 6.4.5+dfsg, CUDA BOINC users have been forced to download the 50MB CUDA Toolkit to be able to use their GPU's to compute with BOINC. Could the maintainers of this package include libcudart.so in the main package, or at least could we have a new 'addon/extra/recommended' package such as boinc-cuda that does includes this file?

Revision history for this message
Andy Duffell (andy-duffell) wrote :

+1 for this. CUDA increases performance of compatible BOINC projects by a factor of two to ten. Using the latest CUDA-enabled BOINC package off their website results in about a fivefold improvement on my crummy Nvidia 8500GT. This is a massive boost, and CUDA should be enabled in Ubuntu packages as a matter of urgency IMO, especially given the high number of Linux users who will have Nvidia kit in their machines already.

Revision history for this message
Andy Schaefer (andy-schaef) wrote :

I totally agree. I went to the trouble of installing this in the prior release only to have it mucked back up.

Revision history for this message
mihasetina (miha-setina) wrote :

I secons,... that. please Add CUDA support

Changed in boinc (Ubuntu):
status: New → Confirmed
assignee: nobody → Debian BOINC Maintainers (pkg-boinc)
Revision history for this message
Nicolás Alvarez (nicolas-alvarez) wrote :

libcudart.so is proprietary code, it can't be included as part of the boinc package.

Redistributing CUDA runtime libraries in Ubuntu is probably possible (in the multiverse section), but I don't think it's the BOINC package maintainers' job to do that...

Revision history for this message
Andy Duffell (andy-duffell) wrote :

Ok fair enough. Any idea who might be willing to take a look at it?

Daniel Hahler (blueyed)
Changed in boinc (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Wishlist
summary: - Please include libcudart.so in the boinc package
+ Please include libcudart.so in the boinc package (non-free/multiverse?)
Revision history for this message
Steffen Möller (moeller-debian) wrote :

Is any of these packages packages here
libcuda1-ia32 - NVIDIA CUDA runtime library (32-bit)
libcuda1 - NVIDIA CUDA runtime library
libnvcuvid1 - NVIDIA CUDA nvcuvid runtime library
libnvidia-compiler-ia32 - NVIDIA runtime compiler library (32-bit)
libnvidia-compiler - NVIDIA runtime compiler library
providing what you need? Then those could be suggested,
indeed.

Revision history for this message
Greg Tippitt (gtippitt) wrote :

Pretty, Pretty, Please !!!
Please include libcudart.so in the boinc package (non-free/multiverse

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

is libcudart still not included?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I don't understand why do you need this library.

Doesn't boinc download automatically it when needed?

Revision history for this message
psl (slansky) wrote :

Boinc client doesn't download this library. When Boinc client is started, it check for library and when it is not find you cannot run project those use GPU. There is a message in the log when client is started.

This library is the key to open your nVidia GPU for boinc projects; some projects.

http://boinc.berkeley.edu/wiki/GPU_computing

Revision history for this message
CassieMoondust (cassie-lx) wrote :

The libraries libcuda.so and libOpenCL.so are in /usr/lib/nvidia-current.
Boinc should see this:

NVIDIA GPU 0: GeForce GTX 260 (driver version unknown, CUDA version 4000, compute capability 1.3, 896MB, 608 GFLOPS peak)

I'm just looking for new tasks from milkyway@home, but they had a hard servercrash so there are still no GPU workunits.
Hope i can test it soon.

Revision history for this message
Steffen Möller (moeller-debian) wrote : Re: [Bug 410809] Re: Please include libcudart.so in the boinc package (non-free/multiverse?)

On 11/01/2011 11:14 PM, Papamatti wrote:
> The libraries libcuda.so and libOpenCL.so are in /usr/lib/nvidia-current.
> Boinc should see this:
>
> NVIDIA GPU 0: GeForce GTX 260 (driver version unknown, CUDA version
> 4000, compute capability 1.3, 896MB, 608 GFLOPS peak)
>
> I'm just looking for new tasks from milkyway@home, but they had a hard servercrash so there are still no GPU workunits.
> Hope i can test it soon.

It does ... sometimes :)

Try

xhost +
sudo /etc/init.d/boinc stop
sudo /etc/init.d/boinc stop
sudo usermod -a -G boinc video

How about now?

Steffen

Revision history for this message
Steffen Möller (moeller-debian) wrote :

On 10/25/2011 01:51 PM, LocutusOfBorg wrote:
> I don't understand why do you need this library.
>
> Doesn't boinc download automatically it when needed?

There is a separate package for it but BOINC does not
(and should not IMHO) depend on it. I happily accept
patches that help the detection of any such setups.

I have added
 libcuda1, libcuda1-ia32 [amd64]
to the suggests of debian/control.

Better ideas?

Steffen

Revision history for this message
CassieMoondust (cassie-lx) wrote :

I'm running Boinc with GPU workunits without problems in oneiric ocelot.
I've done nothing, but only installing boinc and attach boinc to the milkyway-project.

Revision history for this message
Daniel Hahler (blueyed) wrote :

libcuda.so is shipped with nvidia-current / nvidia-current-updates in Ubuntu.

I don't know if just installing them is enough, when using the nouveau driver (instead of "nvidia") for display though.

Revision history for this message
Steffen Möller (moeller-debian) wrote :

On 12/02/2011 04:09 PM, Daniel Hahler wrote:
> libcuda.so is shipped with nvidia-current / nvidia-current-updates in
> Ubuntu.
>
> I don't know if just installing them is enough, when using the nouveau
> driver (instead of "nvidia") for display though.

The just released (to Debian unstable) version 7.0.2 of BOINC comes with
two additional packages, i.e. boinc-nvidia-cuda and boinc-amd-opencl.
Those drag in the additinal libraries they need, which should be equivalent
to your suggestion.

Best,

Steffen

Revision history for this message
Daniel Hahler (blueyed) wrote :

The dependencies are not satisfied in Ubuntu (different packages for the binary drivers).

See https://bugs.launchpad.net/608917 for the request to get Provides for the nvidia ones.

"fglrx-driver" gets provided by "fglrx" in Ubuntu, but amd-libopencl1 is not found. What would be required here?

Package: boinc-amd-opencl
Depends: ${misc:Depends}, boinc, fglrx-driver, amd-libopencl1

For the moment I could imagine to use nvidia-current/nvidia-current-updates for the nvidia dependencies and maybe just "fglrx" for boinc-amd-opencl, but in the long run there should not be a delta between Ubuntu and Debian just because of this.

Revision history for this message
Steffen Möller (moeller-debian) wrote :

Hello,

On 12/05/2011 09:07 PM, Daniel Hahler wrote:
> The dependencies are not satisfied in Ubuntu (different packages for the
> binary drivers).
>
> See https://bugs.launchpad.net/608917 for the request to get Provides
> for the nvidia ones.
That ones says not to be existing. Could you please just edit it? I do not
have the hardware.

> "fglrx-driver" gets provided by "fglrx" in Ubuntu,
I'll make it fglrx-driver|fglrx then. It is the same as for older versions of Debian.

> but amd-libopencl1 is not found. What would be required here?
This rather recent, I think. An alternative would be amd-app,
which is not in the distribution by provided in the forums.

> Package: boinc-amd-opencl
> Depends: ${misc:Depends}, boinc, fglrx-driver, amd-libopencl1
>
> For the moment I could imagine to use nvidia-current/nvidia-current-
> updates for the nvidia dependencies
Sounds good. Does Debian have the same one? Just go for it, please.

> and maybe just "fglrx" for boinc-
> amd-opencl,
That is not sufficient. fglrx is just the 3D driver. For OpenCL you need more.
Leave the AMD side to me. I can test that one.

> but in the long run there should not be a delta between
> Ubuntu and Debian just because of this.

The problem is more between versions of the distro, I presume.

Have many thanks!!

Steffen

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.0.7+dfsg-1

---------------
boinc (7.0.7+dfsg-1) unstable; urgency=low

  * New upstream version.
  * Fixed get-orig-source omitted "fi"

 -- Steffen Moeller <email address hidden> Sun, 01 Jan 2012 16:54:26 +0100

Changed in boinc (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers