boincmgr and boinccmd fail to authenticate - looking in wrong place

Bug #347651 reported by Nicolás Alvarez
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
boinc (Debian)
Fix Released
Unknown
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: boinc-manager

Right after installing boinc-client and boinc-manager, running boinccmd from a terminal makes it always say "Authentication failure", unless --passwd is given explicitly. Running boincmgr from a terminal (instead of the program launcher menu) make it unable to connect too, unless the password is given in the Connect to computer dialog.

Both of these problems go away if the commands are run from /var/lib/boinc-client or /etc/boinc-client, which is what the BOINC Manager program launcher does.

I think both programs should be modified to look in /etc/boinc-client/gui_rpc_auth.cfg. Currently, they only look in the current directory.

Revision history for this message
Nicolás Alvarez (nicolas-alvarez) wrote :

Note: I marked this bug as also affecting Debian, but I haven't reported it separately to Debian bug tracker.

Revision history for this message
Nicolás Alvarez (nicolas-alvarez) wrote :

Another confused user:

<buzz-cp> i'm trying to use the gui app
<buzz-cp> boincmgr
<buzz-cp> it gives me an error
<MTughan> What error?
<buzz-cp> well it just says Error in simple view
<PovAddict> prints that to console?
<buzz-cp> gui
<PovAddict> hmm
<PovAddict> post a screenshot?
<PovAddict> what Linux distro?
* PovAddict slaps Romulus with his /etc/init.d scripts
<buzz-cp> PovAddict: http://img149.imageshack.us/img149/5958/200904112013171440x900s.png
<buzz-cp> btw I am using Ubuntu 8.10
<PovAddict> BOINC installed from apt?
<buzz-cp> Yes
<PovAddict> the version from apt says "pre-release"? weird
<buzz-cp> ya
<PovAddict> try starting BOINC Manager from your desktop environment app launcher
<PovAddict> (like the K Menu on KDE, or the "Applications" menu on GNOME)
<PovAddict> instead of boincmgr on the console
<buzz-cp> using fluxbox, not in my menu
<PovAddict> ok
<PovAddict> then cd to /var/lib/boinc-client, and run boincmgr
<buzz-cp> oh
<MTughan> That file is where the boinc daemon looks for a connection password. The manager should pick it up automatically, but it only searches for the file in the current directory.
<MTughan> Hence why the manager has to/should be run from /var/lib/boinc-client.
<buzz-cp> awesome
<buzz-cp> I think I'm back on track
<buzz-cp> quick q tho: how to I run the command so that it is in the right path (i.e. to put in my ~/.fluxbox/menu file
<PovAddict> cd /var/lib/boinc-client && boincmgr

Changed in boinc (Debian):
importance: Undecided → Unknown
status: New → Unknown
Changed in boinc (Debian):
status: Unknown → New
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in boinc (Ubuntu):
status: New → Confirmed
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I made a patch for fixing this bug, basically I added "/var/lib/boinc-client" to common-defs.h file.

So now when you fopen the path should make boinc point to the right file, could you (when the build will be successful) try this version?
boinc - 7.0.47+dfsg-0~1007 in my ppa
https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

this version should fix this long stading bug

Revision history for this message
Dave (xclusive585) wrote : Re: [Bug 347651] Re: boincmgr and boinccmd fail to authenticate - looking in wrong place

I haven't tried 7.0.47 yet but can confirm 7.0.45 boincmgr won't connect to
boinc-client unless boincmgr is called from the desktop environment. Will
try 7.0.47 soon

-Dave
On Feb 3, 2013 8:45 AM, "LocutusOfBorg" <email address hidden>
wrote:

> I made a patch for fixing this bug, basically I added "/var/lib/boinc-
> client" to common-defs.h file.
>
> So now when you fopen the path should make boinc point to the right file,
> could you (when the build will be successful) try this version?
> boinc - 7.0.47+dfsg-0~1007 in my ppa
> https://code.launchpad.net/~costamagnagianfranco/+archive/boinc
>
> this version should fix this long stading bug
>
> --
> You received this bug notification because you are a member of Debian
> BOINC Maintainers, which is subscribed to boinc in Ubuntu.
> https://bugs.launchpad.net/bugs/347651
>
> Title:
> boincmgr and boinccmd fail to authenticate - looking in wrong place
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/347651/+subscriptions
>
> --
> pkg-boinc-devel mailing list
> <email address hidden>
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-boinc-devel
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Of course, I created the patch this morning :)
boinc is still "Waiting to build", please test revision 1007 asap (I'll test it too)

Revision history for this message
Dave (xclusive585) wrote :

Thanks for all your work locutus. I think most ubuntu based seti ppl are
using your ppas at this point. It means alot to me and is appreciated.

-Dave
On Feb 3, 2013 10:50 AM, "LocutusOfBorg" <email address hidden>
wrote:

> Of course, I created the patch this morning :)
> boinc is still "Waiting to build", please test revision 1007 asap (I'll
> test it too)
>
> --
> You received this bug notification because you are a member of Debian
> BOINC Maintainers, which is subscribed to boinc in Ubuntu.
> https://bugs.launchpad.net/bugs/347651
>
> Title:
> boincmgr and boinccmd fail to authenticate - looking in wrong place
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/347651/+subscriptions
>
> --
> pkg-boinc-devel mailing list
> <email address hidden>
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-boinc-devel
>

Changed in boinc (Debian):
status: New → Fix Released
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Please try this ppa and boinc 7.8.1, and let me know if the problem still occurs by setting back the status to "new"
https://launchpad.net/~costamagnagianfranco/+archive/ubuntu/boinc/

Changed in boinc (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.