project selection combo box too narrow for text

Bug #339822 reported by Jack Wasey
74
This bug affects 11 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Medium
Unassigned
Nominated for Karmic by Captain Chaos

Bug Description

Binary package hint: boinc-manager

See attached image.

Robert suspects (from a comment):
The .sh installer version and the karmic "boinc" package appear to be using different versions of wxWidgets (per Help>About BOINC Manager). Could that be causing it to work in one (.sh, using wxWidgets 2.8.7) and not the other (karmic, using 2.8.9 I think)?

Revision history for this message
Jack Wasey (jackwasey) wrote :
Revision history for this message
rww (rww) wrote :

This happens to me too on Jaunty (boinc v.6.2.18). Changing status to "Confirmed".

Changed in boinc:
status: New → Confirmed
Revision history for this message
rww (rww) wrote :

Workaround until this gets fixed:

<rww> ah, okay. What OS did you test it on? Ubuntu Intrepid, perchance?
<---> Jaunty
<rww> Did you run into https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/339822 ?
* rww has been meaning to figure out what's causing that, hasn't gotten around to it
<---> rww: Yes I did, but, just select a project then press back.
<---> it'll maximize :)
<---> select a project, push next, then press back

Revision history for this message
Daniel Hahler (blueyed) wrote :

Confirming. IIRC I've read about it somewhere before and it may be a toolkit bug, but I'm not sure.
Would be interesting to know if the current release (6.4.5) is affected by this as well.

Changed in boinc:
importance: Undecided → Medium
status: Confirmed → Triaged
Revision history for this message
Martin Beltov (mbeltov) wrote :

+1 from me

Revision history for this message
rww (rww) wrote :

I no longer get this bug with 6.4.5 for Linux x64 from http://boinc.berkeley.edu/download_all.php

Since Karmic currently has the same version as Jaunty (6.2.18), it's currently experiencing it too.

Debian Experimental has 6.4.5, and there appears to be a request that it be synced to Ubuntu open already: bug 311107

Revision history for this message
Daniel Hahler (blueyed) wrote :

Robert, then it's probably something specific to the patches from Debian/Ubuntu: I'm in the process of merging 6.4.5 from Debian and the bug is still there.. :/

Seems to be related to the build process or some patch (but there is nothing obvious in debian/patches/ - but what do I know?! ;)).

Have you built the upstream from source, or used the .sh-installer for the binary?

Revision history for this message
rww (rww) wrote :

Daniel: I used the .sh installer at http://boincdl.ssl.berkeley.edu/dl/boinc_6.4.5_x86_64-pc-linux-gnu.sh on Karmic (as I said earlier, that doesn't exhibit this bug). I haven't figured out how to compile BOINC from source, so I can't test that.

Revision history for this message
rww (rww) wrote :

The .sh installer version and the karmic "boinc" package appear to be using different versions of wxWidgets (per Help>About BOINC Manager). Could that be causing it to work in one (.sh, using wxWidgets 2.8.7) and not the other (karmic, using 2.8.9 I think)?

Revision history for this message
David Stansby (dstansby-deactivatedaccount) wrote : apport-collect data

Architecture: i386
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: boinc 6.4.5-1ubuntu1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.30-9.10-generic
Uname: Linux 2.6.30-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
David Stansby (dstansby-deactivatedaccount) wrote :
Revision history for this message
David Stansby (dstansby-deactivatedaccount) wrote :

Here's my info, and I'm still experiencing this bug. Robert's workaround works fine though.

Revision history for this message
Jeffrey Flaker (jflaker) wrote :

+1 - Makes it difficult to use attach to project

Daniel Hahler (blueyed)
description: updated
Revision history for this message
Frode Egeland (egeland) wrote :

AMD64, Karmic alpha

I confirm this happens for me also.

$ apt-cache policy boinc-client
boinc-client:
  Installed: 6.4.5+dfsg-2ubuntu1
  Candidate: 6.4.5+dfsg-2ubuntu1
  Version table:
 *** 6.4.5+dfsg-2ubuntu1 0
        500 http://ftp.iinet.net.au karmic/universe Packages
        100 /var/lib/dpkg/status

$ uname -a
Linux intersect 2.6.31-10-generic #32-Ubuntu SMP Thu Sep 10 23:29:56 UTC 2009 x86_64 GNU/Linux

Revision history for this message
xteejx (xteejx-deactivatedaccount) wrote :

This bug is current in Karmic Beta 1, same version as above: 6.4.5+dfsg-2ubuntu1

uname -a
Linux teej-laptop 2.6.31-11-generic #38-Ubuntu SMP Fri Oct 2 11:55:55 UTC 2009 i686 GNU/Linux

Revision history for this message
Martin Gamache (martin-gamache) wrote :

Curious. If you select one project, click "Next", then, after the wind has updated, you click "Back" you go back to the initial window, but without the display problem...

Revision history for this message
Martin Gamache (martin-gamache) wrote :

Ooops, I was about to post my other screenshot, but then I saw Robert's solution. Sorry!

Revision history for this message
rww (rww) wrote :

This bug is now fixed in Ubuntu Lucid, BOINC 6.10.17+dfsg-1ubuntu1. The combo box now has a normal width. Marking as Fix Released.

Changed in boinc (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Captain Chaos (launchpad-chaos) wrote :

Can this be fixed in Karmix as well?

Changed in boinc (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
Captain Chaos (launchpad-chaos) wrote :

Duh. I meant Karmic of course.

Revision history for this message
xteejx (xteejx-deactivatedaccount) wrote :

A fix was released for this, please do not change the status back.
It was marked Fix Released because the bug has been fixed in the latest development version of Ubuntu - Lucid Lynx.
If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [1] to bring the need to a developer's attention.
[1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in boinc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers