Please merge boinc 6.4.5-1 (universe) from Debian experimental (main)

Bug #311107 reported by Adrian Jadic
74
This bug affects 6 people
Affects Status Importance Assigned to Milestone
boinc (Debian)
Fix Released
Undecided
Unassigned
boinc (Ubuntu)
Wishlist
Unassigned

Related branches

Revision history for this message
Daniel Hahler (blueyed) wrote :

I would be nice to get this synced from Debian, but the current maintainer is looking for somebody to adopt maintainership of the package.
Anyway, triaging this bug and hopefully somebody (me?) helps out with updating the package soon.

Changed in boinc:
importance: Undecided → Wishlist
status: New → Triaged
Changed in boinc:
status: Unknown → New
Revision history for this message
Nicolás Alvarez (nicolas-alvarez) wrote :

Please note 6.4 has issues with scheduling and work fetch, related to the new GPU support. 6.6 made a lot of changes to improve the situation, and (so far, being still in development) it got worse :)

I think it's more important to make sure we have the latest 6.2.x version...

Revision history for this message
Martin Beltov (mbeltov) wrote :

+1 from me

Revision history for this message
AlanPo (janis-lode) wrote :

6.2 cannot use CUDA.
6.5 can, so please update repository.

Changed in boinc (Ubuntu):
status: Triaged → Confirmed
Revision history for this message
Hew (hew) wrote :

Boinc 6.4.5 is the latest stable version, so this is what should be added to the Ubuntu archive. The best way to do this is a merge from Debian experimental.

Changed in boinc (Ubuntu):
status: Confirmed → Triaged
description: updated
tags: added: upgrade
summary: - package "boinc" need update in repo
+ Please merge boinc 6.4.5-1 (universe) from Debian experimental (main)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 6.4.5-1ubuntu1

---------------
boinc (6.4.5-1ubuntu1) karmic; urgency=low

  * Merge from debian experimental (LP: #311107), remaining changes:
    - Bump build-depend on debhelper to install udev rules into
      /lib/udev/rules.d, add Breaks on udev to get correct version.
  * Provide meta package "boinc", which depends on boinc-client and
    boinc-manager (LP: #226612).
  * Add debian/patches/102_wxPanel_instead_wxControl_r17501.patch,
    picked from upstream trunk to fix FTBFS.

boinc (6.4.5-1) experimental; urgency=low

  * New upstream version
  * debian/patches:
    + 001_dont_install_ca-bundle.crt.patch refreshed
    + 002_remove_hardcoded_optimization.patch refreshed
    + 003_use_sensible-browser.patch
    + 004_exclude_sea.patch removed
    + 006_correct_catalog_path.patch added
  * debian/boinc-dev.install; upstream now calls `boinc' instead
    of `BOINC' the include/ dir
  * debian/boinc-dev.links; make BOINC point to boinc, this
    will save those who still point to the wrong PATH
  * debian/copyright:
    + Update upstream license from LGPL-2.1 to LGPL-3
    + update the file name on : api/textfont.[ch], client/stream.cpp,
      clientgui/wizardex.cpp
    + update copyright years on html/inc/geoip.inc and correct license
    + add copyright and license info for samples/glut/Roman.stroke,
      client/install-sh, samples/glut/win32_util.c,
      samples/glut/win32_x11.[ch], samples/glut/stroke.h,
      samples/glut/glut.h, samples/jpeglib/*
  * debian/rules:
    + don't install .mo files manually
    + correct .mo files perms
    + copy sea/*png file to clientgui/res and remove they on clean target
    + download export-boinc from git instead svn,
      use an ugly wget since git is not able to it by itself
    + delete empty locale dirs
  * debian/boinc-manager.install: usr/share/locale/* files added
  * debian/control, set standards-version to 3.8.1 ( no changes needed )

 -- Daniel Hahler <email address hidden> Sat, 23 May 2009 20:05:16 +0200

Changed in boinc (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Artur Rona (ari-tczew) wrote :

 boinc (6.4.5-1) experimental; urgency=low

   * New upstream version
   * debian/patches:
     + 001_dont_install_ca-bundle.crt.patch refreshed
     + 002_remove_hardcoded_optimization.patch refreshed
     + 003_use_sensible-browser.patch
     + 004_exclude_sea.patch removed
     + 006_correct_catalog_path.patch added
   * debian/boinc-dev.install; upstream now calls `boinc' instead
     of `BOINC' the include/ dir
   * debian/boinc-dev.links; make BOINC point to boinc, this
     will save those who still point to the wrong PATH
   * debian/copyright:
     + Update upstream license from LGPL-2.1 to LGPL-3
     + update the file name on : api/textfont.[ch], client/stream.cpp,
       clientgui/wizardex.cpp
     + update copyright years on html/inc/geoip.inc and correct license
     + add copyright and license info for samples/glut/Roman.stroke,
       client/install-sh, samples/glut/win32_util.c,
       samples/glut/win32_x11.[ch], samples/glut/stroke.h,
       samples/glut/glut.h, samples/jpeglib/*
   * debian/rules:
     + don't install .mo files manually
     + correct .mo files perms
     + copy sea/*png file to clientgui/res and remove they on clean target
     + download export-boinc from git instead svn,
       use an ugly wget since git is not able to it by itself
     + delete empty locale dirs
   * debian/boinc-manager.install: usr/share/locale/* files added
   * debian/control, set standards-version to 3.8.1 ( no changes needed )

 -- Rene Mayorga <email address hidden> Sat, 23 May 2009 13:29:08 -0600

Changed in boinc (Debian):
importance: Unknown → Undecided
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.