update/upgrade to boinc 6.2.25

Bug #294280 reported by Shirish Agarwal
2
Affects Status Importance Assigned to Milestone
Debian
New
Unknown
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

Hi there,
 Dunno if we first sync/merge the 6.2.18 and then sync/merge the 6.2.25

6.2.18 is already in debian.

This is the difference between 6.2.25 and 6.2.18 (debian-experimental)

 Giving below the changelog
between 6.2.25 and 6.2.18
(the one in experimental)

taken from http://boinc.berkeley.edu/dev/forum_thread.php?id=2518#20929

World Community Grid Beta BOINC 6.2.25
Fixed ability to read global preferences.

World Community Grid Beta BOINC 6.2.24
The core client will now use the lesser of the number of cores defined
by the existing max processors
settings or the new max percent of processor settings. This provides
backwards compatibility.

World Community Grid Beta BOINC 6.2.21 and 6.2.23
* Code so that the simple gui will display a message that the
applications are 'Paused: Application start
delayed' when the cc_config.xml contains the delay start option
* There was a bug on windows in the simple gui so that if the taskbar
was at the top of the screen, then
the slide show images would be offset and only partially shown. The
actual bug appears to be a wxWidgets
code, but a work around is implemented.
* The skin tags for organizations were fixed to have the proper
spelling of organization (they were
'organizaton')
* Allow settings in the cc_config.xml file to override the default
website to use for the network
connection test and for new application version check
* Add text to explain the difference between choosing between research
applications available at World
Community Grid and attaching to a new project (this only shows if the
user is using the WCG version of the
boinc client and if they are also attached to WCG) when they start the
process of attaching to a new
project

Within our installer, we have done the following

* Updated the WCG skin
* Add a custom action that will delete a version of the cc_config.xml
that is identical to the version
installed with a previous WCG version. The new cc_config.xml is only
installed if there is not currently a
cc_config.xml present.
* Modified how the ALLUSERS flag is set, so that the option that the
user selects for 'Allow all users on
this computer to manage', their choice is honored (details given to
Rom so he can fix the BOINC version)
* By default, the setup config screen now will show the box for "Allow
all users on this computer...." as
unchecked so that unless the user overrides, only they can control BOINC
* Modify the manager shortcut in the startup folder so that it is run
as 'normal' window instead of
'minimized'. This fixes the issue of the BOINC manager advanced view
opening super tiny after a reboot.
(details given to Rom so he can fix the BOINC version)
* Change the text on configuration screen:

"Use BOINC Screensaver" becomes "Use the World Community Grid - BOINC
Screensaver"
"Protected application execution" becomes "Run the research
applications under a restricted account. A
reboot may be required after installation. (Recommended)"
"Allow all users on this computer to control BOINC" becomes "Allow all
users on this computer to manage
the World Community Grid - BOINC software"
"Click Next to use these options." becomes "Click Next to use these
directories and the options checked."
"Click Advanced to customize options." becomes "Click Advanced to
change these settings."

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 8.10
Package: boinc-client 6.2.12-1
ProcEnviron:
 SHELL=/bin/bash
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_IN
SourcePackage: boinc
Uname: Linux 2.6.27-7-generic i686

Revision history for this message
Shirish Agarwal (shirishag75) wrote :
Revision history for this message
hhfeng (hanhua) wrote :

I am running Hardy on a Pentium 4.
I cannot update to the latest version of boinc-client (6.2.14-2~hardy1) from hardy-backports.

On this page
https://launchpad.net/ubuntu/+source/boinc/6.2.14-2~hardy1

It says

    * hardy sparc Successfully built (DONE)
    * hardy powerpc Successfully built (DONE)
    * hardy lpia Successfully built (DONE)
    * hardy ia64 Successfully built (DONE)
    * hardy i386 Chroot problem <=========
    * hardy hppa Successfully built (DONE)
    * hardy amd64 Successfully built (DONE)

Revision history for this message
Shirish Agarwal (shirishag75) wrote : Re: [Bug 294280] Re: update/upgrade to boinc 6.2.25

To add to what hhfeng says, there is no intrepid backport till yet as well :(
--
          Regards,
          Shirish Agarwal
  This email is licensed under http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
065C 6D79 A68C E7EA 52B3 8D70 950D 53FB 729A 8B17

Revision history for this message
Daniel Hahler (blueyed) wrote :

About the backport problem on i386: I've re-opened bug 277690. The Intrepid backport is bug 295884.
Anyway, that's not the point of this bug report, so please move any further discussion to those bugs. Thank you.

Revision history for this message
Daniel Hahler (blueyed) wrote :

Closing the bug as invalid and marking as duplicate of bug 311107.

Changed in boinc:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.