boinc_cmd --lookup_account doesn't work

Bug #147613 reported by Andreas Gustafsson
4
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Low
Unassigned

Bug Description

When I try to obtain an authenticator for attaching to the Rosetta project using
boinc_cmd, instead of printing the authenticator, boinc_cmd just prints "retval: 0":

  $ boinc_cmd --lookup_account http://boinc.bakerlab.org/rosetta/ email@domain password
  retval: 0

If I observe the generated network traffic using "tcpdump -s 1500 -A",
I can see that an XML file containing the authenticator is in fact being
returned by HTTP from boinc.bakerlab.org; it's just not getting printed by
boinc_cmd. If I cut and paste the authenticator from the tcpdump output
into the shell command line and run

  boinc_cmd --project_attach http://boinc.bakerlab.org/rosetta authenticator

(replacing "authenticator" with the actual hex string in the XML <authenticator>
tag), my machine successfully attaches to the project.

Revision history for this message
Daniel Hahler (blueyed) wrote :

I cannot confirm this on Ubuntu Hardy.

Which version of boinc-client do you have installed? 5.10.8-1 in Gutsy?

It's likely to be fixed for Hardy then.

$ boinc_cmd --lookup_account http://boinc.bakerlab.org/rosetta/ <email address hidden> password
status: Success
poll status: operation in progress
poll status: operation in progress
poll status: operation in progress
account key: ACCOUNTKEY

$ boinc_cmd --version
boinc_cmd, built from BOINC 5.10.30

Changed in boinc:
assignee: nobody → blueyed
importance: Undecided → Low
status: New → Incomplete
Revision history for this message
Andreas Gustafsson (gson) wrote :

> Which version of boinc-client do you have installed? 5.10.8-1 in Gutsy?

$ boinc_cmd --version
boinc_cmd, built from BOINC 5.4.11

This is on Ubuntu 7.04.

Revision history for this message
Daniel Hahler (blueyed) wrote :

Is this still a problem for you?
I would recommend trying to upgrade to Hardy, if not done already.

Changed in boinc:
assignee: blueyed → nobody
Revision history for this message
Andreas Gustafsson (gson) wrote :

> Is this still a problem for you?
> I would recommend trying to upgrade to Hardy, if not done already.

I can't easily upgrade this machine, for complicated Xen-related
reasons. If I ever do install Hardy, I will check whether the bug is
still there.

Revision history for this message
Matthew Woerly (nattgew) wrote :

Intrepid will be out in a couple weeks, so you might as well test that. I'll set this to Invalid, you can reopen it if you find the bug in an updated version.

Changed in boinc:
status: Incomplete → Invalid
Revision history for this message
Andreas Gustafsson (gson) wrote :

Confirmed fixed in 8.04.2 x86_64. The output from boinc_cmd --lookup_account now looks like this (account key value changed from the actual one, sorry :):

status: Success
poll status: operation in progress
poll status: operation in progress
poll status: operation in progress
account key: a38bbadf1ab8c62067cd676ac8426ce2

Revision history for this message
Daniel Hahler (blueyed) wrote :

Thank you for reporting back, Andreas.
Marking "Fix Released" instead of "Invalid".

Changed in boinc (Ubuntu):
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers