boinc-nvidia-cuda does not install nvidia-modprobe

Bug #1400021 reported by Peter D.
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Medium
Unassigned

Bug Description

On 14.04, 14.10, and possibly other versions, BOINC does not work with CUDA "out of the box". One of the reasons is that the meta package boinc-nvidia-cuda does not install nvidia-modprobe, a necessary package. The work around is, "sudo apt-get install nvida-modprobe" and reboot.

See, <https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/1320990> for confirmation.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: boinc-nvidia-cuda 7.2.42+dfsg-1
ProcVersionSignature: Ubuntu 3.13.0-41.70-generic 3.13.11.11
Uname: Linux 3.13.0-41-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CurrentDesktop: XFCE
Date: Sun Dec 7 15:39:55 2014
InstallationDate: Installed on 2014-02-20 (290 days ago)
InstallationMedia: Mythbuntu 12.04.4 "Precise Pangolin" - Release amd64 (20140204)
SourcePackage: boinc
UpgradeStatus: Upgraded to trusty on 2014-11-30 (6 days ago)

Revision history for this message
Peter D. (0123peter) wrote :
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I committed this on debian alioth git, and would be fixed in the following months with some (many) other gpu stuff fixes (and new packages aswell).

Altough I don't think this is a really boinc bug, but rather an nvidia one, I committed the fix

anonscm.debian.org/gitweb/?p=pkg-boinc/boinc.git;a=commitdiff;h=be4e9eb

thanks

Revision history for this message
Peter D. (0123peter) wrote :

Agreed, it is not a boinc bug, but isn't the point of a meta package to make-it-work for ordinary users who don't really know what is going on?

I think that you have done the right thing.

Thank you.

Adolfo Jayme (fitojb)
Changed in boinc (Ubuntu):
importance: Undecided → Medium
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in boinc (Ubuntu):
status: New → Confirmed
Revision history for this message
Peter D. (0123peter) wrote :

Sorry, typo. There was an "i" missing. The work around is, "sudo apt-get install nvidia-modprobe", and it is still necessary on Vivid Vervet.

Revision history for this message
Peter D. (0123peter) wrote :

Also need at least one of;
"sudo apt-get install python-pycuda", and
"sudo apt-get install python3-pycuda",
maybe both. I'm not sure.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi Peter, I do not understand why python-pycuda might be needed, there is no python code on manager/client, and the library loads an so file.

can you please explain more in detail?

Revision history for this message
Peter D. (0123peter) wrote :

Sorry, I have not done this very thoroughly.
When I installed Mythbuntu (14.04 LTS) some time ago I had to install a couple of non-obvious things to get boinc to use cuda and to display some pretty graphics. Recently I did a test install of Vivid Vervet and started boincmgr to see what would happen. Clicking on "activity" gave a drop down menu that was missing the GPU options. After a brief head scratch, an ah-ha moment, and a misguided effort to be helpful, I dashed of a note to say what I did last time. The pycuda stuff looked familiar, but might have been for the pretty graphics that some projects display - or maybe my memory is just failing.
Nvidia-modprobe, python-pycuda and python3-pycuda have been installed on my VV test partition and the drop down menu still does not display the GPU options. I will have another look at it and try to give some more sensible comments, but Wimbledon runs for another week, so I might not be that fast.
Thank you for your work.
bP

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

systemctl restart boinc-client might help since I guess systemd is starting the client before graphic drivers!

Revision history for this message
Peter D. (0123peter) wrote :

I'm not game to play with my main LTS system, but on my Vivid Vervet test partition
tab completion gave, systemctl restart boinc-client.service, which did not do anything obvious. BUT after installing 352 from <https://launchpad.net/~mamarley/+archive/ubuntu/nvidia> the drop down menu showed the GPU options and it asked to connect to a project, which it had completely failed to do earlier.

There seems to be a long standing bug involving dkms, nvidia, uvm and compiling two modules at once. The fix has been found, but not worked its way down to production systems yet. I will have to do a fresh install of Vivid Vervet to work out what is necessary and what is not. At this stage my guess is that the video driver upgrade is necessary and the python stuff is not.

Sorry for the delay, I have only one working computer and I use it to record and watch TV.

Hope this is helpful.

blind Pete

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.6.6+dfsg-2exp1

---------------
boinc (7.6.6+dfsg-2exp1) unstable; urgency=medium

  * Upload to experimental again, with the boinc-server-* packages.

 -- Gianfranco Costamagna <email address hidden> Wed, 29 Jul 2015 20:07:29 +0200

Changed in boinc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers