BOINC is always suspended, if set to work when IDLE

Bug #1274456 reported by Jussi
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
boinc (Debian)
Fix Released
Unknown
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

When set to work only when IDLE, BOINC never start to run. Despite of computer being IDLE for much longer than set to wait.
Logs say only (and this status never changes):
"Suspending Computation - computer is in use"

Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04). All 64 bit.
Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
BOINC 7.2.7 and earlier versions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in boinc (Ubuntu):
status: New → Confirmed
Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

The bug seems to be in client/hostinfo_unix.cpp.
According to documentation, right after XOpenDisplay call, there should be XScreenSaverQueryExtension call.
See http://linux.die.net/man/3/xscreensaverqueryextension .

So this:

        disp = XOpenDisplay(NULL);
         // XOpenDisplay may return NULL if there is no running X
         // or DISPLAY points to wrong/invalid display
         if(disp != NULL) {
             xssInfo = XScreenSaverAllocInfo();
         }

Should continue like this:

  if (XScreenSaverQueryExtension(disp, &event_base_return, &error_base_return) == false ) //Undeclared variables are integers.
            //Error handling here!

I would have investigate and test this by myself, but compiling documentation of BOINC is incorrect and workarounds presented on forums didn't help. I don't have the patience.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

building boinc?

sudo apt-get build-dep boinc

fakeroot debian/rules binary.

Done :)

(I'll look at the code tomorrow, thanks for the hint!)

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Official instructions ( http://boinc.berkeley.edu/trac/wiki/CompileClient ):

./_autosetup
./configure --disable-server --enable-client CXXFLAGS="-O3 "
make
cd packages/generic/sea/
make <-- this fails

And workarounds for that bug doesn't work either. I think I leave it to that.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

can you please download boinc from here and try again (to build)?
https://alioth.debian.org/anonscm/git/pkg-boinc/boinc.git

moreover do you have libxss on your system?

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

What is the path to sources exactly? Is this different from official git repo?

[ ] HEAD 20-Aug-2008 23:13 23
[ ] RENAMED-REF 25-Aug-2008 05:27 41
[DIR] branches/ 05-Nov-2013 12:29 -
[ ] config 05-Nov-2013 12:34 429
[ ] description 20-Aug-2008 23:13 16
[DIR] hooks/ 05-Nov-2013 12:38 -
[DIR] info/ 26-Jan-2014 22:05 -
[DIR] objects/ 26-Jan-2014 22:05 -
[ ] packed-refs 14-Jul-2013 17:33 44K
[DIR] refs/

I do have libxss, but -dev was missing. Last time it didn't create error message.
Also can you give me Xubuntu specific compilation instructions?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

git clone https://alioth.debian.org/anonscm/git/pkg-boinc/boinc.git

sudo apt-get build-dep boinc
cd boinc
dpkg-buildpackage

if you modify the source you can either:
dpkg-source --commit
dpkg-buildpackage
or
fakeroot debian/rules binary

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

$ dpkg-buildpackage
dpkg-buildpackage: source package boinc
dpkg-buildpackage: source version 7.2.33+dfsg-2
dpkg-buildpackage: source changed by Gianfranco Costamagna <snip>
dpkg-buildpackage: host architecture amd64
 dpkg-source --before-build boinc
dpkg-source: error: cannot read boinc/debian/control: No such file or directory
dpkg-buildpackage: error: dpkg-source --before-build boinc gave error exit status 2

Then I tried with "fakeroot debian/rules binary", after several minutes:

make[1]: Leaving directory `/home/jussi/boinc-source/boinc'
   debian/rules override_dh_install
make[1]: Entering directory `/home/jussi/boinc-source/boinc'
# boinc apps are built only together with the server
dh_install
dh_install: libboinc7 missing files (usr/lib/libboinc.so.*), aborting
make[1]: *** [override_dh_install] Error 255
make[1]: Leaving directory `/home/jussi/boinc-source/boinc'
make: *** [binary] Error 2

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

ok so can you please run (inside your git directory)
git checkout pristine-tar
git checkout upstream
git checkout master
git-buildpackage -sd

(you might need git-buildpackage command)

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

oh I found the issue, prease run git pull and try again

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote : Re: [Bug 1274456] Re: BOINC is always suspended, if set to work when IDLE

Non of the ways work. But "git-buildpackage -sd" seems to come most close.
For some reason it tries to make pgp signature with your key... not sure
how to fix.

Now running lintian...
E: boinc changes: bad-distribution-in-changes-file unstable
W: boinc source: newer-standards-version 3.9.5 (current is 3.9.4)
W: boinc-server-maker: package-name-doesnt-match-sonames libboinc-zip7
libsched7
N: 4 tags overridden (1 error, 3 warnings)
Finished running lintian.
Now signing changes and any dsc files...
 signfile boinc_7.2.33+dfsg-2.dsc Gianfranco Costamagna <snip>
gpg: skipped "Gianfranco Costamagna <snip>": secret key not available
gpg: /tmp/debsign.2zNXG4ti/boinc_7.2.33+dfsg-2.dsc: clearsign failed:
secret key not available
debsign: gpg error occurred! Aborting....
debuild: fatal error at line 1280:
running debsign failed
gbp:error: Couldn't run 'debuild -i -I -sd': debuild -i -I returned 29

On Mon, Feb 3, 2014 at 12:46 PM, LocutusOfBorg <
<email address hidden>> wrote:

> oh I found the issue, prease run git pull and try again
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1274456
>
> Title:
> BOINC is always suspended, if set to work when IDLE
>
> Status in "boinc" package in Ubuntu:
> Confirmed
>
> Bug description:
> When set to work only when IDLE, BOINC never start to run. Despite of
> computer being IDLE for much longer than set to wait.
> Logs say only (and this status never changes):
> "Suspending Computation - computer is in use"
>
> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04). All
> 64 bit.
> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
> BOINC 7.2.7 and earlier versions.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

sorry instead of -sd you need "-us -uc"

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

OK, now it compiles, but the missing XScreenSaverQueryExtension call is
still missing. And if I add it, I cannot compile the source anymore,
because of git errors. No actual errors.

How I do compile the code without need for commit/publish/push/etc the
changes I made?

On Mon, Feb 3, 2014 at 5:42 PM, LocutusOfBorg <<email address hidden>
> wrote:

> sorry instead of -sd you need "-us -uc"
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1274456
>
> Title:
> BOINC is always suspended, if set to work when IDLE
>
> Status in "boinc" package in Ubuntu:
> Confirmed
>
> Bug description:
> When set to work only when IDLE, BOINC never start to run. Despite of
> computer being IDLE for much longer than set to wait.
> Logs say only (and this status never changes):
> "Suspending Computation - computer is in use"
>
> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04). All
> 64 bit.
> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
> BOINC 7.2.7 and earlier versions.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Never mind I think --ignore-git-new does it...

On Mon, Feb 3, 2014 at 7:19 PM, Jussi Lahtinen <email address hidden>wrote:

> OK, now it compiles, but the missing XScreenSaverQueryExtension call is
> still missing. And if I add it, I cannot compile the source anymore,
> because of git errors. No actual errors.
>
> How I do compile the code without need for commit/publish/push/etc the
> changes I made?
>
>
> On Mon, Feb 3, 2014 at 5:42 PM, LocutusOfBorg <
> <email address hidden>> wrote:
>
>> sorry instead of -sd you need "-us -uc"
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1274456
>>
>> Title:
>> BOINC is always suspended, if set to work when IDLE
>>
>> Status in "boinc" package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> When set to work only when IDLE, BOINC never start to run. Despite of
>> computer being IDLE for much longer than set to wait.
>> Logs say only (and this status never changes):
>> "Suspending Computation - computer is in use"
>>
>> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04).
>> All 64 bit.
>> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
>> BOINC 7.2.7 and earlier versions.
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>>
>
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

you can avoid the git-buildpackage problem by running dpkg-source --commit and creating a patch file, or run fakeroot debian/rules clean binary after you patched the file

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

OK, I tried to commit my changes, but I assume it didn't succeed.
So I attached patch for my changes.

And now with my patch, everything works as expected. At least on my system.

On Mon, Feb 3, 2014 at 7:27 PM, Jussi Lahtinen <email address hidden>wrote:

> Never mind I think --ignore-git-new does it...
>
>
> On Mon, Feb 3, 2014 at 7:19 PM, Jussi Lahtinen <email address hidden>wrote:
>
>> OK, now it compiles, but the missing XScreenSaverQueryExtension call is
>> still missing. And if I add it, I cannot compile the source anymore,
>> because of git errors. No actual errors.
>>
>> How I do compile the code without need for commit/publish/push/etc the
>> changes I made?
>>
>>
>> On Mon, Feb 3, 2014 at 5:42 PM, LocutusOfBorg <
>> <email address hidden>> wrote:
>>
>>> sorry instead of -sd you need "-us -uc"
>>>
>>> --
>>> You received this bug notification because you are subscribed to the bug
>>> report.
>>> https://bugs.launchpad.net/bugs/1274456
>>>
>>> Title:
>>> BOINC is always suspended, if set to work when IDLE
>>>
>>> Status in "boinc" package in Ubuntu:
>>> Confirmed
>>>
>>> Bug description:
>>> When set to work only when IDLE, BOINC never start to run. Despite of
>>> computer being IDLE for much longer than set to wait.
>>> Logs say only (and this status never changes):
>>> "Suspending Computation - computer is in use"
>>>
>>> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04).
>>> All 64 bit.
>>> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
>>> BOINC 7.2.7 and earlier versions.
>>>
>>> To manage notifications about this bug go to:
>>>
>>> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>>>
>>
>>
>

Changed in boinc (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Oh nice replying via email doesn't hide email addresses. Also "edit" feature is missing.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Upstream has accepted your patch, unfortunately they gave credits to me :(

http://boinc.berkeley.edu/gitweb/?p=boinc-v2.git;a=commitdiff;h=0811886cbb1d282376e2dfd017ab39e34cd7d8ea

but you will have your line in the debian patch and changelog :)

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Don't worry about that, I'm happy when I'm finally able to use BOINC with my required preferences.

Changed in boinc (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

And suddenly BOINC is back in its old behavior. I don't think I changed anything. At least I can't remember. Maybe there was reboot between time it worked and when it stop working.

Now when I run this command (not sure this is good test):
$ sudo su boinc -c 'sh -c 'sleep 2;xprintidle > /mnt/Data/test.txt''

I always get very low numbers, meaning it's not IDLE.
As myself:
$ sh -c 'sleep 2;xprintidle > /mnt/Data/test.txt'

I have that 2s IDLE time.

So the code used now in boinc seems to work separately, but it doesn't work in boinc. Why?

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

OK this:
$ sudo su boinc -c 'sh -c 'sleep 2;xprintidle > /mnt/Data/test.txt''

Seems to be same as:
$ sudo su boinc -c 'sh -c 'baboon;xprintidle > /mnt/Data/test.txt''

So, only xprintidle is executed and the test is therefore invalid.

But for sure, xprintidle prints correct IDLE time when tested in terminal
and so BOINC should work. But it doesn't, what is the difference?

On Tue, Feb 4, 2014 at 3:35 AM, Jussi <email address hidden> wrote:

> And suddenly BOINC is back in its old behavior. I don't think I changed
> anything. At least I can't remember. Maybe there was reboot between time
> it worked and when it stop working.
>
> Now when I run this command (not sure this is good test):
> $ sudo su boinc -c 'sh -c 'sleep 2;xprintidle > /mnt/Data/test.txt''
>
> I always get very low numbers, meaning it's not IDLE.
> As myself:
> $ sh -c 'sleep 2;xprintidle > /mnt/Data/test.txt'
>
> I have that 2s IDLE time.
>
> So the code used now in boinc seems to work separately, but it doesn't
> work in boinc. Why?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1274456
>
> Title:
> BOINC is always suspended, if set to work when IDLE
>
> Status in "boinc" package in Ubuntu:
> Confirmed
>
> Bug description:
> When set to work only when IDLE, BOINC never start to run. Despite of
> computer being IDLE for much longer than set to wait.
> Logs say only (and this status never changes):
> "Suspending Computation - computer is in use"
>
> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04). All
> 64 bit.
> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
> BOINC 7.2.7 and earlier versions.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

can you please try this patch?
http://boinc.berkeley.edu/gitweb/?p=boinc-v2.git;a=commitdiff;h=5a22c7684e01dc24e1bf265bf88dc181fe0b5587

I asked David to refactor and to add error checks to the code :)

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

git apply gives this:

boinc-v2.git-5a22c7684e01dc24e1bf265bf88dc181fe0b5587.patch:148: trailing
whitespace.
        }
error: patch failed: client/hostinfo_unix.cpp:1891
error: client/hostinfo_unix.cpp: patch does not apply

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

$ patch < boinc-v2.git-5a22c7684e01dc24e1bf265bf88dc181fe0b5587.patch
patching file client/hostinfo_unix.cpp
Hunk #1 FAILED at 1891.
1 out of 1 hunk FAILED -- saving rejects to file
client/hostinfo_unix.cpp.rej

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I think the best way can be to replace the function from the file in the trunk tree or to replace the whole file!

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Oh, of course...
Now everything seems to work again. But, let's wait day or two and I will
report.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

thanks! Unfortunately this bug seem to be have been fixed, reopened, fixed, reopened... and so on!

my thought is that xserver is really too buggy to be handled in all the single cases, altough the original code seems to be working so nicely and I didn't experience this bug anymore since the last time I fixed this bug...

But this is an highlander bug, and it has many respawn possibilities... :(

Changed in boinc (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

It seems it's reboot what makes BOINC stop working (same old, computing is
suspended). However I can fix this manually with following commands:
$ sudo /etc/init.d/boinc-client stop
$ sudo /etc/init.d/boinc-client start

Race condition at reboot? Ideas?

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

If I recall correctly, this wasn't case with earlier tests. So maybe we are
dealing with two different bugs, and other is now fixed.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

yes, two different bugs, this one is fixed.

My opinion is:
boinc init script is called before gui initialization, so the calls fails, when you restart it everything works normally.

Something in init script should be set in order to make it run AFTER the gdm/lightdm/* engine.

this is a long stading bug, that prevents some graphic card to be detected without a reboot, and I don't know how to properly fix it

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Start section of the init script starts with command "sleep 10". So I
assume init scripts are executed with multiple threads, and 10s just isn't
enough. I'll edit it to 20s, and do some more testing.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

for some reasons the sleep gets ignored, even 2 minutes doesn't change anything (IIRC)

there is some sort of dependencies, I need to copy from some other program that needs a gui to be started (but I never found one)

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Yes, sleep commands are ignored. And in fact init scripts are read in
strict order and thus probably not executed parallel. I made boinc's init
script to start last, but it starts apparently still too soon.

So, how about writing UpStart script for Linux desktops?
http://buddylindsey.com/getting-started-with-and-understanding-upstart-scripts-on-ubuntu/
http://geeknme.wordpress.com/2009/10/15/getting-started-with-upstart-in-ubuntu/
http://upstart.ubuntu.com/cookbook/

Maybe we could make boinc start when xserver lays lock file? IE boinc would
start when /tmp/.X11-unix/X0 would appear.
Better ideas?

This would happen with line:
start on file FILE=/tmp/.X11-unix/X0 EVENT=create

UpStart scripts are in /etc/init/*.conf.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

the problem is that boinc can run also in headless servers... How can we check this?

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Do you mean that /tmp/.X11-unix/X0 isn't created in headless servers? Isn't
there anything xserver does when it's ready? DBus signal? Pid file..?

Can we put boinc startup script to /etc/X11/Xsession.d and remove it from
runlevels 1,2,3,4,5 ?

On Thu, Feb 6, 2014 at 2:53 PM, LocutusOfBorg <<email address hidden>
> wrote:

> the problem is that boinc can run also in headless servers... How can we
> check this?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1274456
>
> Title:
> BOINC is always suspended, if set to work when IDLE
>
> Status in "boinc" package in Ubuntu:
> In Progress
>
> Bug description:
> When set to work only when IDLE, BOINC never start to run. Despite of
> computer being IDLE for much longer than set to wait.
> Logs say only (and this status never changes):
> "Suspending Computation - computer is in use"
>
> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04). All
> 64 bit.
> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
> BOINC 7.2.7 and earlier versions.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

ll /tmp/.X11-unix/
total 140
drwxrwxrwt 2 root root 4096 Mar 15 2013 ./
drwxrwxrwt 12 root root 135168 Feb 6 04:41 ../

no, seem that on headless it isn't created.

the second option seems to be feasible, can you please provide a patch or test if it works on your system?
I'll give a try on a headless server if you succeed on your system (and maybe provide a patch :p)

thanks for the hint! sounds promising!

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Script didn't get executed from /etc/X11/Xsession.d or the permission for
execution was wrong (start script was not executed as root). There is also
desktop-session-start event for upstart scripts... maybe it would be more
standard.

I'll look more about how to write upstart scripts.

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

I'm doing some tests and I wonder if there is test project for BOINC (with
actual mock up tasks)? So that I don't have to mess with real projects with
my VM.

I don't quite understand Upstart documentation.
http://upstart.ubuntu.com/cookbook/#expect

I made upstart script to launch the old init script, and it seems to be
very hard to tell how many forks there will be. Also it seems upstart
allows max two forks... maybe this isn't way to do it.

Ubuntu doesn't make difference between runlevels 2, 3, 4 and 5... So right
now I don't see other options than find another way to detect idle status
or find yet another way to wait until X is ready.

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Nevermind I think I found solution. I'll post patch in few days.

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Git refuses to apply my changes, so I try to start from begin. And now your
git repo seems to be down. So I can't do anything.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

You need to register on alioth and apply for the pkg-boinc team after adding your key to alioth.

If you want to start contributing you might want to do this, otherwise you can export the commit as a patch with
git format-patch -1
and post here the patch.

I'll review and apply myself!

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

I'm simply trying to clone the code. Yesterday it didn't connect at all,
now it seem to do something for awhile and then refuse.

$ git clone https://alioth.debian.org/anonscm/git/pkg-boinc/boinc.git
Cloning into 'boinc'...
error: Failed connect to alioth.debian.org:443; Connection refused
(curl_result = 7, http_code = 0, sha1 =
9ca5ece5247aa46d788a67335e9596d23dd08ece)
error: Unable to find 9ca5ece5247aa46d788a67335e9596d23dd08ece under
https://alioth.debian.org/anonscm/git/pkg-boinc/boinc.git
Cannot obtain needed object 9ca5ece5247aa46d788a67335e9596d23dd08ece
while processing commit 15d3ea6935a0fb119f260cedeec53965dc5472a3.
error: Fetch failed.

Jussi

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

OK for some unknown reason cloning was successful now.

Is there easy way to resolve this?

$ git-buildpackage -su -uc --git-ignore-new
...
patching file client/hostinfo_unix.cpp
Hunk #1 FAILED at 1867.
Hunk #2 succeeded at 1989 (offset 66 lines).
1 out of 2 hunks FAILED
dpkg-source: info: fuzz is not allowed when applying patches
dpkg-source: info: if patch 'fix-lp-1274456.patch' is correctly applied by
quilt, use 'quilt refresh' to update it
dpkg-source: info: restoring quilt backup files for fix-lp-1274456.patch
dpkg-source: error: LC_ALL=C patch -t -F 0 -N -p1 -u -V never -g0 -E -b -B
.pc/fix-lp-1274456.patch/ --reject-file=- <
boinc/debian/patches/fix-lp-1274456.patch gave error exit status 1
dpkg-buildpackage: error: dpkg-source -i -I -su --before-build boinc gave
error exit status 2
debuild: fatal error at line 1361:
dpkg-buildpackage -rfakeroot -D -us -uc -i -I -su failed
gbp:error: Couldn't run 'debuild -i -I -su -uc': debuild -i -I returned 29

Git seems to be extremely glumsy. I don't even understand why I have to
deal with all these, when I just want to build it for test.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Alioth seems to be down again.

Anyway please read the README.source in debian folder. (the quilt part)

after that please do:
git stash
rm .pc -rf
quilt push -a
do your changes here
dpkg-source --commit (if you changed the source tree)

otherwise if you only changed the debian directory
quilt pop -a
git diff (will show you the changes)
git commit -a -m "your message"
git format patch -1

if you added some new files you need to add them git add debian/file before commit

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

I thought that if I prevent BOINC to touch to X until it's ready,
everything would work. But it doesn't seem to work.
However, maybe that same piece of code (see attachment) could be used to
restart BOINC after X is ready? Ideas?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

mmm don't really know...
what does this code do? I mean, does this code really slow down boinc to start? did you debug it?

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

IsXReady function returns true when X is started. The static boolean
XisReady is just there to make sure IsXReady function is not execute after
X is ready. So it shouldn't slow down idle detection, and the function is
used only if X is expected to be in use (HAVE_XSS). So right now that code
only prevent idle detection code to be run when X is not ready. Because I
think the problem arises when X related things are initialized without X
being ready... apparently not that simple.

I tried it by changing string "Xorg" to "gnuchess", and yes BOINC client
sleeps until gnuchess was launched. So I think the code does what I meant.
My idea just isn't working, not sure why.

But, maybe similarly when BOINC start it would only sleep until X is ready
and then restart.
I will look if BOINC code has function for restart (at least it does make
fork/clone) or anything like that to make things easy.
If you know any relevant details, please let me know.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I really don't know... anyway one problem is that "HAVE_XSS" is defined at build time, not at runtime, so it is always defined even for servers.

I don't really know about your code, anyway I think would be nice to follow-up on boinc-dev mail list, I think it is the most appropriate ml for reporting and asking for help

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.2.42+dfsg-1

---------------
boinc (7.2.42+dfsg-1) unstable; urgency=medium

  * New upstream hotfix release.

 -- Gianfranco Costamagna <email address hidden> Sat, 01 Mar 2014 11:34:55 +0100

Changed in boinc (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

This bug has been closed since I forgot to remove the "closes" in the changelog...
How can we progress on this? I don't remember what was the issue on the boinc-dev mail list

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

I initiated the issue in dev-list and it seems to be completely stalled.
I don't mean to offense, but I really don't believe it has been fixed.

Changed in boinc (Ubuntu):
status: Fix Released → In Progress
Changed in boinc (Ubuntu):
status: In Progress → Confirmed
Revision history for this message
Patrick (patrick-w) wrote :

I've been trying to fix this for days and just found this bug report. I'm on Ubuntu 14.04LTS with BOINC 7.2.42 yet this has still not been fixed. It's really an infuriating bug and from what I can tell it's been running for the last six years (this bug report was linked to from another older one.

Can there be any hope of a fix soon?

In my case, it would neither suspend or resume upon activity or idle, although switching to the advanced view of BOINC seems to have made it suspend when I move the mouse, but it never resumes on idle thereafter.

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Patrick, there is no fix and it's not even currently under work. The problem seems to be in race condition at system startup (boinc starts before some component of X is ready). I'm out of ideas and mainly out of energy to work on this right now.
Partly because BOINC is badly managed (official sources doesn't even compile) and then the git hell.

Revision history for this message
Greggth (greggth) wrote :

Hey,
wow, Jussi, you have put in great effort trying to fix this!
So I was just having this problem on Ubuntu 14.04.1LTS with boinc 7.2.42 and was disappointed to see how it doesn't look like this issue has been resolved. But, I think I just found a fix, and it'll need to bake a little longer to see if it really works.
Basically, I installed xprintidle and restarted the boinc mgr and boinc client. Now, with it set to require 1 minute idling, it seems like it's working.

Install xprintidle:
sudo apt-get install xprintidle
Restart the boincmgr and boinc-client:
sudo /etc/init.d/boinc-client stop
sudo /etc/init.d/boinc-client start

-G

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

doesn't make any difference, since the tool is just to know the amount of idle time on the system.

However upstream changed completely the idle time code, and now they rely on /dev/input. So I presume with the next release this bug will be fixed
"7.4.18+dfsg-1" should be fine.

In a few hours will be available for testing on this ppa:
https://code.launchpad.net/~costamagnagianfranco/+archive/ubuntu/boinc

Revision history for this message
Greggth (greggth) wrote :

Ah, so I was just hitting a simple configuration issue then?

Glad to hear that the idle detection is being upgraded!

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

This will fix the problem until your computer is restarted again:
sudo /etc/init.d/boinc-client stop
sudo /etc/init.d/boinc-client start

So, it's fix if you are willing to do it every time you turn your computer
on. This is because it will resolve the race condition that happens in
start up.

On Fri, Sep 5, 2014 at 12:18 PM, Greggth <email address hidden> wrote:

> Ah, so I was just hitting a simple configuration issue then?
>
> Glad to hear that the idle detection is being upgraded!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1274456
>
> Title:
> BOINC is always suspended, if set to work when IDLE
>
> Status in “boinc” package in Ubuntu:
> Confirmed
>
> Bug description:
> When set to work only when IDLE, BOINC never start to run. Despite of
> computer being IDLE for much longer than set to wait.
> Logs say only (and this status never changes):
> "Suspending Computation - computer is in use"
>
> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04). All
> 64 bit.
> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
> BOINC 7.2.7 and earlier versions.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

> However upstream changed completely the idle time code, and now they rely
> on /dev/input. So I presume with the next release this bug will be fixed
> "7.4.18+dfsg-1" should be fine.
>
> In a few hours will be available for testing on this ppa:
> https://code.launchpad.net/~costamagnagianfranco/+archive/ubuntu/boinc
>

Good to hear progress about this issue. I have not been able to put more
time on this, but I will test the new version. However latest build seems
to have failed.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

just the armhf build failed, and this is because of a buildd system bug. I retried the build, but both i386 and amd64 should be fine

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Now I have constantly running boinc with completely fucked up scheduler
clogging my computer. And no possibility of uninstall..? How?

$ sudo apt-get purge boinc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'boinc' is not installed, so not removed

On Fri, Sep 5, 2014 at 7:58 PM, LocutusOfBorg <<email address hidden>
> wrote:

> just the armhf build failed, and this is because of a buildd system bug.
> I retried the build, but both i386 and amd64 should be fine
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1274456
>
> Title:
> BOINC is always suspended, if set to work when IDLE
>
> Status in “boinc” package in Ubuntu:
> Confirmed
>
> Bug description:
> When set to work only when IDLE, BOINC never start to run. Despite of
> computer being IDLE for much longer than set to wait.
> Logs say only (and this status never changes):
> "Suspending Computation - computer is in use"
>
> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04). All
> 64 bit.
> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
> BOINC 7.2.7 and earlier versions.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

Ah, of course the package is boinc-client... but as said, the problem has
gone only worse.

On Fri, Sep 5, 2014 at 10:56 PM, Jussi Lahtinen <email address hidden>
wrote:

> Now I have constantly running boinc with completely fucked up scheduler
> clogging my computer. And no possibility of uninstall..? How?
>
> $ sudo apt-get purge boinc
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package 'boinc' is not installed, so not removed
>
>
>
> On Fri, Sep 5, 2014 at 7:58 PM, LocutusOfBorg <
> <email address hidden>> wrote:
>
>> just the armhf build failed, and this is because of a buildd system bug.
>> I retried the build, but both i386 and amd64 should be fine
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/1274456
>>
>> Title:
>> BOINC is always suspended, if set to work when IDLE
>>
>> Status in “boinc” package in Ubuntu:
>> Confirmed
>>
>> Bug description:
>> When set to work only when IDLE, BOINC never start to run. Despite of
>> computer being IDLE for much longer than set to wait.
>> Logs say only (and this status never changes):
>> "Suspending Computation - computer is in use"
>>
>> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04).
>> All 64 bit.
>> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
>> BOINC 7.2.7 and earlier versions.
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>>
>
>

Revision history for this message
Jussi (jussi-lahtinen-gmail) wrote :

No, still cannot uninstall:

The following packages will be REMOVED:
  boinc-client*
0 upgraded, 0 newly installed, 1 to remove and 3 not upgraded.
After this operation, 1 695 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 718132 files and directories currently installed.)
Removing boinc-client (7.4.18+dfsg-0~1283~ubuntu14.04.1) ...
Purging configuration files for boinc-client
(7.4.18+dfsg-0~1283~ubuntu14.04.1) ...
rm: cannot remove ‘/var/lib/boinc-client’: Directory not empty
dpkg: error processing package boinc-client (--purge):
 subprocess installed post-removal script returned error exit status 1
Processing triggers for man-db (2.6.7.1-1) ...
Errors were encountered while processing:
 boinc-client
E: Sub-process /usr/bin/dpkg returned an error code (1)

On Fri, Sep 5, 2014 at 10:58 PM, Jussi Lahtinen <email address hidden>
wrote:

> Ah, of course the package is boinc-client... but as said, the problem has
> gone only worse.
>
>
> On Fri, Sep 5, 2014 at 10:56 PM, Jussi Lahtinen <email address hidden>
> wrote:
>
>> Now I have constantly running boinc with completely fucked up scheduler
>> clogging my computer. And no possibility of uninstall..? How?
>>
>> $ sudo apt-get purge boinc
>> Reading package lists... Done
>> Building dependency tree
>> Reading state information... Done
>> Package 'boinc' is not installed, so not removed
>>
>>
>>
>> On Fri, Sep 5, 2014 at 7:58 PM, LocutusOfBorg <
>> <email address hidden>> wrote:
>>
>>> just the armhf build failed, and this is because of a buildd system bug.
>>> I retried the build, but both i386 and amd64 should be fine
>>>
>>> --
>>> You received this bug notification because you are subscribed to the bug
>>> report.
>>> https://bugs.launchpad.net/bugs/1274456
>>>
>>> Title:
>>> BOINC is always suspended, if set to work when IDLE
>>>
>>> Status in “boinc” package in Ubuntu:
>>> Confirmed
>>>
>>> Bug description:
>>> When set to work only when IDLE, BOINC never start to run. Despite of
>>> computer being IDLE for much longer than set to wait.
>>> Logs say only (and this status never changes):
>>> "Suspending Computation - computer is in use"
>>>
>>> Xubuntu 13.10 (and earlier versions at least down to Xubuntu 11.04).
>>> All 64 bit.
>>> Linux 3.11.0-15-generic #23-Ubuntu SMP Mon Dec 9 18:17:04 UTC 2013
>>> BOINC 7.2.7 and earlier versions.
>>>
>>> To manage notifications about this bug go to:
>>>
>>> https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1274456/+subscriptions
>>>
>>
>>
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

please try something like sudo apt-get purge boinc*, it should work, otherwise install synaptic and try in the graphical way. there should also be some apt flags to force a removal anyway

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

otherwise you can just manually remove /var/lib/boinc-client and try again

Revision history for this message
Cameron Paine (cbp) wrote :

FWIW this bug effects the 7.2.42 (x86) BOINC client on Xubuntu 14.01.

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04.1 LTS
Release: 14.04
Codename: trusty
# uname -a
Linux lab-netvista 3.13.0-43-generic #72-Ubuntu SMP Mon Dec 8 19:35:44 UTC 2014 i686 i686 i686 GNU/Linux
# dpkg-query -W boinc-client xubuntu-desktop
boinc-client 7.2.42+dfsg-1
xubuntu-desktop 2.180

The work-around of restarting /etc/init.d/boinc-client gets things going again.

Ken Sharp (kennybobs)
tags: added: amd64 i386 saucy trusty
Changed in boinc (Debian):
status: Unknown → Confirmed
Changed in boinc (Debian):
status: Confirmed → Fix Released
Changed in boinc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.