boincmgr unable to launch a second instance

Bug #1115607 reported by Ken Sharp
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
BOINC
Fix Released
Unknown
boinc (Debian)
New
Undecided
Unassigned
boinc (Ubuntu)
Medium
Unassigned

Bug Description

Not sure if this is an upstream bug or not as I am unable to test on another Linux.

Open boincmgr, open Advanced menu and select "Launch another BOINC manager". Nothing happens.

This appears in the console:
execv: Permission denied

Cannot find anything in the syslog regarding permission conflicts.

Tried with upstream version 7.0.44 and the problem remains.

Could this be specific to Ubuntu?

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: boinc-manager 7.0.27+dfsg-5ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-37.58-generic 3.2.35
Uname: Linux 3.2.0-37-generic x86_64
NonfreeKernelModules: fglrx wl
ApportVersion: 2.0.1-0ubuntu17.1
Architecture: amd64
Date: Mon Feb 4 20:52:35 2013
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: boinc
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Ken Sharp (kennybobs) wrote :
Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Are you saying you have the problem with the official build too?

Could you please try boinc 7.0.47 from ppa:costamagnagianfranco/boinc ppa?

Thanks

Revision history for this message
Ken Sharp (kennybobs) wrote :

Yep, all versions I've tried from the official build up to 7.0.47 from the ppa have the same problem.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi Ken, I see the same behaviour in my machines, definitively a bug, but I have this bug too with the official client build (from berkeley/dl website).

So I suggest you to report it directly upstream, otherwise I'll have a look at the source code, but this is an upstream bug, so is stupid to fix it on debian side.

I saw some your mail on boinc_alpha mailing list, so feel free to report this bug too :)

Changed in boinc (Ubuntu):
status: New → Confirmed
Revision history for this message
Ken Sharp (kennybobs) wrote :

Mail sent. Mailing list is private.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

No problem I read it :-)

Anyway the problem is how the exec calls boincmgr, I think I patched it yesterday night but only locally, before pushing anything to debian I just want to be sure the patch works in any case...

In the meanwhile you can run another boinc manager instance with
boincmgr --multiple
And maybe with --directory /etc/boinc-client as well

Revision history for this message
Daniel Winzen (q-d-deactivatedaccount) wrote :

This still exists in saucy release 7.1.20+dfsg-1

tags: added: saucy
Revision history for this message
Ken Sharp (kennybobs) wrote :

Was the patch accepted upstream?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

no way, the patch wasn't working for some reasons, I need to further investigate

Changed in boinc (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Revision history for this message
Ken Sharp (kennybobs) wrote :

The process for reporting a bug upstream to BOINC seems to be to send an e-mail to a black hole, and then forget about it. The Trac system that they have installed is broken so there's no way at all to record a bug report!

http://boinc.berkeley.edu/trac/register

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

forwarded to boinc_alpha mail list

Revision history for this message
Ken Sharp (kennybobs) wrote :

I don't suppose there's been any kind of response?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

nope, I'll try to have a look soon (I hope)

Revision history for this message
Ken Sharp (kennybobs) wrote :

I'm guessing that nobody is interested in this.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

seems that nobody is interested in boinc anymore, and I don't have time to look at it :(

Revision history for this message
ChristianB (djangofett) wrote :

I could reproduce this with an upstream dev build. It seems something is going wrong when calling execv() which is not reported back internally, thus the lack of error messages. I'm filing an upstream bug report on github.

Revision history for this message
ChristianB (djangofett) wrote :

It turns out there was already a bug reported for that. I added the new info to https://github.com/BOINC/boinc/issues/1177

I don't know if I can spare the time to investigate but maybe someone on github picks up on this.

ChristianB (djangofett)
Changed in boinc:
importance: Undecided → Unknown
status: New → Unknown
Changed in boinc:
status: Unknown → New
Changed in boinc (Ubuntu):
importance: High → Medium
Changed in boinc (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.6.33+dfsg-10

---------------
boinc (7.6.33+dfsg-10) unstable; urgency=medium

  * New upload changing the working dir during execve

 -- Gianfranco Costamagna <email address hidden> Wed, 15 Mar 2017 17:53:03 +0100

Changed in boinc (Ubuntu):
status: Fix Committed → Fix Released
Changed in boinc:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.