crashes when trying to add projects

Bug #1001168 reported by LAZA
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
BOINC
New
Unknown
boinc (Debian)
Fix Released
Unknown
boinc (Ubuntu)
High
Unassigned

Bug Description

I did a fresh install from XUbuntu Precise 64 bit with the alternate CD, installed BOINC with Synaptic and tried to run it.

[Test Case]
After opening up BOINC the Menu bar is blank, it opens up the window to add projects.
By clicking on the button next, BOINC crashes.

I tried then the ppa from ppa:trekcaptainusa-tw/boinc, (version 7.0.27).
Menu bar is visible, but i can't connect with the client (tried name and 127.0.0.1) - it is not possible to add projects.

So i think it is not a duplicate of the know bug in 7.0.24.

XUbuntu 12.04
Linux xubuntu2 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

first: BOINC 7.0.24+dfsg-1

last: BOINC 7.0.27+dfsg-3.1

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

could you please try boinc from here?
https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

and make sure you DON'T have any other boinc instances before running it

(maybe launch boinc from terminal and post here the stack trace)

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I'm experiencing the same problem, so this is not fixed afaics, I'm looking for a clean upstream version to look if the problem is due to a bad patch in ubuntu/debian system.

Changed in boinc (Ubuntu):
status: New → Confirmed
Revision history for this message
Steffen Möller (moeller-debian) wrote : Re: [Bug 1001168] Re: crashes when trying to add projects

On 05/18/2012 02:48 PM, LocutusOfBorg wrote:
> I'm experiencing the same problem, so this is not fixed afaics, I'm
> looking for a clean upstream version to look if the problem is due to a
> bad patch in ubuntu/debian system.
Something is wrong in that "add project". That much we know.
Amazingly, the with "--enable-debug" set during compilation, the dialog
box behaves differently, i.e. for me it crashes even before opening. I
have directly informed upstream about it.

Steffen

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

HI Steffen, I tried now with a clean installation of .28 build, and the problem is still there, so I opened a ticket upstream.
I know you had a mail exchange, but maybe this way will help us so find a patch when available ;)

http://boinc.berkeley.edu/trac/ticket/1183

to LAZA can you please confirm that the second time you run it works well?

Revision history for this message
LAZA (laza74) wrote :

@LocutusOfBorg:

Yeah, you right!
After a reboot today it works... - but the problem with the menu bar is back (seems to be a problem with the full screen mode; after minimize and maximise the window the menu bar is back and visible)

If i try to use the new "category" push down menu, BOINC crashes again.

Without this i was able to add my 5 projects and try now to crunch some WUs...

BOINC 7.0.27 (x86)

Changed in boinc:
status: Unknown → New
Revision history for this message
Steffen Möller (moeller-debian) wrote :

-------- Original-Nachricht --------
> Datum: Sat, 19 May 2012 10:53:57 -0000
> Von: LAZA <email address hidden>
> An: <email address hidden>
> Betreff: [Bug 1001168] Re: crashes when trying to add projects

> @LocutusOfBorg:
>
> Yeah, you right!
> After a reboot today it works... - but the problem with the menu bar is
> back (seems to be a problem with the full screen mode; after minimize and
> maximise the window the menu bar is back and visible)
Any change of the window size fixes that - until you add another project :-/ Upstream has no idea why this happens. So, any wxWidget affectionado please help out.

> If i try to use the new "category" push down menu, BOINC crashes again.
This is something upstream. Reported, fixed, resurfaced.

> Without this i was able to add my 5 projects and try now to crunch some
> WUs...
>
> BOINC 7.0.27 (x86)
Excellent.

Steffen

Revision history for this message
Daniel Hahler (blueyed) wrote :

This looks like the following Debian bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=641593

I am working on a StableReleaseUpdate for Proposed, which should fix this then, too.

Changed in boinc (Debian):
status: Unknown → Fix Released
Revision history for this message
Chris Halse Rogers (raof) wrote :

This bug is missing some required information for an SRU; particularly, the description should have an Impact, Test Case, and Regression potential section as documented in https://wiki.ubuntu.com/StableReleaseUpdates

Also, is this fixed in Quantal?

Revision history for this message
Daniel Hahler (blueyed) wrote :

1. The main SRU bug is bug 1009536, which has been edited by Dave to fit the SRU requirements
2. I only have looked at other bugs this upload would fix and if there was feedback from PPA users which indicated it, I have added it to the changelog.
3. This is fixed in Quantal, which has 7.0.27 already.

If an updated description (according to SRU specs) would be still required, I would have to ask someone else to add it.

Given the slowness of this particular SRU process I could imagine that it would be better to ask/wait for 7.0.32+ anyway.

Changed in boinc (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Revision history for this message
Clint Byrum (clint-fewbar) wrote :

Daniel, thanks for the response. The issue is that we don't allow changes into the stable release without a test case to prove that the change was needed and successful in producing the intended outcome. We also need to know what parts of the program a change touches so that we can prevent regressions.

However given the seriousness of bug 1009536, I think we should waive that requirement and instead focus on testing the program with a prolonged stay in precise-proposed.

Given that I'm going to accept the upload. This bug will need to be verified, however, so I've marked the test case in the description as the one that users should try after installing the package from proposed.

description: updated
tags: added: verification-needed
Revision history for this message
Clint Byrum (clint-fewbar) wrote : Please test proposed package

Hello LAZA, or anyone else affected,

Accepted boinc into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/boinc/7.0.27+dfsg-5ubuntu0.12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Alexander Lazarević (e11bits) wrote : Re: [Bug 1001168] Please test proposed package

2012/7/18 Clint Byrum <email address hidden>

> Hello LAZA, or anyone else affected,
>

Wow, I still need to find my way around, but thanks for the warm welcome
Clint!!!

Revision history for this message
Alexander Lazarević (e11bits) wrote :

2012/7/18 Alexander Lazarević <email address hidden>

> Wow, I still need to find my way around, but thanks for the warm welcome
> Clint!!!
>

Oh, different LAZA. Sorry for the misconception! :)

Revision history for this message
LAZA (laza74) wrote :

Hai Clint and all others (especially Alexander Lazarević :)

i will try this at the weekend when i'm at home - but will need some days to test cause weekdays i'm on work an the PC doesn't crunch.
Maybe some other persons try the proposed version just for fun or interest...

Thanks for the fast response and stay tuned.

LAZA

Revision history for this message
LAZA (laza74) wrote :

Works for me incl. all options!

- add project
-- choose a categorie!
-- choose a project
- communication
-- add email an password
- done!!!

I was able to add 'Spinhenge@home' and 'Leiden Classical' without any problems.

Thanks to all for the good and fast(!) work.
Have a nice and sunny sunday :-)

Revision history for this message
Arno Wagner (arnow-deactivatedaccount) wrote :

Hi

I've been testing the proposed version for two days. No crashes yet and Docking tasks work fine again. But the issue with the vanishing menu bar is still present.

I'm going to run this version until a newer one comes out.

Regards,
Arno

Revision history for this message
Dave (xclusive585) wrote : Re: [Bug 1001168] Re: crashes when trying to add projects

I can second that the menu bug still exists in this version. But I am glad
to see so many bugs are resolved with this 7.0.27
On Jul 22, 2012 9:35 AM, "LAZA" <email address hidden> wrote:

> Works for me incl. all options!
>
> - add project
> -- choose a categorie!
> -- choose a project
> - communication
> -- add email an password
> - done!!!
>
> I was able to add 'Spinhenge@home' and 'Leiden Classical' without any
> problems.
>
> Thanks to all for the good and fast(!) work.
> Have a nice and sunny sunday :-)
>
> --
> You received this bug notification because you are a member of Debian
> BOINC Maintainers, which is subscribed to boinc in Ubuntu.
> https://bugs.launchpad.net/bugs/1001168
>
> Title:
> crashes when trying to add projects
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/boinc/+bug/1001168/+subscriptions
>
> --
> pkg-boinc-devel mailing list
> <email address hidden>
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-boinc-devel
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

the menu problem is fixed in 31+ release

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.0.27+dfsg-5ubuntu0.12.04.1

---------------
boinc (7.0.27+dfsg-5ubuntu0.12.04.1) precise-proposed; urgency=low

  * Stable Release Update to fix multiple bugs:
    - fixes regression with Seti, Docking@Home and maybe others
      (LP: #1009536)
    - fixes crash when adding projects (LP: #1001168)
    - fixes file descriptor leak (LP: #968021)
  * debian/control: enable building of boinc-amd-opencl again (disabled in
    7.0.27+dfsg-4 for Debian specific reasons)

boinc (7.0.27+dfsg-5) unstable; urgency=low

  * debian/rules: use dpkg-buildflags to get default flags.
  * debian/control: build-depend on dpkg-dev >= 1.16.1.1, because
    buildflags.mk and DEB_BUILD_MAINT_OPTIONS are needed.
  * debian/patches/add_hardening_flags.patch: pass CXXFLAGS, CPPFLAGS and
    LDFLAGS to hand-written Makefiles in samples/.

boinc (7.0.27+dfsg-4) unstable; urgency=low

  [ Steffen Moeller ]
  * Not building boinc-amd-opencl, for fglrx-driver is not in testing.
  * Adding hardening flags.
  * Addressed FTBFS on hurd (Closes: #672725)
  * debian/boinc-client.init: increasing priority of boinc client, change nice
    value from 19 to 10.

  [ Guo Yixuan ]
  * Add patch from Rom that fix the project category crash. (Closes: #641593)
  * debian/rules: fix to set sched/transitioner_catchup.php in
    boinc-server-maker executable.
  * Cherry-picking above commits from master to sid branch.
  * Add myself to uploaders.

boinc (7.0.27+dfsg-3) unstable; urgency=low

  * Now truly reconstituting compatibility with SETI
    (Closes: #672328, lp: #991179).
  * builds with gcc 4.7 (Closes: #671999)
    Thanks to Matthias Klose for his patch, had sadly only seen it after
    I patched it myself :o/ The NMU of his should not kick in because
    of the SETI incompatibility.

boinc (7.0.27+dfsg-2) unstable; urgency=low

  * Removed a couple of patches to help preventing crash in some
    scientific apps

boinc (7.0.27+dfsg-1) unstable; urgency=low

  * New upstream release
    - NVidia issue settled, presumably.
    - Some patches adopted by upstream.

boinc (7.0.26+dfsg-1) unstable; urgency=low

  * New upstream release
    - Comes with NVidia patches
    - Other incompatibilities with various projects fixed

boinc (7.0.25+dfsg-2) UNRELEASED; urgency=low

  * Added patch by Bernd Machenschalk to improve the uniqueness
    of clients when multiple instances are run.
  * Helping man page of stripchart.

boinc (7.0.25+dfsg-1) UNRELEASED; urgency=low

  [ Steffen ]
  * New upstream version (not yet with NVidia API improvements).

  [ Thorsten ]
  * Helping warnings in init scripts (Closes: #651278,#651303).
  * Fixing Python dir problem for boinc-server-maker (Closes: #657036)
  * Fixed warning for man page to stripchart.

boinc (7.0.24+dfsg-4) UNRELEASED; urgency=low

  * Improved support of NVidia cards - API incompatibility

boinc (7.0.24+dfsg-3) UNRELEASED; urgency=low

  * Support of clang through DEB_BUILD_OPTIONS

boinc (7.0.24+dfsg-2) UNRELEASED; urgency=low

  * More adjustments of patches.
 -- Daniel Hahler <email address hidden> Thu, 28 Jun 2012 01:17:04 +0200

Changed in boinc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.