Work unit calculation fails with SIGILL

Bug #1132545 reported by Christian Lins
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
boinc-app-seti (Ubuntu)
Undecided
Unassigned

Bug Description

Using boinc and boinc-app-seti from the repositories on my Toshiba AC100 (armhf architecture) the calculation of WUs fails with the following error message:

<core_client_version>7.0.27</core_client_version>
<![CDATA[
<message>
process exited with code 193 (0xc1, -63)
</message>
<stderr_txt>
setiathome_enhanced 6.12 $Revision: 316 $ g++ (Ubuntu/Linaro 4.7.0-12ubuntu1) 4.7.0
libboinc: BOINC 7.0.27

Work Unit Info:
...............
WU true angle range is : 0.011816
Optimal function choices:
-----------------------------------------------------
name
-----------------------------------------------------
SIGILL: illegal instruction
Stack trace (2 frames):
../../projects/setiathome.berkeley.edu/setiathome_enhanced(boinc_catch_signal+0x75)[0x5e0aa]
/lib/arm-linux-gnueabihf/libc.so.6(__default_sa_restorer_v2+0x0)[0x4034b9d0]

Exiting...

</stderr_txt>
]]>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I'm building boinc 7.0.53 and boinc-app-seti in my ppa right now, in the meanwhile could you try only boinc-app-seti from my ppa [1]?

I just need to know if the problem is only in boinc-app-seti or in boinc too

thanks

[1] https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

In a few hours boinc app seti will be available in my ppa [1] too.
(less frequen updates than the previous one)
[1] https://code.launchpad.net/~costamagnagianfranco/+archive/locutusofborg-ppa/+packages

Revision history for this message
Christian Lins (cli) wrote :

I tried boinc-app-seti from your PPA without luck. At first together with boinc from main repositories, then your boinc version.
In both cases I got calculation errors, see http://setiathome.berkeley.edu/result.php?resultid=2848721919

Revision history for this message
Christian Lins (cli) wrote :

Is it possible that this is not a bug of boinc-* but of g++? Perhaps g++ is generating a invalid opcode or is using ARM extensions the Tegra2 does not support?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I'm packaging right now a new release, please try again in a few hours

https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

I'm building right now 7.00_svn1772

Revision history for this message
Christian Lins (cli) wrote :

Same error...

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi Christian, could you please explain which seti version are you running on? does this ahppens with the official seti client too? a new seti release has been uploaded on debian today, and will be available in saucy soon.

Would be also nice if you can provide a stacktrace with boinc-app-seti-dbg.
thanks

Changed in boinc-app-seti (Ubuntu):
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for boinc-app-seti (Ubuntu) because there has been no activity for 60 days.]

Changed in boinc-app-seti (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers