bogl ftbfs in eoan

Bug #1843727 reported by Matthias Klose on 2019-09-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bogl (Ubuntu)
High
Adam Conrad
Eoan
High
Adam Conrad

Bug Description

seen in a test rebuild:
https://launchpadlibrarian.net/441264299/buildlog_ubuntu-eoan-armhf.bogl_0.1.18-13ubuntu1_BUILDING.txt.gz

make[2]: Entering directory '/<<PKGBUILDDIR>>/build-udeb'
cc -E -Os -g -D_GNU_SOURCE -Wall -D_GNU_SOURCE -DBOGL_CFB_FB=1 -DBOGL_VGA16_FB=1 -M arrow.c bdftobogl.c bogl-cfb.c bogl-cfb.h bogl-cfb8.c bogl-cfb8.h bogl-font.c bogl-font.h bogl-test.c bogl.h boglP.h boml.c boml.h bowl.c bowl.h pngtobogl.c bogl-pcfb.c bogl-pcfb.h bogl-tcfb.c bogl-tcfb.h bowl-boxes.c bogl.c bogl-vga16.c bogl-vga16.h > .depend
bogl-vga16.c:33:10: fatal error: sys/io.h: No such file or directory
   33 | #include <sys/io.h>
      | ^~~~~~~~~~
compilation terminated.
make[2]: *** [Makefile:104: .depend] Error 1

Matthias Klose (doko) on 2019-09-12
tags: added: ftbfs rls-ee-incoming
Matthias Klose (doko) on 2019-09-12
Changed in bogl (Ubuntu):
status: New → Confirmed
importance: Undecided → High
tags: removed: rls-ee-incoming
tags: added: id-5d7f649cb64ef382be8e8b68
Steve Langasek (vorlon) wrote :

Fixed in bogl 0.1.18-13ubuntu2.

bogl (0.1.18-13ubuntu2) eoan; urgency=medium

  * debian/patches/makefile: Use DEB_HOST vars consistently, rather than
    incorrectly using DEB_BUILD and uname to guess what we're building.
  * debian/patches/makefile: Don't build vga16 on arm, due to glibc 2.30.

Changed in bogl (Ubuntu Eoan):
assignee: nobody → Adam Conrad (adconrad)
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers