Unable to send/recieve files using bluetooth

Bug #913648 reported by Rigved Rakshit on 2012-01-09
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned

Bug Description

lDescription: Ubuntu precise (development branch)
Release: 12.04

bluez:
  Installed: 4.96-3ubuntu5
  Candidate: 4.96-3ubuntu5
  Version table:
 *** 4.96-3ubuntu5 0
        500 http://in.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

Expected Outcome: Files should have been transferred (sent and received) successfully between computer and phone.

Actual Outcome: The phone is connecting successfully with the computer. The computer is able to use the Internet connection of the phone. But file transfer (send and receive) is not working.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: bluez 4.96-3ubuntu5
ProcVersionSignature: Ubuntu 3.2.0-8.14-generic 3.2.0
Uname: Linux 3.2.0-8-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
CheckboxCommand: hcitool dev | tail -n+2 | awk '{print $2}' |diff $CHECKBOX_DATA/bluetooth_address -
CheckboxData: diff: /home/administrator/.cache/checkbox/bluetooth_address: No such file or directory
CheckboxDescription: This test grabs the hardware address of the bluetooth adapter after suspend and compares it to the address grabbed before suspend.
CheckboxTest: suspend/bluetooth_detect_after_suspend
Date: Mon Jan 9 11:53:44 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20111215)
InterestingModules: bnep rfcomm bluetooth
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: L3000 Y300 Y300
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-8-generic root=UUID=e855e87e-93cf-486a-89a9-9c8216e44dad ro quiet splash vt.handoff=7
SourcePackage: bluez
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 11/06/06
dmi.bios.vendor: Lenovo
dmi.bios.version: Q3B11W
dmi.board.name: Y300
dmi.board.vendor: L3000 Y300
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Lenovo
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnLenovo:bvrQ3B11W:bd11/06/06:svnL3000Y300:pnY300:pvrRev1.0:rvnL3000Y300:rnY300:rvrNotApplicable:cvnLenovo:ct10:cvrN/A:
dmi.product.name: Y300
dmi.product.version: Rev 1.0
dmi.sys.vendor: L3000 Y300
hciconfig:

rfkill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no

Rigved Rakshit (rigved) wrote :
Rigved Rakshit (rigved) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Kevin Huang (wasikevin) wrote :

After the latest update today, I confirmed it is able to send files using bluetooth to my smartphone, but failed to received files from.

Bluez: 4.98-2ubuntu7

LordGiotto (lordgiotto) wrote :

I've solved installing obexpushd :)

Receiving files requires that you get the the File sharing application (gnome-file-share-properties), and allow receiving files via bluetooth. Closing as Fix Released since as far as I know everything in this works properly. If you're still unable to receive files via bluetooth with the properties set to allow receiving files; please set this bug back to New and provide any additional information which might help us debugging the issue, including brand/model of phone used.

Changed in bluez (Ubuntu):
status: Confirmed → Fix Released
Peter Sewell (peter-sewell) wrote :

How can this bug be marked as Fix Released when I can't transfer files from either of my mobile phones to or from ubuntu 12.04.

I have enabled the bluetooth file share properties and I've connected my Nokia E65 and my HTC Desire to ubuntu 12.04 and both will not transfer files in either direction.

In fact when I tried ubuntu completely crashed and on reboot didn't load into unity but into command prompt only - After several reboots I finally got into unity as normal.

So clearly something is seriously wrong here.

If you say that this bug is fixed then I would hope that a clear guideline could be written down for everyone who is affected by this so that we can fix our ubuntu installations.

Thanks

Randy Perkins (randyperkins) wrote :

I tried to reopen this bug but the options were grayed out?
I was able to send files via bluetooth but not receive them.

The status is fix released but Mathieu Trudel-Lapierre (mathieu-tl) does not proposes fix.
He stated 'Closing as Fix Released since as far as I know everything in this works properly'.
What logic was used to closed under 'fix released' is beyond my grasp.

Anyway.
comment 5, which suggested installing 'obexpushd' resolved the issue for me.
I restarted the bluetooth daemon after installing obexpushd

Would someone who has the ability reopen this bug.

obexpushd is neither a dependency nor recommends for gnome-user-share. Make it so.
obex-data-server is a dependency but it appears only to support pushing files, not receiving them

rperkins@htpc:~$ dpkg-query -W -f='Depends ----- ${Depends}\n Recommends ----- ${Recommends}\n' gnome-user-share
Depends ----- gconf-service, libc6 (>= 2.4), libcanberra-gtk3-0 (>= 0.25), libcanberra0 (>= 0.2), libdbus-1-3 (>= 1.1.1), libdbus-glib-1-2 (>= 0.78), libgconf-2-4 (>= 2.31.1), libglib2.0-0 (>= 2.28.0), libgnome-bluetooth8 (>= 2.91.2), libgtk-3-0 (>= 3.0.0), libnotify4 (>= 0.7.0), libselinux1 (>= 1.32), libx11-6, gconf2 (>= 2.28.1-2), obex-data-server, gnome-bluetooth
 Recommends -----

obex-data-server is D-Bus service providing high-level OBEX client and server side functionality. It cur‐
       rently supports OPP (Object Push Profile), FTP (File Transfer profile) and partially BIP (Basic Imaging
       profile). Supported transports are Bluetooth, USB (client only) or TTY. obex-data-server exposes it's
       functionality through 'org.openobex' namespace in D-Bus.

obexpushd is a program that can be used to receive files using OBEX (OBject EXchange) protocol over
       Bluetooth, IrDA or network connection. It can be used to receive files from mobile phones and other
       devices.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers