Bluetooth mouse opens "Grant access" window

Bug #774854 reported by Norbert on 2011-05-01
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bluez

I have a VAIO F13Z1R with integrated bluetooth and bluetooth mouse Logitech M555b. They worked together successfully under 10.04.2 LTS.
After upgrading to 11.04 mouse is broken. When I switch on bluetooth on the devices, I got a windows with access prompt (see screenshot). When I try to add mouse manually via "Set up new device" a got "Setting up 'Logitech Bluetooth Mouse M555b' failed" or NULL PIN (see screenshot).

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: bluez 4.91-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
Architecture: amd64
Date: Sun May 1 16:31:26 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InterestingModules: rfcomm sco bnep l2cap btusb bluetooth
MachineType: Sony Corporation VPCF13Z1R
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=0de67daf-431c-4445-b917-625f411a53a7 ro i8042.nopnp quiet splash vt.handoff=7
SourcePackage: bluez
UpgradeStatus: Upgraded to natty on 2011-04-29 (1 days ago)
dmi.bios.date: 09/03/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: R0180Y9
dmi.board.asset.tag: N/A
dmi.board.name: VAIO
dmi.board.vendor: Sony Corporation
dmi.board.version: N/A
dmi.chassis.asset.tag: N/A
dmi.chassis.type: 10
dmi.chassis.vendor: Sony Corporation
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrR0180Y9:bd09/03/2010:svnSonyCorporation:pnVPCF13Z1R:pvrC6070EHZ:rvnSonyCorporation:rnVAIO:rvrN/A:cvnSonyCorporation:ct10:cvrN/A:
dmi.product.name: VPCF13Z1R
dmi.product.version: C6070EHZ
dmi.sys.vendor: Sony Corporation
hciconfig:
 hci0: Type: BR/EDR Bus: USB
  BD Address: C0:CB:38:FA:A7:D5 ACL MTU: 1021:8 SCO MTU: 64:1
  UP RUNNING PSCAN
  RX bytes:2378 acl:24 sco:0 events:85 errors:0
  TX bytes:1279 acl:32 sco:0 commands:40 errors:0

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

NULL PIN-code window

Norbert (nrbrtx) wrote :

Output of "sudo hcidump -XYt > $HOME/hci.log".

Norbert (nrbrtx) wrote :

Grant access window also appears on 11.04 LiveCD.

Norbert (nrbrtx) wrote :

I get mouse to work with following actions:
1. System -> Preferencies -> Startup Applications
Uncheck "Bluetooth Manager" mark
2. Reboot
3. Run 'bluetooth-wizard' from terminal
Mouse found and successfully set up. No grant access window appeared.
4. System -> Preferencies -> Startup Applications
Check "Bluetooth Manager" mark
5. Reboot
6. Mouse works from login screen!

I need comments from developers.

Dave (digitaljail) wrote :

this affect me also on 10.04 after lastest update, same mouse, on a Dell Precision M4500, it worked till today.
I also tested the Norbert WorkAraund with no luck.

I experienced the same problem in Sony Vaio Vpcf113fx. My Bluetooth mouse didn't work even there executed the Norbert footsteps.

spooky33 (sozialkunde) wrote :

The same problem here.
Norbert's workaround did not work for me!

spooky33 (sozialkunde) wrote :

Got it working ;-)
For me it works after I clicked the mouse's "CONNECT" button and then performed the bluetooth setup!

Changed in bluez (Ubuntu):
status: New → Confirmed

This still affects Lucid; can't get my mouse (same M555b) working on a Toshiba Qosmio. It works fine with Maverick and Oneiric Beta 1.

i get this with 12.04 using an a4tech bt-630 bluetooth mouse.

headlessspider: please file a separate bug for your issue, it's most assuredly not the same problem. Thanks!

Norbert (nrbrtx) wrote :

Bug exists in Quantal.

tags: added: precise quantal
flob (fburka) wrote :

I got my M555b only working with a combination of a lot of patience, blueman-manager doing the same thing over and over again and sometimes restarting bluetooth :/

Stephen Platz (steveplatz) wrote :

I was able to get my mouse paired after following the steps in #5 then #9. My mouse failed to connect suddenly with the same error in the syslog. It's a Thinkpad Bluetooth Laser.

The only way that the M555b from Logitech is working on Ubuntu 14.04 for me was to follow this: https://wiki.archlinux.org/index.php/bluetooth_mouse

This is reported against an old version of Ubuntu and many things has changed since then. Because of that we won't fix this issue however if this behavior repeats on a modern version please fill a bug report against it and we will take it from there.

Changed in bluez (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers