resume problems with bluetooth

Bug #73546 reported by dperson
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
acpi (Ubuntu)
Undecided
Unassigned
bluez (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: acpi

Since adding the Dell BT (lsusb: Bus 002 Device 010: ID 413c:8103 Dell Computer Corp. Wireless 350 Bluetooth) to my Inspiron 6000D laptop (running kubuntu 6.06.1 and later 6.10), most times (9 out of 10) my laptop would freeze with a suspend / resume cycle. Adding bluetooth to the services that need to be shutdown and restarted in acpi-support did not solve the problem. I had to add the following files into the /etc/acpi directory.

/etc/acpi/suspend.d/50-bluetooth-stop.sh:
    #!/bin/sh

    # Stop bluetooth if it's running
    if [ -e /var/run/sdp ]; then
        /etc/init.d/bluetooth stop
    fi

/etc/acpi/resume.d/40-bluetooth-start.sh:
    #!/bin/sh

    [ -f /etc/default/bluetooth ] && . /etc/default/bluetooth

    # Start bluetooth
    if [ -n "$BLUETOOTH_ENABLED" ]; then
        /etc/init.d/bluetooth start
    fi

They are very loosely modeled on the irda scripts for a similar purpose.

Revision history for this message
Sridhar Dhanapalan (sridhar) wrote :

I don't have problems with my laptop (a Dell Inspiron 9400) freezing, but my Bluetooth often does not work upon resume. These scripts fix that problem.

Revision history for this message
Martey Dodoo (martey) wrote :

I am seeing similar freezing issues with my Thinkpad T43 (Bus 003 Device 003: ID 0a5c:201e Broadcom Corp.) running Ubuntu 7.04 (kernel is 2.6.20-16-generic). On resume from both suspend-to-disk and suspend-to-RAM, the screen remains blank and the keyboard and touchpad do not respond. These issues do not happen if bluetooth is disabled prior to suspend.

Changed in acpi:
status: Unconfirmed → Confirmed
Revision history for this message
Matija Polajnar (matija-polajnar) wrote :

I experience freezing when Bluetooth is on when suspending too.
I am using Feisty on Thinkpad R52 with built-in bluetooth adapter. (Strange, lspci doesn't list any bluetooth device so I cannot find information about the adapter.)

Revision history for this message
Matija Polajnar (matija-polajnar) wrote :

For now, it looks good for me in Hardy. I installed Hardy even before the final release and have yet to experience a sleep problem, although I use bluetooth most of the time.

Revision history for this message
Mario Limonciello (superm1) wrote :

Closing bug per comments.

Changed in acpi:
status: Confirmed → Fix Released
Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

Is this still an issue for you? What Ubuntu version do you use? Thank you for telling us!

Changed in acpi (Ubuntu):
status: New → Incomplete
Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

Closing because of no response from the author.

Changed in acpi (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers