Ubuntu

internal bluetooth device 413c:8121 in dell m2010 is not recognized

Reported by mcfrei on 2009-10-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bluez

Thank you for your interest to this!

I'm using Ubuntu 9.04 on notebook XPS m2010. It has wireless bluetooth keyboard and mouse. The bluetooth device is not recognized by blues.

lsusb shows it as:
Bus 002 Device 002: ID 413c:8121 Dell Computer Corp. Eastfold in HID

but when i try to make hid2hci

$sudo hid2hci --tohci
No devices in HID mode found

and

$ hcitool scan
Device is not available: No such device

however,

$ dmesg | grep Bluetooth
[ 0.368763] Bluetooth: Core ver 2.15
[ 0.368763] Bluetooth: HCI device and connection manager initialized
[ 0.368763] Bluetooth: HCI socket layer initialized
[ 0.694049] Bluetooth: L2CAP ver 2.14
[ 0.694050] Bluetooth: L2CAP socket layer initialized
[ 0.694053] Bluetooth: SCO (Voice Link) ver 0.6
[ 0.694055] Bluetooth: SCO socket layer initialized
[ 0.694107] Bluetooth: RFCOMM TTY layer initialized
[ 0.694109] Bluetooth: RFCOMM socket layer initialized
[ 0.694111] Bluetooth: RFCOMM ver 1.11
[ 46.128315] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 46.128318] Bluetooth: BNEP filters: protocol multicast

the version of bluez is as follows:

$ apt-cache policy bluez
bluez:
  Installed: 4.32-0ubuntu4.1
  Candidate: 4.32-0ubuntu4.1
  Version table:
 *** 4.32-0ubuntu4.1 0
        500 http://ru.archive.ubuntu.com jaunty-updates/main Packages
        100 /var/lib/dpkg/status
     4.32-0ubuntu4 0
        500 http://ru.archive.ubuntu.com jaunty/main Packages

Please tell me what information i can gather to make this bug fixed.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: bluetooth 4.32-0ubuntu4.1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: bluez
Uname: Linux 2.6.32-999-generic x86_64

mcfrei (mcfrei) wrote :
mcfrei (mcfrei) wrote :

Hi there,

Usually bluetooth adapters have to be enable in Windows (sigh) to be usable in Linux.
Could you try that?

Thanks.

Changed in bluez (Ubuntu):
status: New → Incomplete
mcfrei (mcfrei) wrote :

Hello, Baptiste Mille-Mathias.

Thank you for your interest.
Yes, i tried that. I tried to load ubuntu immediately after restarting windows with the bluetooth adapter on, i tried disabling and enabling adapter in windows and then restarting, i tried disabling and enabling the device in Device Manager and restarting, but no matter what i tried the bluetooth device is not found.

For your consideration: it works in the HID-emulation mode, because the bluetooth keyboard is the only keyboard on this notebook and it must work in BIOS setup. That's why it's not found. I think there is a command that switches it to bluetooth device mode.

CharlesR (steincr) wrote :

Here are some clues I discovered on my M2010: If I boot the Lucid LiveCD from the Windows "sleep mode" (that is, power off, but not shut down through the logging off, shutting down sequence), I can coerce the Bluetooth module into recognizing both the keyboard and the mouse. But when I installed Lucid via WUBI from the normal Windows running mode and shut down Windows to reboot, I cannot connect the keyboard and mouse running Lucid's WUBI installation. With plugged-in USB keyboard and mouse, Lucid works fine. No sound comes from the speakers as everyone reports, but the headphone jack has audio. Strangely, the touchpad in the keyboard does work, probably because there are two modes of operating the Bluetooth adapter -- one before Windows loads and the second after Windows loads.

Solving the audio might be as easy as buying an amplifier/speaker set like the ordinary Dell things. I am going to try to find a USB Bluetooth dongle which works in Lucid to see if that solves the keyboard/mouse problem. (I can report that the D'Link DBT120 doesn't work.)

Just got to get this thing off Windows.

CRS

CharlesR (steincr) wrote :

I mis-spoke above. Where I said "sleep mode", I should have said "hibernate mode". The "sleep mode" keeps the working system in memory and does not allow a choice of boot locations when next turned on. Only the "hibernate mode" allows the choice of boot location, and then the choices are only the Windows partition on the main hard disk or the USB device. There is no choice of the imbedded Ubuntu loop. Sorry for the error.

CRS

mcfrei (mcfrei) wrote :

CharlesR: here's a fix for the speakers to work
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=3403

CharlesR (steincr) wrote :

mcfrei: Thank you for that fix. "Make" is something I have not done before, but it seems to work -- that is I got sound out of one of the Gnome-games. More tests, soon.

If only "we" could get the native keyboard and mouse to work Windows would be gone!

Thanks again.

CRS

mcfrei (mcfrei) wrote :

Actually, it works in ubuntu 9.04 for me, but the mouse scroll is not working, and that's sad.
I'm waiting for it too.

CharlesR (steincr) wrote :

@mcfrei: Thanks again for the good tip. I put a copy of the Jaunty iso on a USB stick and booted. The keyboard works; its touchpad works, the numeric keypad works! I was unable to get the M2010's native mouse to do anything. But, hey, a USB mouse is not that big a deal -- I've got several to move around. I'll try the Logitech wireless for the M2010; would be nice.

I tried to boot Karmic thinking that maybe it was Lucid's Plymouth that was messing with the keyboard, but Karmic has the same reaction as Lucid. Keyboard dead. I'm almost ready to make the big switch; just a little more courage is needed. Do you have your installation of Jaunty up to date? Are there updates which break the keyboard? Did you do a full wipe and install, getting rid of Windows completely, or did you do a dual boot, or did you do a WUBI install?

Why have others not discovered that the keyboard works? Do you have any clue what in Karmic and Lucid kills the keyboard? Can we just remaster the ISO leaving out some arcane program? Like BlueZ, maybe? I'll check the pedigree of BlueZ for a clue.

Thanks again.

CRS

mcfrei (mcfrei) wrote :

@CharlesR:
My mouse worked after i installed the bluetooth software that also paired it in bluetooth mode, i guess.
I was not doing through testing, moreover, i've (sadly) updated it to Jaunty and now i have ot reinstall it.
I have a dual boot, one hdd is for windows, and another for ubuntu.

As far as i know there are no updates for 9.04 that break the keyboard.

I don't have a clue what kills the keyboard. As far as i know it's the default hid driver that makes the keyboard work, and i think that it sees the device as custom composite hid that has keyboard, touchpad and mouse data in one.

CharlesR (steincr) wrote :

@mcfrei:
Thanks for your help. I now have the M2010 dual booting with Dreamlinux 3.5 and Jaunty. With Dream, the hwC0D0 file was present at installation, but I had to add hda-verb and the scripts. Dream chose the "vesa" driver for the display and I installed "fglrx" and changed /etc/X11/xorg.conf from "vesa" to "fglrx". That allowed the full 1680x1050 resolution. Jaunty did not have the hwC0D0 file, so I had to update ALSA. Then added the hda-verb business. Both still use an external USB mouse.

So, now, it is working adequately on these two distros without Windows anywhere present. If you can find what you did to make the native mouse work, I would appreciate that information. I'll keep looking into a USB Bluetooth dongle which works with Linux.

Thanks again.

CRS

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.