Bluetooth file transfer to phone fails (from both Nautilus and Bluetooth applet)

Bug #285283 reported by Mary Gardiner on 2008-10-18
86
This bug affects 13 people
Affects Status Importance Assigned to Milestone
nautilus-sendto
New
Undecided
Unassigned
bluez (Ubuntu)
Undecided
Unassigned
Nominated for Intrepid by squalleo
Declined for Jaunty by Brian Murray
nautilus-sendto (Ubuntu)
Low
Unassigned
Nominated for Intrepid by squalleo
Declined for Jaunty by Brian Murray

Bug Description

Binary package hint: bluez

Ubuntu version: Intrepid
Package versions:

bluetooth: 4.12-0ubuntu2
bluez: 4.12-0ubuntu2
bluez-gnome: 1.8-0ubuntu1
obex-data-server: 0.3.4+svn1951-0ubuntu1

Attempt to send file 1:

1. On desktop, right click on .txt file and select 'Sent To...'
2. In "Send To..." dialog, select "Bluetooth (OBEX Push)" and name of phone
3. Press "Send"

Expected:

4. File transfer dialog

Actual behaviour:

4. Error message "Obex Push file transfer unsupported"

Syslog contains:
Oct 18 14:24:00 gertrude bluetoothd[9012]: Discovery session 0xb95e50d8 with :1.597 deactivated
Oct 18 14:24:03 gertrude bluetoothd[9012]: Discovery session 0xb95e50d8 with :1.598 activated

Phone reports nothing.

Attempt to send file 2:

1. Right click on Bluetooth icon in notification area.
2. Select "Send files to device..."
3. Select .txt file in file dialog
4. Select phone in "Select Device" dialog
5. Click "Connect"
6. "File transfer" dialog opens

Expected:

7. File transfer completes, phone reports incoming file to store.

Actual behaviour:

7. File transfer remains with an empty progress bar for approximately 10 seconds. Then it reports "Error occurred" and red error text appears: "org.openobex.Error.ConnectionAttemptFailed"

Syslog contains:
Oct 18 14:27:22 gertrude bluetoothd[9012]: Discovery session 0xb95e58c8 with :1.600 activated
Oct 18 14:27:28 gertrude bluetoothd[9012]: Discovery session 0xb95e58c8 with :1.600 deactivated
Phone reports nothing.

These are regressions from Hardy, where both methods allowed successful file transfer with identical hardware on both ends.

Mario Limonciello (superm1) wrote :

It sounds like your device might simply not be working with any bluetooth period. Do you by chance have an input device (keyboard or mouse) that you can test with?

Changed in bluez:
status: New → Incomplete
Mary Gardiner (puzzlement) wrote :

I do not have other Bluetooth devices aside from the two phones tested.

Mary Gardiner (puzzlement) wrote :

As regards the "device" "working" with Bluetooth, I am not quite sure which device you mean or what would count as working.

Assuming you meant the phone, it appears on "hcitool scan":

$ hcitool scan
Scanning ...
 00:1D:FD:3B:10:EB Cora

I am attaching the output of dbus-send --system --print-reply --dest=org.bluez /org/bluez/hci0/dev_00_1D_FD_3B_10_EB org.bluez.Device.GetProperties

Changed in bluez:
status: Incomplete → New
BSOD (lm-bsod) wrote :

I have the same problem in my Ubuntu. But when using "send files to device" in bluetooth-applet, it works fine...

I add nautilus-sendto to the list of affected project because this is the component used to send files over bluetooth in the file manager.

Mary, the output of dbus-sendto helps a lot, it show your phone doesn't expose its capabilities, so that's why you can't send a file to you phone.
Could you try to send the file using the bluetooth applet, right-click and choose "Send files..." or use bluetooth-sendto from a console, and tell us if it works or not.

Mary Gardiner (puzzlement) wrote :

Baptiste Mille-Mathias: an attempt to send the file via the applet is already described in the bug report, see "Attempt to send file 2".

bluetooth-sendto, when run from the command line, eventually reports this error: "org.openobex.Error.ConnectionAttemptFailed", that is, the same as the applet does.

kylea (kylea) wrote :

I had been successfully syncing to my Nokia 6233 for two weeks - but this week it just stopped working. I have a 6110 and it used to work too, but not anymore. If I discover Ubuntu 8.10 from the phone I can Pair up the phone and the Laptop (Dell E6500). But nothing else works. It just seems to not want to stay connected. The phone has not been updated so its seems to be something with Ubuntu.

I also get "Obex Push file transfer unsupported" from Nautilus 2.24.1 and bluetooth-sendto - see attached image

Here is was sdltool returns:

sdptool browse 00:1B:AF:F8:86:9D
Failed to connect to SDP server on 00:1B:AF:F8:86:9D: Connection timed out

kylea@kylea-e6500:~$ dmesg | grep Bluetooth
[ 15.644873] Bluetooth: Core ver 2.13
[ 15.644975] Bluetooth: HCI device and connection manager initialized
[ 15.644977] Bluetooth: HCI socket layer initialized
[ 15.683372] Bluetooth: Generic Bluetooth USB driver ver 0.3
[ 107.632300] Bluetooth: L2CAP ver 2.11
[ 107.632315] Bluetooth: L2CAP socket layer initialized
[ 107.665844] Bluetooth: SCO (Voice Link) ver 0.6
[ 107.665858] Bluetooth: SCO socket layer initialized
[ 107.710470] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 107.710486] Bluetooth: BNEP filters: protocol multicast
[ 107.903937] Bluetooth: RFCOMM socket layer initialized
[ 107.904300] Bluetooth: RFCOMM TTY layer initialized
[ 107.904311] Bluetooth: RFCOMM ver 1.10

phlegm (daveshome) wrote :
Download full text (6.4 KiB)

Exact problem here since upgrade to Intrepid. Works fine from the bluetooth applet. Fails with error message mentioned above when sending from desktop "send to"

Nokia N95

dpkg -l | grep -i bluez
ii bluez 4.12-0ubuntu5 Bluetooth tools and daemons
ii bluez-alsa 4.12-0ubuntu5 Bluetooth audio support
rc bluez-audio 3.26-0ubuntu6 Bluetooth audio support
ii bluez-cups 4.12-0ubuntu5 Bluetooth printer driver for CUPS
ii bluez-gnome 1.8-0ubuntu1 Bluetooth utilities for GNOME
ii bluez-gstreamer 4.12-0ubuntu5 Bluetooth gstreamer support
ii bluez-utils 4.12-0ubuntu5 Transitional package
rc libbluetooth2 3.29-0ubuntu1 Library to use the BlueZ Linux Bluetooth sta
ii libbluetooth3 4.12-0ubuntu5 Library to use the BlueZ Linux Bluetooth sta

is02430@islapx01:~$ sdptool browse 00:1A:DC:CD:3C:94
Browsing 00:1A:DC:CD:3C:94 ...
Service Name: AVRCP Target
Service Description: Audio Video Remote Control
Service Provider: Symbian Software Ltd.
Service RecHandle: 0x10000
Service Class ID List:
  "AV Remote Target" (0x110c)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 23
  "AVCTP" (0x0017)
    uint16: 0x100
Profile Descriptor List:
  "AV Remote" (0x110e)
    Version: 0x0100

Service RecHandle: 0x10001
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 1

Service Name: Dial-Up Networking
Service RecHandle: 0x10002
Service Class ID List:
  "Dialup Networking" (0x1103)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 2
Language Base Attr List:
  code_ISO639: 0x454e
  encoding: 0x6a
  base_offset: 0x100
Profile Descriptor List:
  "Dialup Networking" (0x1103)
    Version: 0x0100

Service Name: OBEX Object Push
Service RecHandle: 0x10004
Service Class ID List:
  "OBEX Object Push" (0x1105)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 9
  "OBEX" (0x0008)
Language Base Attr List:
  code_ISO639: 0x454e
  encoding: 0x6a
  base_offset: 0x100
Profile Descriptor List:
  "OBEX Object Push" (0x1105)
    Version: 0x0100

Service Name: Imaging
Service RecHandle: 0x10006
Service Class ID List:
  "Imaging Responder" (0x111b)
Protocol Descriptor List:
  "L2CAP" (0x0100)
  "RFCOMM" (0x0003)
    Channel: 15
  "OBEX" (0x0008)
Language Base Attr List:
  code_ISO639: 0x454e
  encoding: 0x6a
  base_offset: 0x100
Profile Descriptor List:
  "Imaging" (0x111a)
    Version: 0x0100

Service Name: Audio Source
Service RecHandle: 0x10007
Service Class ID List:
  "Audio Source" (0x110a)
Protocol Descriptor List:
  "L2CAP" (0x0100)
    PSM: 25
  "AVDTP" (0x0019)
    ...

Read more...

Since my original bug is that all forms of file transfer fail (both applet and nautilus-send-to), people who only have send-to failures need to file a separate bug.

On Tue, Nov 4, 2008 at 7:12 PM, phlegm <email address hidden> wrote:
> Exact problem here since upgrade to Intrepid. Works fine from the
> bluetooth applet. Fails with error message mentioned above when sending
> from desktop "send to"
>

Please open a different bug for this problem, this is totally different.

kylea (kylea) wrote :

I cannot get "sdptool browse" to work at all - it used to prior to RC of Intrepid:

Here are my outputs:

root@kylea-e6500:~# hcitool scan

 00:1B:AF:CA:BE:44 Kyle6110

root@kylea-e6500:~# hcitool inq

Inquiring ...
 00:1B:AF:CA:BE:44 clock offset: 0x068c class: 0x5a020c

root@kylea-e6500:~# sdptool browse 00:1B:AF:CA:BE:44

Failed to connect to SDP server on 00:1B:AF:CA:BE:44: Connection reset by peer

Now the sdptool browse has previously worked and syncing used to work fine for the Calendar.

Maybe in all the attempts to get this working something is missing.

frenchy82 (cartes) wrote :

Exactly same problem for me on xubuntu 8.10

I do not use nautilus so i use the Second method

When i want transfert a file from computer I have this message on the attempt of transfert in red : "org.openobex.Error.ConnectionAttemptFailed"

It worked perfectly with hardy but since i updated to intrepod it didn'nt work any more
(sorry for my english)

French82, what are you adding comments on this bug which clearly is not the same than yours?
please open a new bug, and I will try to help you there.

Alex Mayorga (alex-mayorga) wrote :

Looks to me like this is now fixed on Intrepid on these package versions:

bluetooth: 4.12-0ubuntu5
bluez: 4.12-0ubuntu5
bluez-gnome: 1.8-0ubuntu1
obex-data-server: 0.3.4+svn1951-0ubuntu1

I successfully transferred a .txt file to my phone using the procedure outlined on "Attempt to send file 1" and I successfully transferred a .jpg file to my phone using the procedure outlined on "Attempt to send file 2"

Mary,

Can you please check again with updated packages and confirm if this can be now closed as "Fix Released"?

Thanks, regards and happy 2009 to you all.

Changed in bluez:
assignee: nobody → alex-mayorga
lucge (luc-loiseau) wrote :

Packages you list has not changed since ibex initial release
I can can confirm that with a fully updated Ibex, nothing has changed and I still cannot transfer any file to my Palm Tungsten E2 (method 1 and method 2)
-> cannot be closed
regards and happy 2009 to you all

phlegm (daveshome) wrote :

Things also started working for me again. I saw the email above and decided to try again. I know it wasn't working a couple of weeks ago but now .... perfect.

Same versions as Alex.

bluetooth: 4.12-0ubuntu5
bluez: 4.12-0ubuntu5
bluez-gnome: 1.8-0ubuntu1
obex-data-server: 0.3.4+svn1951-0ubuntu1

kylea (kylea) wrote :

Ok campers - here is good some news:

I have be playing with Kubuntu 8.10 64 bit (a glutton for punishment I hear you say!!)

Well after mucking around with kdebluetooth4 and stuff - I down graded all 4.25 bluetooth components to 4.12 as suggested by Alex and using bluez-gnome - bluetooth worked !!!

Could pair and send files and use anyremote.

On Mon, Dec 29, 2008, Alex Mayorga Adame wrote:
> Can you please check again with updated packages and confirm if this can be now closed as "Fix Released"?

Nothing has improved for me at all. Both methods of file transfer fail.

bluetooth: 4.12-0ubuntu5
bluez: 4.12-0ubuntu5
bluez-gnome: 1.8-0ubuntu1
obex-data-server: 0.3.4+svn1951-0ubuntu1

lucge (luc-loiseau) wrote :
lucge (luc-loiseau) wrote :

Additional informations of my problem:
My device is a Palm Tungsten E2
Currently with Ibex:
- I can never transfer file from the Ibex PC to the device (like Mary with the 2 methods)
- Sometimes I can transfer a file from the device to the Ibex PC (~1 success every 5 trials)
- Sometimes I can connect to the internet through dund (~1 success every 5 trials)
With Heron, all is OK

Then I compare the behavior between Ibex and Heron when I attempt to send a file to the Palm device.
Previous attachment compare dbus messages during the attempt for both Heron and Ibex.
What surprise me with Ibex record is the number of parameters sent with the command CreateBluetoothSession: We find 3 parameters, but according to http://wiki.muiline.com/obex-data-server/migrating_to_0.4 only 2 are needed.
I tried to upgrade obex_server to version 0.42 but the problem remains the same... with the fact I could not transfer file from the device anymore -> so I came back to the 0.3.4+svn1951-0ubuntu1 version

Next attachment compare the result of the command hcitool info for both Heron and Ibex:
It seems that Ibex is not able to connect to my Palm device for reading its features

I see the same behavior (file transfer to phone fails from both Nautilus and Bluetooth Applet) on 8.10 Intrepid Ibex 64-bit.

I have successfully received files via "gnome-obex-server 0.11.0"
My partnered device is a Blackberry 8230 phone.

ramirand@zygoma:~$ lsb_release -rd
Description: Ubuntu 8.10
Release: 8.10
ramirand@zygoma:~$ uname -a
Linux zygoma 2.6.27-11-generic #1 SMP Thu Jan 29 19:28:32 UTC 2009 x86_64 GNU/Linux

bluetooth: 4.12-0ubuntu5
bluez: 4.12-0ubuntu5
bluez-gnome: 1.8-0ubuntu1
obex-data-server: 0.3.4+svn1951-0ubuntu1

ramirand@zygoma:~$ dmesg | grep -i blue
[ 12.449398] Bluetooth: Core ver 2.13
[ 12.451183] Bluetooth: HCI device and connection manager initialized
[ 12.451186] Bluetooth: HCI socket layer initialized
[ 12.986626] Bluetooth: Generic Bluetooth USB driver ver 0.3
[ 23.406350] Bluetooth: L2CAP ver 2.11
[ 23.406356] Bluetooth: L2CAP socket layer initialized
[ 23.419600] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 23.419604] Bluetooth: BNEP filters: protocol multicast
[ 23.441188] Bluetooth: SCO (Voice Link) ver 0.6
[ 23.441193] Bluetooth: SCO socket layer initialized
[ 23.616247] Bluetooth: RFCOMM socket layer initialized
[ 23.616259] Bluetooth: RFCOMM TTY layer initialized
[ 23.616261] Bluetooth: RFCOMM ver 1.10

Here's /var/lib/bluetooth/<my-adapter-address>/features:
00:23:7A:20:37:36 BFFE8FFE98190080

I can paste or attach the other /var/lib/bluetooth files, too, if they'd be useful.

Changed in bluez:
assignee: alex-mayorga → nobody
Pedro Villavicencio (pedro) wrote :

isn't this the same as bug 282325 ?

Changed in nautilus-sendto (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
lucge (luc-loiseau) wrote :

In my case, problem seems to be related to the USB driver (btdriver)
With the same hardware/software configuration, the problem is solved if I change my bluetooth adapter:

1) The bad one is:
"Bus 002 Device 004: ID 1131:1001 Integrated System Solution Corp. KY-BT100 Bluetooth Adapter"
With that adapter:
Ubuntu 8.04 (with hci-usb driver I think): All is OK with my Palm device: I can send, receive files from the PC and connect to internet without any problem
Ubuntu 8.10 (with btdriver driver I think); I can connect and transfer files sometimes from Palm device to PC (1 time every 5 trials). I can never transfer files from PC to device whatever the metho I use ( nautilus or applet)
Ubuntu 9.04-alpha6 (with btdriver driver I think): I can never transfer files from PC to device whatever the method I use ( nautilus or applet)

2) The correct one is:
"Bus 002 Device 003: ID 0a5c:2121 Broadcom Corp. BCM2210 Bluetooth"
With that adapter all works fine with the 3 Ubuntu versions fully updated except for 8.10 when doing the transfer with Nautilus (BUT always OK if the transfer is done through the applet)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers