Dell Wireless 360 Bluetooth LED Not Working in Latitude D830

Bug #219089 reported by Heikki Toivonen on 2008-04-18
6
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Low
Unassigned

Bug Description

The bluetooth LED does not come on when running Ubuntu on this Dell Latitude D830. It goes on under Windows XP. It flashes briefly when coming from suspend running Ubuntu.

I have seen this with 32-bit 7.10 and 8.04 beta, and 64 bit 8.04 beta with all updates. According to logs and the lighting up on Windows XP it seems like bluetooth actually works, and it is only the LED that does not come on under Ubuntu.

(Incidentally, I have the same issue on my D820 although not sure if same bluetooth hardware, tried with dapper to gutsy in 32 and 64 bit modes. I have used bluetooth fine on that computer.)

$ dmesg|grep -i blue
[ 22.492809] Bluetooth: Core ver 2.11
[ 22.492938] Bluetooth: HCI device and connection manager initialized
[ 22.492940] Bluetooth: HCI socket layer initialized
[ 22.512155] Bluetooth: HCI USB driver ver 2.9
[ 29.244192] Bluetooth: L2CAP ver 2.9
[ 29.244200] Bluetooth: L2CAP socket layer initialized
[ 29.399116] Bluetooth: RFCOMM socket layer initialized
[ 29.399140] Bluetooth: RFCOMM TTY layer initialized
[ 29.399144] Bluetooth: RFCOMM ver 1.8

$ sudo /usr/sbin/dellWirelessCtl --st_bt
Radio Status for Bluetooth:
 Bluetooth supported
 Bluetooth installed
 Bluetooth enabled
 Status Code: 0

Mario Limonciello (superm1) wrote :

Try turning it on by flipping the switch on and doing this:

sudo dellWirelessCtl --sw_bt 1 --bt 1

Changed in bluez:
importance: Undecided → Low
status: New → Incomplete
Heikki Toivonen (hjtoi) wrote :

I tried that command both on the D830 and D820, and the bluetooth LED did not come on. This is the output from the command:

Wireless Info:
 Hardware switch supported
 Hardware switch is On
 WiFi Locator supported
 Wireless Keyboard not supported
 NVRAM Size: 256 bytes
 NVRAM format version: 1

Radio Status for WLAN:
 WLAN supported
 WLAN installed
 WLAN enabled
 Status Code: 0

Radio Status for Bluetooth:
 Bluetooth supported
 Bluetooth installed
 Bluetooth enabled
 Status Code: 0

Radio Status for WWAN:
 WWAN supported
 WWAN not installed
 WWAN enabled
 Status Code: 2

Wireless Switch Configuration
 WLAN switch control on
 Bluetooth switch control on
 WWAN switch control on
 switch config not locked
 WiFi locator enabled
 WiFi Locator config not locked

Heikki Toivonen (hjtoi) wrote :

By the way, Bluetooth light does not work in my Dell Inspiron 9300 either.

Here are links to my writeups of these machines:

http://www.heikkitoivonen.net/UbuntuHardyHeron64bitOnDellLatitudeD830.html
http://www.heikkitoivonen.net/linux/ubuntu-8.04-d820.html
http://www.heikkitoivonen.net/linux/ubuntu-8.04-9300.html

Carlos Perelló Marín (carlos) wrote :

I'm having the same problem with my Lenovo Thinkpad X61s. It used to work with Intrepid, but I moved to jaunty and it stop working (the led). The bluetooth device works without problems.

Mario Limonciello (superm1) wrote :

Is the LED just not working, or the bluetooth device itself? Eg can you pair and what not? Can you turn it on in windows first, does it then work in Ubuntu?

Carlos Perelló Marín (carlos) wrote :

Bluetooth works without problems, but recently, I used it on Windows and seems like whatever caused the problem, is affecting Windows too now, the led does not work anymore so I'm not sure whether my problem is directly related with this or is just that something in Linux 'disabled' or 'broke' the led, no idea...

Mario Limonciello (superm1) wrote :

If it's not working in Windows, then its sounding like a hardware bug. I'd go through warranty services.

Changed in bluez (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers