Enable MIDI support

Bug #1713017 reported by wvengen on 2017-08-25
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Wishlist
Unassigned

Bug Description

Now that bluez has landed with 5.46-0ubuntu2, it would be nice to enable Bluetooth MIDI support. This did not seem to be enabled by default in the build from https://launchpad.net/ubuntu/+source/bluez/5.46-0ubuntu2 (it found BLE MIDI devices, gatttool could talk to them, but no MIDI device was made; also ldd showed no linkage to libasound.so.2).

After recompiling it with libasound2-dev installed and --enable-midi in debian/rules, it worked.

Suggestion: add libasound2-dev to bluez dependencies, add --enable-midi to rules.

Daniel van Vugt (vanvugt) wrote :

Very interesting suggestion. Yes I think we should do this. Since it's a feature rather than a bug though, we would either need to request an exception to get it into 17.10, or wait till 18.04.

Changed in bluez (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
wvengen (wvengen) wrote :

Thanks, I agree that 18.04 would be good.

wvengen (wvengen) wrote :

For those seeking a workaround, see instructions here: https://gist.github.com/wvengen/7ebd29da38c08540832fb228c4628171#bluez-546

Andrew M (primary-edw) wrote :

Any chance this could be added? I know the last message is from 2017, but there commercial products such as the Yamaha MD-BT01 Bluetooth Wireless MIDI Adaptor that rely on this being enabled.

korakios (korakios667) wrote :

I tried the latest version (5.50) from

https://launchpad.net/~bluetooth/+archive/ubuntu/bluez

without success. Is bluetooth midi completely disabled on Ubuntu?

Sebastien Bacher (seb128) wrote :

The option is off by default in the upstream build see
https://git.kernel.org/pub/scm/bluetooth/bluez.git/tree/README#n252

Since the option is flagged experimental by upstream it doesn't seem like something we want to enable in Ubuntu yet

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers