Deprecated rfcomm.conf still mentioned in bluetooth.conf and README

Bug #1674680 reported by Dariusz Gadomski
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bluez (Debian)
New
Undecided
Unassigned
bluez (Ubuntu)
Low
Dariusz Gadomski
Xenial
Low
Unassigned
Yakkety
Low
Unassigned
Artful
Low
Dariusz Gadomski

Bug Description

[Impact]

 * The package contains misleading documentation mentioning the use of /etc/bluetooth/rfcomm.conf for rfcomm setup while the support for config file has been dropped after 14.04 release. I have directly received a question about it from a user mislead by the documentation.

* Additionally deprecated -f option is still used in legacy upstart /etc/init/bluetooth.conf. Actually this does not seem longer required due to upstart being removed.

[Test Case]

 * Install bluez.

 * Look for misleading rfcomm.conf mentions in /etc/init/bluetooth.conf, /usr/share/doc/bluez/README.Debian.gz

[Regression Potential]

 * This is mostly a documentation correction, however if somebody still depends bluetooth started with Ubuntu 16.04+ by upstart (or possibly some kind of upstart compatibility in systemd, is that even possible?) he/she may end up with bluetooth not being started. This seems highly unlikely.

[Other Info]

 * Original bug description:

Support for config files has been dropped upstream in 2012 (however version shipped with Trusty still supports it), but the latest versions (including Xenial and Zesty) still mention it in the docs and in the legacy /etc/init/bluetooth.conf file.

Additionally the /etc/init/bluetooth.conf don't seem necessary these days. In fact it has been dropped by Debian already.

Tags: sts Edit Tag help
summary: - Dropped rfcomm.conf still mentioned
+ Deprecated rfcomm.conf still mentioned
description: updated
Revision history for this message
Dariusz Gadomski (dgadomski) wrote : Re: Deprecated rfcomm.conf still mentioned

Patch proposal for Zesty.

tags: added: sts sts-sponsor
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "zesty_bluez_5.43-0ubuntu2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Mathew Hodson (mhodson)
Changed in bluez (Ubuntu):
importance: Undecided → Low
description: updated
Mathew Hodson (mhodson)
Changed in bluez (Ubuntu Xenial):
importance: Undecided → Low
Changed in bluez (Ubuntu Yakkety):
importance: Undecided → Low
Dave Chiluk (chiluk)
tags: added: sts-sponsor-chiluk
Revision history for this message
Dave Chiluk (chiluk) wrote :

Just so you know I'm waiting for zesty release before uploading this. I don't want to risk causing issues on the release media. Additionally policy is to only push high priority bug fixes for the few weeks leading up to release.

summary: - Deprecated rfcomm.conf still mentioned
+ Deprecated rfcomm.conf still mentioned in bluetooth.conf and README
Revision history for this message
Eric Desrochers (slashd) wrote :

Hi Dariusz,

Since no upload has been done since last April for this particular bug, this now need to be in devel release, thus Artful, before proceeding with affected stable releases (if relevant).

I would suggest you prepare a debdiff for Artful get it sponsored by a CoreDev, and then I'll be able to help with the SRU sponsorship for the affected stable releases (again if relevant)

Regards,
Eric

Changed in bluez (Ubuntu Yakkety):
status: New → Won't Fix
Revision history for this message
Dariusz Gadomski (dgadomski) wrote :

Artful patch proposal.

Dave Chiluk (chiluk)
tags: removed: sts-sponsor-chiluk
Revision history for this message
Dariusz Gadomski (dgadomski) wrote :

Patch proposal for Artful.

Revision history for this message
Dave Chiluk (chiluk) wrote :

Sponsored artful.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 5.45-0ubuntu4

---------------
bluez (5.45-0ubuntu4) artful; urgency=medium

  * Drop deprecated rfcomm.conf and upstart config. (LP: #1674680)

 -- Dariusz Gadomski <email address hidden> Mon, 07 Aug 2017 13:29:41 +0200

Changed in bluez (Ubuntu Artful):
status: New → Fix Released
Eric Desrochers (slashd)
tags: removed: patch
Changed in bluez (Ubuntu Xenial):
status: New → Won't Fix
Changed in bluez (Ubuntu Artful):
assignee: nobody → Dariusz Gadomski (dgadomski)
Dan Streetman (ddstreet)
tags: removed: sts-sponsor
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers