Bluetooth search gets nothing on Dell XPS 15 9550

Bug #1589889 reported by Nara Huang on 2016-06-07
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Medium
ethan.hsieh

Bug Description

Title: Bluetooth search gets nothing on Dell XPS 15 9550

Summary:
Bluetooth search gets nothing on Dell XPS 15 9550

Steps:
1. Open Bluetooth Setting
2. Click "+" to search nearby bluetooth devices

Expected results: BT search could get nearby BT devices

Actual results: Nothing shows from BT search

Additional information:
BT device:
Bus 001 Device 002: ID 0a5c:6410 Broadcom Corp.
Couldn't open device, some information will be missing
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 2.00
  bDeviceClass 255 Vendor Specific Class
  bDeviceSubClass 1
  bDeviceProtocol 1
  bMaxPacketSize0 64
  idVendor 0x0a5c Broadcom Corp.
  idProduct 0x6410

CPU: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz (8x)

GPU: 00:02.0 VGA compatible controller: Intel Corporation HD Graphics 530 (rev 06)

Manufacturer: Dell

ProductName: XPS 15 9550

BiosVersion: 01.02.00

Nara Huang (narahuang) wrote :

Lsusb: n/a

Changed in ubuntu:
status: New → Confirmed
Nara Huang (narahuang) wrote :

Automatically attached

Nara Huang (narahuang) wrote :

Automatically attached

Nara Huang (narahuang) wrote :

Automatically attached

Nara Huang (narahuang) wrote :

Automatically attached

Nara Huang (narahuang) wrote :

Automatically attached

Nara Huang (narahuang) wrote :

Automatically attached

description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1589889/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Nara Huang (narahuang) on 2016-06-08
affects: ubuntu → bluez (Ubuntu)
Anthony Wong (anthonywong) wrote :

Firmware is missing:

[ 3.479417] bluetooth hci0: Direct firmware load for brcm/BCM-0a5c-6410.hcd failed with error -2
[ 3.479421] Bluetooth: hci0: BCM: Patch brcm/BCM-0a5c-6410.hcd not found

I'm having same issue. Is the directory mentioned part of linux-firmware ? I think the directory where the file is missing is /lib/firmware/brcm/ ?

After some digging, as suggested in http://ubuntuforums.org/showthread.php?t=2317843 says:
"""
Following https://bbs.archlinux.org/viewtopic.php?id=204739 I downloaded the missing firmware file (thanks @ZombieMeat) at Dropbox and copied it to /lib/firmware/brcm/
"""
Actually that worked. Attaching file that fixed it

Updated firmware with latest one (version 481).

Same as last one, decompress it, and ensure the permissions are correct on:

-rw-r--r-- 1 root root 54734 may 19 21:22 /lib/firmware/brcm/BCM-0a5c-6410.hcd

When loaded you should see something this on 'dmesg' like:

[ 6828.577574] Bluetooth: hci0: BCM (001.001.005) build 0481

After more digging on how this works, looks like several broadcom chips have similar problems to load this type of files (bug #1129865, bug #1065400). According to a question in askubuntu (also best place of how the procedure to produce this .hcd files) http://askubuntu.com/questions/632336/bluetooth-broadcom-43142-isnt-working-on-ubuntu , there are some legal problems that don't allow this firmware files to be added to the Ubuntu installation

Thanks a lot to @bertusrex on http://ubuntuforums.org/showthread.php?t=2317843&p=13514092#post13514092 for getting into windows and getting us the firmware file.

Pascal Morin (pcm689) wrote :

@Ethan

4$ got the system (@home). He will send it to the office this week so you can investigate the problem.

Changed in bluez (Ubuntu):
importance: Undecided → Medium
assignee: nobody → ethan.hsieh (ethan.hsieh)
Changed in bluez (Ubuntu):
status: Confirmed → In Progress
Changed in bluez (Ubuntu):
status: In Progress → Confirmed

Looks like nowadays you can download this firmware files from microsoft site? (this can enable us to automate this installation somehow on Ubuntu, AFAIK).

1. a Github site that generates this files https://github.com/winterheart/broadcom-bt-firmware
2. the Microsoft URL: http://www.catalog.update.microsoft.com/Search.aspx?q=Broadcom+bluetooth

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers