Annoying "call from" message when connecting Bose devices

Bug #1553669 reported by Rajinder Yadav on 2016-03-06
116
This bug affects 24 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Medium
Unassigned
pulseaudio (Ubuntu)
Medium
Unassigned

Bug Description

I have a bluetooth Bose OE SoundLink working on Kubuntu 15.10 but each time I initially connect to listen to an audio or video, I hear an annoying "Call from" on my headset. My headset seems to think a connection to a phone call is taking place. This is annoying because the audio will start to play and after a little while the "call from" voice talks over the audio.

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu. Ubuntu 15.10 (wily) reached end-of-life on July 28, 2016.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

Please upgrade to the latest version and re-test.

Changed in bluez (Ubuntu):
status: New → Incomplete
Jan Saell (jansaell) wrote :

I can confirm that its still exists in ubuntu 16.04 (well kubuntu 16.04 - but i guess that bluetooth is the same)

tags: added: wily xenial
Changed in bluez (Ubuntu):
status: Incomplete → Confirmed
summary: - Annoying call from message
+ Annoying "call from" message

Can reproduce the same with 16.04.3 and Bose QC35 headphones.

Changed in pulseaudio (Ubuntu):
status: New → Confirmed
tags: added: a2dp
summary: - Annoying "call from" message
+ Annoying "call from" message when connecting Bose devices
Daniel van Vugt (vanvugt) wrote :

I have a theory that Bose devices are probably just noticing they've been connected in HSP mode by default and that's when they say "call from". In that case this might be fixed with bug 1720684, so keep an eye on that one.

tags: added: bose

This problem is still present in Ubuntu 17.10.

Daniel van Vugt (vanvugt) wrote :

Can anyone affected tell if Ubuntu 18.04 has fixed this? (I'm thinking about the fix for bug 1720684)

tags: added: artful
Rajinder Yadav (rajinder-yadav) wrote :

Hello All,

For me the problem went away after I upgraded to Kubuntu 16.10. I no longer have a Linux box available to check with. However to those still experiencing the problem, first make sure you disabled the voice prompt on your bose headset:

https://www.bose.com/en_us/support/article/disabling-voice-prompts-soundlink-mini-ii.html

Verify prompt is disabled before testing. This is how the bug was manifesting for me initially.

Krasi (krasi-georgiev) wrote :

@Hélio can you share exactly which step fixed this issue for you?

@Krasi,

do a complete reinstall not upgrade. If you have your (User) home directory on a separate partition, then old system settings in hidden folders will exist to give your problems even with a fresh install.

To be sure back-up important User files then do a complete fresh install and format the partition you are installing Linux.

Better yet before you go this route and you have a spare drive, try installing the latest version on a separate disk, then you can dual boot while you verify if the problem has been fixed. This might be the more paranoid approach if you're scared to lose important files due to forgetting to back them up.

Hope this helps.

Christopher Berner (cberner) wrote :

I tried following the directions to disable LE (https://askubuntu.com/questions/833322/pair-bose-quietcomfort-35-with-ubuntu-over-bluetooth), but that didn't help. This is running on a fresh install of 18.04. I only hear the "call from" message when in HSP/HFP mode. A2DP works fine

tags: added: bionic

This is issue is still present in Ubuntu 18.04.

Seppe Lenders (seppe-lenders) wrote :

Since this is the first hit on Google, I'd like to elaborate on cberner's solution: you should choose the "A2DP Sink" profile in the "Output" tab of the Sound settings. The "A2DP Source" profile in the "Input" tab doesn't seem to work.

Haotian Teng (havens2) wrote :

Confirm that by switch the mode from HSP/HFP to A2DP Sink solve the problem.

Changed in bluez (Ubuntu):
importance: Undecided → Medium
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
Christopher Berner (cberner) wrote :

I seems that HSP/HFP doesn't work at all on 18.04. I've tried a variety of different Pulseaudio modules/settings, and also ofono. @vanvugt do you know if a different issue tracks that?

Daniel van Vugt (vanvugt) wrote :

Yes, see bug 1768625.

Daniel van Vugt (vanvugt) wrote :

Also see bug 1771040 ;)

This just started happening to me and I realized its after I used my headphones in a conference call. Selecting the headphone input in Sound Settings silently switched the output profile to HSP/HFD mode. The only "bug" here is that when the call ended and I turned off the microphone (selecting a different input device) it didn't restore A2DP output, so you have to do it manually.

With that manual selection, "call from" is gone.

joes (joesken) wrote :

Can confirm the same behaviour. Using LE-Bose QC35 II on Ubuntu 18.04.4 LTS.

Switching to A2DP stops the "Call from.." prompts on the headphones but it also then deselects it as an input device. (I think this is correct for A2DP).

Selecting HSP/HFP or going back and selecting Bose QC35 II as an input device (which has the effect of selecting HSP/HFP) means the "Call from.." prompt comes back.

Banui (banui) wrote :

The bug manifests on v.19.10 too. I have experienced it also in past on v.^16 and v.^18.

David Mortals (davidmortals) wrote :

This problem is still present in Ubuntu 20.04 (DEV).

Daniel van Vugt (vanvugt) wrote :

As hinted in comment #8, disabling voice prompts on the Bose device may help. To do that, press and hold the + and - buttons simultaneously until you hear “voice prompts off.”

tags: added: eoan focal
removed: artful wily

I too had this problem in 18.04, and now in 20.04. I am unable to use the headphones for conferencing.

Reshad Dernjani (reshadd94) wrote :

Same issue here on Ubuntu 20.04 5.6.4 Kernel.
Logitech MX3 Mouse works. Keyboard does pair difficult. When it pairs connection flickers on off. Same issue with Bose SoundSport headset and Samsung Q90R soundbar.

If you need logs please provide commands.

M M (m-connect-io-m) wrote :

I've had this issue since 16.04. How is it that we've gone through 3 LTS releases without a fix? What is the technical challenge with getting a Bluetooth LE headset paired for use as a headset? What is going on?

Daniel van Vugt (vanvugt) wrote :

As suggested in comment #8, please try disabling voice prompts. That seems to work on a variety of Bose devices:

  https://www.bose.com/en_us/support/article/disabling-voice-prompts-soundlink-mini-ii.html

If you would like to discuss the problem further then it would probably be best to report it to the developers here:

  BlueZ: https://bugzilla.kernel.org/enter_bug.cgi?product=Drivers&component=Bluetooth
  PulseAudio: https://gitlab.freedesktop.org/groups/pulseaudio/-/issues

No one has yet(?)

I can confirm that the error persist on Ubuntu 20.04 LTS with headphones LE-Bose AE2 SoundLink.

Disabling voice prompts (as Daniel van Vugt mentioned in comment #8) helps a lot, but still there is a whistle but no "call from" voice anymore.

tags: removed: eoan
thinkpad (fellowsgarden) wrote :

bump (Ubuntu 20.04.1 LTS, 5 Nov 2020).

thinkpad (fellowsgarden) wrote :

(PS: all along I thought my headphones had dropped once too often... only now discovered by chance that it's a Ubuntu-related bug.)

Jonas (thesaltyj) wrote :

I am having the same issue with ubuntu 20.04 - super annoying! I even bought new headphones (the same model) but having the same troubles... Bose support cannot really help and they are "not aware of the issue"

Ninj (ninjds) wrote :

2021, Ubuntu 20.04.2 and this is still not fixed.

Some answers here don't seem acceptable. We keep getting advised to turn voice notifications off. Well, that's a headset feature I needed, and even made me buy this Bose. We probably like or need the voice notification, you cannot just suggest to remove the safety belt in your car if it's blocked.

Windows handles the bluetooth much better in my opinion, so what is the difference? Can't the BT behaviour just be reproduced on Ubuntu? Why does A2DP prevents the mic from being used? Or why does the HSP format introduces the "Call from"..." message? How does Windows allows to both use the mic and have no voice message?

Well, I believe Windows uses some kind of mode called "Communication", which must be selected on both input and output. At least that's what I do and it works smoothly. Would that be a hint?

This bug is very annoying however, and still not assigned to anyone. I don't get that (QC35 is the most used headset at work in the world I think)

Daniel van Vugt (vanvugt) wrote :

I suggest you should report it to the developers of PulseAudio since that's the component that implements Bluetooth audio:

  https://gitlab.freedesktop.org/groups/pulseaudio/-/issues

Less likely, you might need to report it to the BlueZ Bluetooth developers:

  https://bugzilla.kernel.org/enter_bug.cgi?product=Drivers&component=Bluetooth

When done, please tell us the new issue ID here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers