Pulseaudio + Bluetooth Sap Failed Sink Creation

Bug #1524600 reported by Vindicator
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned

Bug Description

I was listening to music through my bluetooth headset earlier today with no issues.
I did step outside and had a little issue with the distance, but the connection never dropped.

I was about to listen to some more. Headset connected according to the GUI, but a sound test did not work, and of course no music would play.

I figured bluez was the more appropriate package to file this under, but I also did generate a bug report for the pulseaudio pid which I'll attach.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: bluez 5.35-0ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-21.25-generic 4.2.6
Uname: Linux 4.2.0-21-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
Date: Wed Dec 9 22:30:04 2015
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/bluetooth/bluetoothd
InstallationDate: Installed on 2015-10-28 (42 days ago)
InstallationMedia: Ubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
InterestingModules: rfcomm bnep btusb bluetooth
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-21-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro noprompt quiet splash elevator=cfq vt.handoff=7
SourcePackage: bluez
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/27/2015
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.80
dmi.board.name: H97M-ITX/ac
dmi.board.vendor: ASRock
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.80:bd07/27/2015:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASRock:rnH97M-ITX/ac:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.
hciconfig:
 hci0: Type: BR/EDR Bus: USB
  BD Address: 4C:BB:58:4A:7F:7E ACL MTU: 820:8 SCO MTU: 255:16
  DOWN
  RX bytes:5319 acl:54 sco:0 events:423 errors:0
  TX bytes:125713 acl:222 sco:0 commands:155 errors:0

Revision history for this message
Vindicator (vindicator) wrote :
Revision history for this message
Vindicator (vindicator) wrote :

And after a fresh reboot (just making sure because I thought I had had to reboot before), it STILL isn't working.
"bluetoothd[853]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)"
And "$ sudo rfcomm -a" doesn't show ANY device.

Revision history for this message
Vindicator (vindicator) wrote :

Eh, go figure. I tried connecting to S705 headset to my smartphone, and while it also was able to connect, android kitkat only wanted to send the audio to my speaker.
Must have been something IN the S705. It didn't matter that I had turned it off, charged it and tried it with both devices.
I went ahead and "forgot" both devices and the S705 on each, then paired it back starting with my smartphone and that worked.
After I finished what I was working on, I just tried 15.10 as well and that is now working too.

Sometimes tech just torques me the wrong way. :(

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu. Ubuntu 15.10 (wily) reached end-of-life on July 28, 2016.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

Please upgrade to the latest version and re-test.

Changed in bluez (Ubuntu):
status: New → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for bluez (Ubuntu) because there has been no activity for 60 days.]

Changed in bluez (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers