Bluetooth initiated after quitting airplane mode

Bug #1488170 reported by Stefan on 2015-08-24
192
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
John McAleely
bluez (Ubuntu)
High
Konrad Zapałowicz
urfkill (Ubuntu)
Undecided
Unassigned

Bug Description

This happens despite bluetooth not being enabled when entering airplane mode.

On Aquaris E5 OTA-5.

Boot with bluetooth disabled
Turn on flight mode
turn off flight mode
Bluetooth gets enabled

See bug #1421249 for related symptoms

Stefan (boldos) wrote :

Oh - this happens only "sometimes".

melanie witt (melwitt) on 2015-09-10
no longer affects: python-novaclient
Simon Fels (morphis) on 2015-09-15
affects: ubuntu-system-image → bluez (Ubuntu)
tags: added: after-bluez5 bluetooth
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Changed in urfkill (Ubuntu):
status: New → Confirmed
description: updated
Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
importance: Undecided → High
status: New → Confirmed
Sven (sdiedrichsen) wrote :

Also experienced on Aquaris E5 OTA-6

Bill Filler (bfiller) on 2015-11-04
Changed in bluez (Ubuntu):
assignee: nobody → Simon Fels (morphis)
importance: Undecided → High

Still happens on OTA-8

Changed in canonical-devices-system-image:
milestone: none → ww02-2016
Tony Espy (awe) wrote :

I'm able to reproduce it every time on a krillin running OTA8.5 ( bluez4 userspace ):

phablet@ubuntu-phablet:~$ system-image-cli -i
current build number: 26
device name: mako
channel: ubuntu-touch/stable/ubuntu
last update: 2015-12-22 23:02:17
version version: 26
version ubuntu: 20151210
version tag: OTA-8.5
version device: 20150911
version custom: 20151210

Can't reproduce on mako running OTA8.5 ( bluez4 userspace ):

phablet@ubuntu-phablet:~$ system-image-cli -i
current build number: 26
device name: mako
channel: ubuntu-touch/stable/ubuntu
last update: 2015-12-22 23:02:17
version version: 26
version ubuntu: 20151210
version tag: OTA-8.5
version device: 20150911
version custom: 20151210

Can't reproduce on arale running OTA-8.5 ( stable/meizu.en #8 ); tested both with and without a valid SIM card.

I can reproduce this on BQ Aquaris E4.5 - krillin - rc-proposed r277 (released today) and this bug is really annoying. :)

Changed in canonical-devices-system-image:
milestone: ww02-2016 → ww04-2016
Changed in canonical-devices-system-image:
milestone: ww04-2016 → ww08-2016

I cannot reproduce this on kirillin and frieza running recent rc-proposed channels.

It has been a while since I experienced this bug. It is possible that it
has been fixed during one of the OTA's.

2016-03-02 12:08 GMT+01:00 Konrad Zapałowicz <
<email address hidden>>:

> I cannot reproduce this on kirillin and frieza running recent rc-
> proposed channels.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1436721).
> https://bugs.launchpad.net/bugs/1488170
>
> Title:
> Bluetooth initiated after quitting airplane mode
>
> Status in Canonical System Image:
> Confirmed
> Status in bluez package in Ubuntu:
> Confirmed
> Status in urfkill package in Ubuntu:
> Confirmed
>
> Bug description:
> This happens despite bluetooth not being enabled when entering
> airplane mode.
>
> On Aquaris E5 OTA-5.
>
> Boot with bluetooth disabled
> Turn on flight mode
> turn off flight mode
> Bluetooth gets enabled
>
> See bug #1421249 for related symptoms
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1488170/+subscriptions
>

Good, I will mark this as Fix Commited then and we will take it from there.

Changed in bluez (Ubuntu):
status: Confirmed → Fix Committed
Simon Fels (morphis) on 2016-03-10
tags: added: bluetooth-ota10
Simon Fels (morphis) on 2016-03-11
Changed in urfkill (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Gabriele (gabrielemartelli) wrote :

HI.
No. Unfortunately it happened to me this morning on my BQ 4.5 . My phone is updated to the latest available OTA ...

g

Pat McGowan (pat-mcgowan) wrote :

@gabriele This is not yet released, just fix committed, so next OTA will resolve it

@Pat

afaik, the status was changed to 'fix committed' because I said I haven't experienced it in a while; not because a fix was actually committed

Tommi Tervo (tommi-tervo) wrote :

Well, I can easily reproduce this bug with vegetahd r272.

I tested this when bug marked as fixed and then I could not reproduse this
problem. But after I arrived to Barcelona last Sat, bug reappeared.

BR,
Tommi

On Friday, March 11, 2016, Merlijn Sebrechts <email address hidden>
wrote:
> @Pat
>
> afaik, the status was changed to 'fix committed' because I said I
> haven't experienced it in a while; not because a fix was actually
> committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1488170
>
> Title:
> Bluetooth initiated after quitting airplane mode
>
> Status in Canonical System Image:
> Fix Committed
> Status in bluez package in Ubuntu:
> Fix Committed
> Status in urfkill package in Ubuntu:
> Invalid
>
> Bug description:
> This happens despite bluetooth not being enabled when entering
> airplane mode.
>
> On Aquaris E5 OTA-5.
>
> Boot with bluetooth disabled
> Turn on flight mode
> turn off flight mode
> Bluetooth gets enabled
>
> See bug #1421249 for related symptoms
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1488170/+subscriptions
>

Pat McGowan (pat-mcgowan) wrote :

Right you are, I just reproduced it easily as described.

Changed in canonical-devices-system-image:
status: Fix Committed → Confirmed
Changed in bluez (Ubuntu):
status: Fix Committed → Confirmed
Pat McGowan (pat-mcgowan) wrote :

its happening every time for me

Turn off bluetooth in the indicator
Long press power and restart
from the greeter, pull down the network indicator and enable flight mode
Once flight mode is active, disable flight mode
Close the indicator and see the bluetooth icon light up, check the indicator and its enabled

The log contains

At boot:

Mar 11 15:18:44 ubuntu-phablet URfkill[1135]: adding killswitch type 2 idx 0 soft 0 hard 0
Mar 11 15:18:44 ubuntu-phablet URfkill[1135]: Setting device 0 (BLUETOOTH) to blocked
Mar 11 15:18:44 ubuntu-phablet URfkill[1135]: set_soft: Setting BLUETOOTH to blocked
Mar 11 15:18:44 ubuntu-phablet bluetoothd[874]: src/rfkill.c:rfkill_event() RFKILL event idx 0 type 2 op 2 soft 1 hard 0
Mar 11 15:18:44 ubuntu-phablet kernel: [ 10.443882]rfkill: input handler disabled
Mar 11 15:18:44 ubuntu-phablet URfkill[1135]: <warning> Reading of RFKILL events failed
Mar 11 15:18:44 ubuntu-phablet URfkill[1135]: Setting WLAN devices to unblocked
Mar 11 15:18:44 ubuntu-phablet URfkill[1135]: Setting BLUETOOTH devices to blocked
Mar 11 15:18:44 ubuntu-phablet URfkill[1135]: set_soft: Setting BLUETOOTH to blocked

...

Flight mode enabled:

Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: urf_killswitch_soft_block_cb: all done
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: handle_flight_mode_killswitch: killswitch[BLUETOOTH] state: UNBLOCKED block: 1
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: Setting BLUETOOTH devices to blocked
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: set_soft: Setting BLUETOOTH to blocked
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: urf_killswitch_soft_block_cb: all done
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: handle_flight_mode_killswitch: killswitch[UWB] state: NO_ADAPTER
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: handle_flight_mode_killswitch: killswitch[WIMAX] state: NO_ADAPTER
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: handle_flight_mode_killswitch: killswitch[WWAN] state: UNBLOCKED block: 1
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: Setting WWAN devices to blocked
Mar 11 15:19:28 ubuntu-phablet URfkill[1135]: set_soft: Setting WWAN to blocked

...

Flight mode disabled:

Mar 11 15:19:54 ubuntu-phablet URfkill[1135]: Setting BLUETOOTH devices to unblocked
Mar 11 15:19:54 ubuntu-phablet URfkill[1135]: set_soft: Setting BLUETOOTH to unblocked
Mar 11 15:19:54 ubuntu-phablet bluetoothd[874]: src/rfkill.c:rfkill_event() RFKILL event idx 0 type 2 op 2 soft 0 hard 0
Mar 11 15:19:54 ubuntu-phablet URfkill[1135]: urf_killswitch_soft_block_cb: all done

Pat McGowan (pat-mcgowan) wrote :

rfkill list outputs

Before restart
0: hci0: Bluetooth
 Soft blocked: yes
 Hard blocked: no
2: phy1: Wireless LAN
 Soft blocked: no
 Hard blocked: no

After boot

0: hci0: Bluetooth
 Soft blocked: yes
 Hard blocked: no
1: phy0: Wireless LAN
 Soft blocked: no
 Hard blocked: no

Flight mode enabled

0: hci0: Bluetooth
 Soft blocked: yes
 Hard blocked: no

Flight mode disabled

0: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no
2: phy1: Wireless LAN
 Soft blocked: no
 Hard blocked: no

Pat McGowan (pat-mcgowan) wrote :

log with debug on for bluetooth and urfkill

Changed in urfkill (Ubuntu):
status: Invalid → Confirmed
Stefan (boldos) wrote :

Yep - happened to me again this morning on E5.

BTW: This is still to be confirmed, but it seems this issue *might* be present also on a desktop (x86) Ubuntu 15.10??!!
I'm using suspend resume on my 2 notebooks, and it *seems* that bluetooth gets started withtout any reason, but only sporadically, after a resume. Will follow this and confirm...

Stefan (boldos) wrote :

Ok, that was quick....
Now I can confirm that similar issue with bluetooth being started-up automatically sometimes also happens on x86 Ubuntu 15.10 desktop.

Changed in canonical-devices-system-image:
milestone: ww08-2016 → 11
Stefan (boldos) wrote :

Still happens under OTA-10.

Changed in bluez (Ubuntu):
assignee: Simon Fels (morphis) → Konrad Zapałowicz (kzapalowicz)
Changed in canonical-devices-system-image:
milestone: 11 → 12
Gregory Opera (gregoryopera) wrote :

I experience this under Ubuntu 10.1 also.

--

Reproduce:
- Ensure that bluetooth is DISABLED.
- Enable "flight" mode (so that all wireless communications are switched-off).
- Wait a few seconds after all wireless communications has been switched-off, then disable "flight" mode.

Result:
- Wireless connectivity (in my case, connection to a cellular telecommunications network) is restored, but with bluetooth ENABLED.

Expectation:
- Wireless connectivity is restored to the same state it was in when "flight" mode was enabled (i.e. the mobile device remembers the state of wireless networking/Wi-Fi, bluetooth and cellular).

--

bq Aquaris E5 HD Ubuntu Edition
* OS: Ubuntu 15.04 (OTA-10.1)
* OS build number: OTA-10.1
* Ubuntu Image part: 20160408.4
* Ubuntu build description: Ubuntu 15.04 - armf (20160408-211605)
* Device Image part: 20160329-a9bacdb
* Device build description: VEGETA01A-S23A_BQ_L100EN_2012_160408
* Customisation Image [art: 20160324--36-54-vivid

Did something change with this? Because I can't reproduce this any more on my bq Aquaris E4.5 phone with OTA-11. With OTA-10.1 this happened every time.

I cannot reproduce this either. I marked it as incomplete since we are looking for someone who can reproduce it. If nobody can reproduce it, the bug will be closed in x amount of days.

Changed in canonical-devices-system-image:
status: Confirmed → Incomplete

(60 days to be precise)

Buzea Bogdan (bogdanke8) wrote :

I can' t reproduce myself... Was an anoying bug, but it disapaer today with OTA-11 update.

Richard Somlói (ricsipontaz) wrote :

I can't reproduce this either

Pat McGowan (pat-mcgowan) wrote :

Will assume this symptom was also fixed with the new urfkilld landing per bug #1567467

Changed in canonical-devices-system-image:
milestone: 12 → 11
status: Incomplete → Fix Released
Gregory Opera (gregoryopera) wrote :

This appears to have been fixed for me... I cannot reproduce this under the current version of Ubuntu.

--

bq Aquaris E5 HD Ubuntu Edition:
* OS build number: OTA-13
* Ubuntu Image part: 20160913
* Ubuntu build description: Ubuntu 15.04 - armhf (20160913-023544)
* Device Image part: 20160606-540a47f
* Device build description: VEGETA01A-S23A_BQ_L100EN_2015_160913
* Customization Image part: 20160831-991-38-18

Gabriele (gabrielemartelli) wrote :

This appears to have been fixed for me too.

g

Stefan (boldos) wrote :

Appears to be fixed.

Changed in bluez (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers