Bluetooth Will Not Find Attached Adaptor Though lsusb Sees It

Bug #1477955 reported by digitalangel
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned

Bug Description

Upgraded from 12.04 to 14.04 yesterday, where Bluetooth worked fine. I had to do a fresh install of 12.04 and 14.04 upgrade broke (second attempt worked), so probably lost all of the working Bluetooth settings. Makes no sense as PC can see it but not seeing it as Bluetooth adaptor.

hcidump gives “Can't open device: No such device”

lsusb finds the Logitech Bluetooth mini receiver:

"Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 004: ID 046d:c70c Logitech, Inc. BT Mini-Receiver (HID proxy mode)
Bus 004 Device 003: ID 046d:c70b Logitech, Inc. BT Mini-Receiver (HID proxy mode)
Bus 004 Device 002: ID 046d:0b02 Logitech, Inc. C-UV35 [Bluetooth Mini-Receiver] (HID proxy mode)
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub"

Have all bluez, bluedevil and even Blueman installed (from looking at previous issues from people this might have helped).

Release: 14.04.2 LTS
Bluetooth version: 4.101-0ubuntu13.1
Bluedevil: 2.0~rc1really1.3.2.0ubuntu1

I prefer to use LTS releases than every new release but not sure if upgrading will fix the issue anyway!

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: bluetooth 4.101-0ubuntu13.1
ProcVersionSignature: Ubuntu 3.13.0-58.97-generic 3.13.11-ckt22
Uname: Linux 3.13.0-58-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.11
Architecture: amd64
CurrentDesktop: KDE
Date: Fri Jul 24 12:04:41 2015
InstallationDate: Installed on 2015-07-23 (0 days ago)
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120423)
InterestingModules: rfcomm bnep bluetooth
MachineType: System manufacturer System Product Name
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-58-generic root=UUID=47b90882-7cc6-474d-9d54-1539100e1c2c ro quiet splash
SourcePackage: bluez
UpgradeStatus: Upgraded to trusty on 2015-07-23 (0 days ago)
dmi.bios.date: 09/22/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0604
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M5A78L LE
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0604:bd09/22/2011:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM5A78LLE:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
hciconfig:

rfkill:

syslog:

Revision history for this message
digitalangel (uv-goth) wrote :
Revision history for this message
digitalangel (uv-goth) wrote :

It was a hardware specific problem. This works for my Logitech receiver and may also work for other brands...

http://ubuntuforums.org/showthread.php?t=1332197

"There are two modes the dongle works in, Embedded and HCI. By default the embedded is active, which emulates a USB device so it seems to your PC that your using a normal USB mouse/keyoard.

If you hold the little red Button on the USB BT mini-receiver it will enable the other mode. Hold the red button on the BT dongle and plug it into the computer, and after 3-5 seconds of holding the button, the Bluetooth icon will appear in the system tray.

You can then use the adapter as a BT receiver. The adapter continues to work in BT mode after reboots, but I think the occasional BT failure (usually after an update) is caused by the mode changing."

Changed in bluez (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers