bluetooth speaker and suspension issue

Bug #1413363 reported by Dave Morley
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)

Bug Description

1. Open settings bluetooth
2. Turn on your blue tooth speaker
3. Pair the speaker
4. Open the music app
5. Play music
6. Pause the music
7. Let the phone suspend
8. After a while it goes into deep sleep and the speaker disconnects
9. Wake the phone press the play button

I expected the music to play out of the bluetooth speaker

A long pause, then a click then the music plays from the internal speaker. You can no longer get the music to play from the bluetooth speaker.

Things I've tried:
Reboot the phone re connect to the bt speaker music still plays from the loud speaker on the phone.
Turned off the speaker, restarted it still plays through the Loud speaker on the phone

Forget the connection. Re pair the device now press play now it works as expected.

Dave Morley (davmor2)
Changed in bluez-utils (Ubuntu):
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
summary: - bluetooth speak and suspension issue
+ bluetooth speaker and suspension issue
Dave Morley (davmor2)
description: updated
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

Could you also try to re-pair the speaker by pressing a button after the system is resumed?

affects: bluez-utils (Ubuntu) → bluez (Ubuntu)
Changed in bluez (Ubuntu):
status: New → Incomplete
Revision history for this message
Dave Morley (davmor2) wrote :

Mathieu I have pressed the connect button on the phone in setting bluetooth (s10 the device) nothing happens, I have pressed buttons on the speaker and nothing happens, the speakers ready to pair is done automatically on power on so unless it finds a thing it has previously connected to it will sit there beeping at you till the sun goes down or the battery runs out :)

Nothing seems to allow the music to transfer back to the speaker unless I forget it and re pair it from fresh then it works fine till my next meal time :)

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

In that case we'll need the logs from ubuntu-system-settings; on re-connection there should be a message, something like "Host down" or "Connection refused". Perhaps there is something extra we need to do in this particular case for the headset to be happy with re-connecting.

Changed in bluez (Ubuntu):
status: Incomplete → New
status: New → Incomplete
Revision history for this message
Why (recibe-distraction) wrote :

This bug affects uses on x64 platforms also.


Mathieu: rather than require the bug reporter to provide you with log data so that you can sidestep the fix, you could just try to replicate the issue?

A cursory google search shows that bluetooth support on Ubuntu is widely broken.

Revision history for this message
TarotChen (tarotchen) wrote :

I can reproduce this on krillin-rc274 with following steps:

1.Pair a bluetooth speaker
2.Open the music app and play music
3.Turn off the bluetooth speaker (the playback pauses)
4.Wait a few seconds, then turn on the bluetooth speaker
5.Wait until the speaker reconnects
6.Tap on play button to continue playing

->the sound comes from the phone

7.Close music app
8.Launch music app to play music again

-> now, the sound is routed to Bluetooth speaker

Expected result:
The sound should be routed to bluetooth speaker after step 6

Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

No, it's not widely broken. Some things are broken on some hardware, and it's not all broken in the same way, that's why I asked for logs -- so we can know what the actual issue is.

I don't have all the hardware in the world, so I can't reproduce these issues myself.

Dave, if you're still having this issue, could you include the logs as per comment #3?

Why (recibe-distraction), if you think you're seeing this issue on x86, you're actually seeing a different bug. Please file your own bug report, and send me the bug number so I can have a look, but it's most definitely not the "same issue", as this bug here is specific to the bluetooth stack on the Ubuntu Phone.

tags: added: bluez-touch
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Reduced priority for Ubuntu Touch bugs.

Changed in bluez (Ubuntu):
importance: High → Medium
Changed in bluez (Ubuntu):
assignee: Mathieu Trudel-Lapierre (cyphermox) → nobody
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for bluez (Ubuntu) because there has been no activity for 60 days.]

Changed in bluez (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers