bluetoothd crashed with SIGSEGV in server_disconnect()

Bug #1362538 reported by Marcos K
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Medium
Unassigned

Bug Description

at startup

ProblemType: Crash
DistroRelease: Ubuntu 14.10
Package: bluez 4.101-0ubuntu19
ProcVersionSignature: Ubuntu 3.16.0-10.15-generic 3.16.1
Uname: Linux 3.16.0-9-generic x86_64
ApportVersion: 2.14.6-0ubuntu2
Architecture: amd64
Date: Thu Aug 21 02:15:28 2014
ExecutablePath: /usr/sbin/bluetoothd
InterestingModules: bnep rfcomm btusb bluetooth
MachineType: Acer Aspire V5-551
ProcCmdline: /usr/sbin/bluetoothd
ProcEnviron:
 PATH=(custom, no user)
 TERM=linux
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-10-generic.efi.signed root=UUID=bdba8918-495e-47cf-bc7c-8dc076ec2212 ro text nomodeset noplymouth console=tty1 radeon.dpm=1 acpi_backlight=vendor nomdmonddf nomdmonisw
SegvAnalysis:
 Segfault happened at: 0x7fbb97d33e1c <__GI___libc_free+28>: mov -0x8(%rdi),%rax
 PC (0x7fbb97d33e1c) ok
 source "-0x8(%rdi)" (0x00000019) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: bluez
StacktraceTop:
 __GI___libc_free (mem=0x21) at malloc.c:2929
 ?? ()
 ?? ()
 ?? ()
 dbus_connection_try_register_fallback () from /lib/x86_64-linux-gnu/libdbus-1.so.3
Title: bluetoothd crashed with SIGSEGV in __GI___libc_free()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 04/19/2013
dmi.bios.vendor: Insyde Corp.
dmi.bios.version: V2.16
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Havok
dmi.board.vendor: Acer
dmi.board.version: Type2 - A01 Board Version
dmi.chassis.type: 10
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsydeCorp.:bvrV2.16:bd04/19/2013:svnAcer:pnAspireV5-551:pvrV2.16:rvnAcer:rnHavok:rvrType2-A01BoardVersion:cvnChassisManufacturer:ct10:cvrChassisVersion:
dmi.product.name: Aspire V5-551
dmi.product.version: V2.16
dmi.sys.vendor: Acer
hciconfig:
 hci0: Type: BR/EDR Bus: USB
  BD Address: F4:B7:E2:88:01:EE ACL MTU: 1022:8 SCO MTU: 183:5
  UP RUNNING PSCAN ISCAN
  RX bytes:1224 acl:0 sco:0 events:74 errors:0
  TX bytes:2300 acl:0 sco:0 commands:74 errors:0
mtime.conffile..etc.bluetooth.audio.conf: 2014-06-10T23:38:40.331777

Revision history for this message
Marcos K (g-ubuntu-com-y) wrote :
information type: Private → Public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 ?? ()
 server_disconnect (conn=<optimized out>, user_data=0x7fbb9ad85f70) at network/server.c:577
 service_filter (connection=0x7fbb9ad7ebc0, message=<optimized out>, user_data=0x7fbb9adaff30) at gdbus/watch.c:477
 message_filter (connection=0x7fbb9ad7ebc0, message=0x7fbb9ada30b0, user_data=0x0) at gdbus/watch.c:527
 ?? ()

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in bluez (Ubuntu):
importance: Undecided → Medium
summary: - bluetoothd crashed with SIGSEGV in __GI___libc_free()
+ bluetoothd crashed with SIGSEGV in server_disconnect()
tags: removed: need-amd64-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Revision history for this message
Tyson Clugg (tyson-clugg) wrote :

I was looking at the details before letting apport submit the bug and I noticed that the stack trace I was just like the one submitted here having no debug information available. So I ran 'sudo apt-get install bluez-dbg libbluetooth3-dbg', rebooted and the problem went away... it's a hiesenbug. :-/

I'll remove the debug packages one by one rebooting between and report back with any more details I can find.

Revision history for this message
Tyson Clugg (tyson-clugg) wrote :

That's odd - the error had been annoying me every boot for months has now gone, even after "apt-get --purge bluez-dbg; reboot" and then the same for bluez-dbg. To be clear, the last time the error appeared was at boot time before installing both bluez-dbg and libbluetooth3-dbg as per comment #7.

I tried both warm and cold booting (at *every* reboot I've mentioned in this and the other comment) to see if it was some weird state the BIOS was setting on the hardware, but it's not apparent that warm versus cold booting is making any difference.

It appears to me that rebooting with debug libraries installed has either allowed the failing branch of code to complete without error, or caused some alternate branch of code to be executed instead. In either case, the lack of crashing suggests that bluez has saved it's new state in some as yet unresolved location - does bluez keep/alter state anywhere in the code, or am I getting carried away here?

Marcos K: Can you try installing just libbluetooth3-dbg and rebooting? Submit the stack trace if the error persists, then try installing bluez-dbg and rebooting again once again submitting the stack trace if it crashes?

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu. Ubuntu 14.10 (utopic) reached end-of-life on July 23, 2015.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

Please upgrade to the latest version and re-test.

Changed in bluez (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for bluez (Ubuntu) because there has been no activity for 60 days.]

Changed in bluez (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers