Bluetooth menu's content disappeared after resume.

Bug #1303819 reported by Shih-Yuan Lee on 2014-04-07
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

 * It is very annoying to see Bluetooth menu's content disappeared after suspending and resuming when playing music through Bluetooth audio output.
 * The better user experience is still seeing Bluetooth menu's content.

[Test Case]

 * Pairing Bluetooth audio device.
 * Playing music through Bluetooth audio output.
 * Suspending the system.
 * Resuming the system.

[Regression Potential]

 * No obvious regression exists.

[Other Info]

 * The patch is to reset default_adapter_id's value to -1, then it can send the signal 'DefaultAdapterChanged' next time when new default adapter is set.

* Reproducing Steps
1. Playing music through Bluetooth audio ouput.
2. Suspending the system.
3. Resuming the system.
4. Check Bluethooth menu's content

* Expected Result
The Bluetooth menu's content is not affected.

* Actual Result
The Bluetooth menu's content disappeared.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: bluez 4.98-2ubuntu7.1
ProcVersionSignature: Ubuntu 3.5.0-48.72~precise1-generic 3.5.7.31
Uname: Linux 3.5.0-48-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.0.1-0ubuntu17.6
Architecture: amd64
Date: Mon Apr 7 19:08:01 2014
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
InterestingModules: rfcomm bnep btusb bluetooth
MachineType: Dell Inc. Latitude E6230
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.5.0-48-generic root=UUID=8da8a808-6d55-4e04-a813-3f1217ab4f35 ro quiet splash vt.handoff=7
SourcePackage: bluez
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/19/2012
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A05
dmi.board.name: 098M9Y
dmi.board.vendor: Dell Inc.
dmi.board.version: X03
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA05:bd09/19/2012:svnDellInc.:pnLatitudeE6230:pvr01:rvnDellInc.:rn098M9Y:rvrX03:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude E6230
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.
hciconfig:
 hci0: Type: BR/EDR Bus: USB
  BD Address: 74:DE:2B:D4:BB:8E ACL MTU: 1021:8 SCO MTU: 64:1
  UP RUNNING PSCAN
  RX bytes:6082 acl:32 sco:0 events:625 errors:0
  TX bytes:949448 acl:1140 sco:0 commands:45 errors:0

Shih-Yuan Lee (fourdollars) wrote :
Shih-Yuan Lee (fourdollars) wrote :

I uploaded two screenshots, i.e. BluetoothMenuBefore.png and BluetoothMenuAfter.png.
You can compare them to see the problem.

description: updated
tags: added: patch
Sebastien Bacher (seb128) wrote :

Thanks for the work! Do you know if the issue/patch has been reported upstream? That doesn't seem code that is Ubuntu specific, it would probably make sense to send back the fix to bluez?

V字龍(Vdragon) (vdragon) wrote :

@Shih-Yuan
Just curious about the missing "BluetoothMenuAfter.png" :-)
Great work!

Shih-Yuan Lee (fourdollars) wrote :

@seb128,
I don't know if this issue has been reported upstream.
If not, I will try to report it and fix it in upstream.

@vdragon,
Please see 'Bug attachments' in the right to find 'BluetoothMenuAfter.png'.

Bofu Chen (bafu) on 2014-04-09
no longer affects: bluez
affects: bluez (Ubuntu) → dell
Changed in dell:
assignee: nobody → Bofu Chen (bafu)
status: New → Confirmed
status: Confirmed → New
affects: dell → bluez (Ubuntu)
Changed in bluez (Ubuntu):
assignee: Bofu Chen (bafu) → nobody
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :
Changed in bluez (Ubuntu Trusty):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Precise SRU uploaded to queue: https://launchpad.net/ubuntu/precise/+queue?queue_state=1

Unsubscribing sponsors team, subscribing SRU team.

Changed in bluez (Ubuntu Precise):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 4.101-0ubuntu12

---------------
bluez (4.101-0ubuntu12) trusty; urgency=low

  * debian/patches/13_reset_default_adapter_id.patch: Reset default_adapter_id
    when there is no adapter. (LP: #1303819)
 -- Shih-Yuan Lee (FourDollars) <email address hidden> Tue, 08 Apr 2014 10:54:11 +0800

Changed in bluez (Ubuntu Trusty):
status: Fix Committed → Fix Released
V字龍(Vdragon) (vdragon) wrote :

@Shih-Yuan Lee
Thanks for pointing out :-)

Hello Shih-Yuan, or anyone else affected,

Accepted bluez into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/bluez/4.98-2ubuntu7.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bluez (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Shih-Yuan Lee (fourdollars) wrote :

I have verified bluez 4.98-2ubuntu7.2 on precise and it works fine.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for bluez has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez - 4.98-2ubuntu7.2

---------------
bluez (4.98-2ubuntu7.2) precise-proposed; urgency=low

  * debian/patches/13_reset_default_adapter_id.patch: Reset default_adapter_id
    when there is no adapter. (LP: #1303819)
 -- Shih-Yuan Lee (FourDollars) <email address hidden> Tue, 08 Apr 2014 10:30:33 +0800

Changed in bluez (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers