Get rid of 0.5s latency when playing audio over Bluetooth with A2DP

Bug #1211102 reported by Diego Carrera Gallego on 2013-08-11
66
This bug affects 13 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned

Bug Description

1) The release of Ubuntu you are using, via 'lsb_release -rd' or System -> About Ubuntu
Description: Ubuntu 13.04
Release: 13.04

2) The version of the package you are using, via 'apt-cache policy pkgname' or by checking in Software Center
bluez:
  Instalados: 4.101- 0ubuntu8b1
  Candidato: 4.101-0ubuntu8b1
  Tabla de versión:
 *** 4.101-0ubuntu8b1 0
        500 http://es.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status

3) What you expected to happen
The audio always is sync when i listen music on my bluetooth device
If i listen music or have a videoconference with skype.. it receive audio perfectly without delay.

4) What happened instead
 I experience a half a second delay when playing audio over Bluetooth with A2DP.
This makes watching movies not possible as the sound is not synchronised with the video.

+ If i listen music, then stop about 5 minutes and then restart to listen music, it gets work bad.
+ If i get a skype videoconference, it gets too much delay.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: bluez 4.101-0ubuntu8b1
ProcVersionSignature: Ubuntu 3.8.0-27.40-generic 3.8.13.4
Uname: Linux 3.8.0-27-generic x86_64
ApportVersion: 2.9.2-0ubuntu8.3
Architecture: amd64
Date: Mon Aug 12 01:24:24 2013
InstallationDate: Installed on 2013-07-13 (29 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
InterestingModules: rfcomm bnep btusb bluetooth
MachineType: ASUSTeK Computer Inc. UX31E
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.8.0-27-generic root=UUID=89d221ec-829a-456e-963d-ec7ac2c7d47d ro crashkernel=384M-2G:64M,2G-:128M quiet splash rootfstype=ext4 vt.handoff=7
SourcePackage: bluez
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/26/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: UX31E.210
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: UX31E
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrUX31E.210:bd12/26/2011:svnASUSTeKComputerInc.:pnUX31E:pvr1.0:rvnASUSTeKComputerInc.:rnUX31E:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: UX31E
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
hciconfig:
 hci0: Type: BR/EDR Bus: USB
  BD Address: 74:2F:68:CE:17:57 ACL MTU: 1022:8 SCO MTU: 183:5
  UP RUNNING PSCAN
  RX bytes:407502 acl:14820 sco:0 events:8796 errors:0
  TX bytes:7391611 acl:8717 sco:0 commands:45 errors:0

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
jpka (jopka) wrote :

I also affected by ~0.5 s delay.
Unfortunately, BYL-918 device does not have other than a2dp profile, so switching not possible, and solutions in comment #2 not applicable.
A number of cheap adapters at online shops have BYL-918 IC.
Playing piano with 0.5 s delay makes cacophony.
Ubuntu 12.04 LTS
Thanks.

jpka (jopka) wrote :

Still not fixed...

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu 12.04.5 LTS"
$ uname -a
Linux ssd 3.13.0-32-generic #57~precise1-Ubuntu SMP Tue Jul 15 03:50:54 UTC 2014 i686 i686 i386 GNU/Linux

jpka (jopka) wrote :

I obtain other receiver module, bc57f687a05 based (appears as BLK-MD-BC05-B). It provides two profiles, HSP/HFP and A2DP. So now i able to switch profiles, but it is not helpful. Switching between them only changes delay but not removes it. HSP/HFP gives 1/4 s but unacceptable sound quality. A2DP gives 1/2 s regardless of switching. Looks like not driver/OS problem, but unavoidable HW problem. I now wonder if someone (using any OS / HW) can get high quality sound via bluetooth without delays. Unless that, bluetooth considered as unusable at all for audio, and also, Kirk Shrewsbury's answer at link mentioned in #2, considered correct.
Thanks.

Chozabu (chozabu) wrote :

Similar experience here:

A2DP - often starts of with low latency, but seems to get worse over time - can get well past 0.5 seconds

HSP/HFP - not used much, except to switch to/back to lower latency in A2DP (which normally works, but often still leaves some lag)

Niklas Keller (kelunik) wrote :

Same issue here. More or less often small disruptions. Seems like those add up and create the latency. Currently using Ubuntu 15.10. Speaker works totally fine with my phone.

Daniel van Vugt (vanvugt) wrote :

Thank you for reporting this bug to Ubuntu.

Ubuntu 15.10 (wily) reached end-of-life on July 28, 2016.
Ubuntu 13.04 (raring) reached end-of-life on January 27, 2014.
Ubuntu 12.04 (precise) reached end-of-life on April 28, 2017.

See this document for currently supported Ubuntu releases:
https://wiki.ubuntu.com/Releases

Please upgrade to the latest version and re-test.

Changed in bluez (Ubuntu):
status: Confirmed → Incomplete
mokrates (mmolle) wrote :

Still not working in 17.04.

Daniel van Vugt (vanvugt) wrote :

mokrates: Could you please log a new bug with your system details and a full description of the persisting problems? -> https://bugs.launchpad.net/ubuntu/+source/bluez/+filebug

It's easier if we're dealing with bug reports logged against still-supported versions of Ubuntu.

Launchpad Janitor (janitor) wrote :

[Expired for bluez (Ubuntu) because there has been no activity for 60 days.]

Changed in bluez (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers