Computer isn't discoverable

Bug #59222 reported by Stian Jordet on 2006-09-06
42
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
High
Bluetooth

Bug Description

Hi,

I'm not really sure when this started (not using bluetooth very often). It might have been with Dapper, or it might have been with edgy. Anyway, with updated edgy, hciconfig shows:

stianj@chevrolet:~$ hciconfig
hci0: Type: USB
        BD Address: 00:60:57:33:5B:A6 ACL MTU: 192:8 SCO MTU: 64:8
        UP RUNNING PSCAN
        RX bytes:43331 acl:262 sco:0 events:825 errors:0
        TX bytes:11015 acl:254 sco:0 commands:295 errors:0

stianj@chevrolet:~$

and hcid.conf has:

iscan enable; pscan enable;

But the only way to make the computer discoverable, is for me to manually run hciconfig hci0 piscan. I have tried this on two computers running edgy, and they both have the same problem.

Please look into this before edgy.

Thanks!

-Stian

Chris Samuel (chris-csamuel) wrote :

I can confirm this as I've just upgraded to Edgy and had to use the above to get my PC discoverable. :-(

I also don't know if this changed in Dapper or Edgy as I'd not tried it since Breezy, sorry!

Johan Christiansen (johandc) wrote :

Confirmed. Running edgy here.

Running sido hciconfig hci0 piscan makes the computer discoverable.

Changed in bluez-utils:
status: Unconfirmed → Confirmed
fbk (fredericback) wrote :

I can confirm this. Only pscan is enabled by default, but
pscan and iscan should be.

It does not solve the problem for me, though. I still can't
pair to my device because the pin I enter on it is not accepted.

fbk (fredericback) wrote :

Could this be related to bug 56651?

Johan Christiansen (johandc) wrote :

@fbk, Yes, the failing pin-code on outgoing connections is due to the missing passkey-agent. I fixed the pairing issue by using:
sudo hciconfig hci piscan (Fixes #59222)
and afterwards installing passkey-agent from source (Fixes #56651)

Roshan Shariff (roshan.shariff) wrote :

As above, running "hciconfig hci0 piscan" fixes the problem form me. This bug isn't present on Dapper. My /etc/bluetooth/hcid.conf file is almost exactly the same in Dapper and Edgy, but it works perfectly in the former but not in the latter.

Changed in bluez-utils:
assignee: nobody → bluetooth
Paul van Genderen (paulvg) wrote :

Confirmed with Edgy and a Belkin USB bt dev. My cellphone isn't discoverable, but the phone discovers the PC after hciconfig hci0 piscan. Pairing fails because of an invalid passcode.

Changed in bluez-utils:
importance: Undecided → High
Tollef Fog Heen (tfheen) wrote :

Can some of you please try adding:

        discovto 0;

to /etc/bluetooth/hcid.conf, then stopping bluetooth, removing any subdirectories of /var/lib/bluetooth (not /var/lib/bluetooth itself, mind), then starting bluetooth again?

If this makes discovery work for you, please report back. The passcode pairing will still fail, but the machine should be discoverable.

michelem (michele-marcucci) wrote :

Yes Tollef if I put
       discovto 0;
to device section in /etc/bluetooth/hcid.conf the machine become discoverable, I confirm it.

I tried Tollef Fog Heen's solution, and it sort of works. Initially, I
didn't empty out /var/lib/bluetooth/ because pairing was working
perfectly for me (I copied the link key from a Dapper install.) My
only problem was with ISCAN not being enabled by default.

I added "discovto 0;" to the device section of
/etc/bluetooth/hcid.conf and and restarted bluetooth. ISCAN was still
off. Then I emptied /var/lib/bluetooth/ and tried again. This time
ISCAN was enabled.

Then I commented out the "discovto 0;" line and restarted bluetooth.
Predictably, ISCAN was off. When I uncommented out that line and
restarted, ISCAN failed to come on. The only difference between the
two cases was the ISCAN worked if /var/lib/bluetooth/*/config/ had
"mode discoverable" and didn't work if it had "mode connectable".

So, as far as as I can see, the problem is this. If the "discovto 0"
line is present, and /var/lib/bluetooth/*/config contains "mode
discoverable", then ISCAN is enabled. If the "discovto 0" line is
absent, the the "config" file is changed to contain "mode connectable"
and ISCAN is disabled. If "discovto 0" is added again, the config file
isn't changed back to "mode discoverable".

I was able to restore the contents of /var/lib/bluetooth from a Dapper
install and get it to work by adding "discovto 0;" to
/etc/bluetooth/hcid.conf and changing /var/lib/bluetooth/*/config to
"mode discoverable". After this ISCAN (and PSCAN) is enabled by
default.

I still have problems actually connecting though. I use bluetooth for
a PAN and at both ends the pand says "Connection failed. File
exists(17)".

Onkar Shinde (onkarshinde) wrote :

@Tollef

The solution works perfectly.

Tollef Fog Heen (tfheen) wrote :

I just uploaded a version with this in the changelog:

   * Add discovto 0 to the default config file leading to iscan enable
     working out of the box. Malone: #59222

Changed in bluez-utils:
status: Confirmed → Fix Released
nclm (nclm) wrote :

Reopening for 8.04

Changed in bluez-utils:
status: Fix Released → New
nclm (nclm) wrote :

My laptop is not discoverable even though discovto 0; is present in hcid.conf

bluez-utils version is 3.26-0ubuntu3

Onkar Shinde (onkarshinde) wrote :

@nclm

Have you set your computer discoverable from the applet in panel? Make sure you have bluez-gnome installed.

nclm (nclm) wrote :

ok, everything is fine (but my mobile can't connect to my laptop, only the other way works but that is another story)... my mobile didn't showed my laptop because "Receive files from remote devices" was disabled.

Changed in bluez-utils:
status: New → Fix Released
Feanor (angelo-pantano) wrote :

in 8.04 my laptop cant connect to my mobile (nokia e51):

feanor@eldar:~$ sudo hcitool cc 00:1D:6E:B8:11:30
Can't create connection: Input/output error

feanor@eldar:~$ sudo sdptool browse 00:1D:6E:B8:11:30:
Failed to connect to SDP server on 00:1D:6E:B8:11:30: Connection refused

any clues?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers