hidd binary removed form bluez-utils package unable to connect as a result

Bug #191704 reported by Michael Favia on 2008-02-13
60
This bug affects 3 people
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
High
Unassigned
Nominated for Hardy by Bart Samwel

Bug Description

Binary package hint: bluez-utils

Upgrade to most recent hardy bluez-utils package and attempt to locate hidd and or use. If there is a new way to search and connect BT keyboard and mice please let me know and ill update the ubuntu guide, etc. but this seems more like a packaging error than an purposeful omission.

Note: if using Ubuntu (Gnome) and the Bluetooth applet with Ubuntu 7.10 or 8.04, there is a graphical interface to pair mice and keyboards. See:
https://help.ubuntu.com/community/BluetoothMouse

Dustin (dustinh) wrote :

hidd is missing in both bluez-utils packages from 02/12/08 and 02/13/08 (bluez-utils_3.26-0ubuntu1_i386.deb and bluez-utils_3.26-0ubuntu2_i386.deb). Downgrading to bluez-utils_3.24-0ubuntu2_i386.deb from 01/09/08 fixes the issue for now.

Ryan Rawdon (flieslikeabrick) wrote :

I created a question about this originally, thanks to Michael for creating the bug report.

https://answers.launchpad.net/ubuntu/+question/24516

Needless to say, I am seeing the same behavior

Bart Samwel (bart-samwel) wrote :

Confirmed here as well. Please fix!

Michael Favia (michaelfavia) wrote :

Do you have the older version in your var/cache/apt or are you fetching online somewhere? Im never able to find archived packages and would appreciate a link or description where you got it. Thx. -mf

Dustin (dustinh) wrote :

I retrieved it from the pool directory:

http://de.archive.ubuntu.com/ubuntu/pool/main/b/bluez-utils/

There you can find bluez-utils_3.24-0ubuntu2_i386.deb (or similar for your matching architecture). Please keep in mind that you need to do the following in order to downgrade:

sudo dpkg -r bluez-audio bluez-utils
sudo dpkg -i bluez-utils_3.24-0ubuntu2_i386.deb

Starting from version 3.26 bluez-utils adds bluez-audio in a separate package it seems and both depend on each other so you need to remove them before installing the older version from January.

HTH,
Dustin

Matti Lindell (mlind) wrote :

Package should probably be built with additional --enable-hidd or even with --enable-all.

Paul Leger (pleger) wrote :

In http://de.archive.ubuntu.com/ubuntu/pool/main/b/bluez-utils/, I cannot find "bluez-utils_3.24-XXX.deb".

A naive question
Why doesn't ubuntu update a version of "bluez-utils + hidd"?

I'm sorry, i dont know how ubuntu works with updates....

Cheers!

Michael Favia (michaelfavia) wrote :

marking confirmed status. anyone care to mark the importance?

Changed in bluez-utils:
status: New → Confirmed
Dustin (dustinh) wrote :

@Paul Leger:

Odd, it was indeed removed from the mirror since I downloaded it this morning. So let's hope for a quick fix.

Michael Favia (michaelfavia) wrote :

rebuilding the package locally with hopefully correct build options. will update if it works

Onkar Shinde (onkarshinde) wrote :

@Michael,

I have already attached debdiff to bug #178525. Let me know if it works for you.

I've successfully rebuilt the package using that debdiff and the Input service is now listed as running in the gnome bluetooth preferences thing, but hiid still doesn't seem to exist!

Per Osbeck (perosb) wrote :

I downgraded to Gutsys bluez-utils_3.19-0ubuntu3 to get the mouse and keyboard working again.
It seem to work as well.

Matti Lindell (mlind) on 2008-02-14
Changed in bluez-utils:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez-utils - 3.26-0ubuntu3

---------------
bluez-utils (3.26-0ubuntu3) hardy; urgency=low

  * Add missing Ubuntu change in bluez-utils to install service files.
    (LP: #178525, #191704)

 -- Steve Kowalik <email address hidden> Fri, 15 Feb 2008 10:14:40 +1100

Changed in bluez-utils:
status: Confirmed → Fix Released
Matti Lindell (mlind) wrote :

I reckon the hidd and pand (bug #192043) binaries are still missing from 3.26-0ubuntu3:

The following results empty:
$ lesspipe bluez-utils_3.26-0ubuntu3_i386.deb | grep -e 'hidd' -e 'pand'

Michael Favia (michaelfavia) wrote :

@mlind: the binaries are missing but the service files are present and enable the attachment of BT hidd devices (heyboard and mouse im using right now). If you put you BT dongle in "visable and connectable" mode in "bluetooth-properties" (assuming you installed bluez-gnome) then as soon as you move the device it pops open a dialog to accept the connection. I used to have to edit the hcid.conf manually or the other bluetooth file. now it JustWorks for me. that said, i havent tested pand (or rather the network service which i imagien auto detects devices like the input service does once the device is in pairing mode). will do so now and report back.

Onkar Shinde (onkarshinde) wrote :

@mlind

As far as I know. You don't need hidd and pand binaries now. It is all some sort of dbus magic now. Previously *.service and bluetoothd-service-* files were missing.

Ryan Rawdon (flieslikeabrick) wrote :

That doesn't mean they won't be missed by people who use fluxbox, xfce, or some other window manager without bluez-gnome. Personally I know that I want as slim an installation as possible on my ASUS Eee, so I do a lot of things manually.

That said, I use hidd on my other machines as well.

Dustin Kirkland  (kirkland) wrote :

dund appears to still be missing. Is that now part of the dbus magic too?

Michael Favia (michaelfavia) wrote :

the new automated way is great and even an improvement over making people par the devices with a developed UI/CLI. That said i dont seem to be able to make the network service work automatically without pand, and i havent tried anythign dund related. Anyone with better success or a resource for information?

David A Knight (david-ritter) wrote :

The new way seems to be slightly broken however. With 3.24 and hidd my apple keyboard worked fine. Now I get the passcode dialog, the device is listed as paired, however the encryption fails and so the keyboard doesn't work.

Paul Leger (pleger) wrote :

Hi,
       I have some questions...

       @Michael Favia:

        You say that:"
         The binaries are missing but the service files are present and enable the attachment of BT hidd devices (heyboard and mouse im using right now). If you put you BT dongle in "visable and connectable" mode in "bluetooth-properties" (assuming you installed bluez-gnome) then as soon as you move the device it pops open a dialog to accept the connection. I used to have to edit the hcid.conf manually or the other bluetooth file. ...."

        I edited the hcid.conf manually....
        " # Added by Paul
           device 00:07:61:D1:AB {
           name "Dell BT Travel Mouse";
         }

       And in "bluetooh-preference" i have "visable and connectable" (and restarted bluetooth service)
       But, I move my mouse Bluetooth and my mouse doesn't connect...

       What is my problem?... I need my mouse bluetooth

PS: Besides, In "bluetooth-manager", I select "browser devices" and I choose my mouse and i do click in "connect", but ubuntu says
"nautilus cannot handled obex: locations!!!

PS2: Sorry... My english is too bad.

Michael Favia (michaelfavia) wrote :

@paul
this worked for me, your mileage may vary:

1. remove your edits of your conf files.
2. remove the links/trusts shown in bluetooth-properties
3. make your device visable and connectable
4. make sure the input service is running on that tab.
5. put your mouse in pairing mode and move it around

you should be presented with a gnome notification bubble to authorize connection. if not consifder a restart of the bluetoth service or the whole computer (shouldnt be necessary). make sure you have the gnome-bluetooth package installed too or the notifications wont come up.

hope that helps. anyone else with confirmed working now? please comment.

Onkar Shinde (onkarshinde) wrote :

@paul,

'Browse Device' is not for bluetooth input devices. It is for browsing phones/pda. And even in that case it doesn't work because nautilus does not use gnome-vfs anymore and the extension that is supposed to let you 'Browse Device' is not yet ported.

@Michael,
I guess you meant to say 'bluez-gnome' instead of 'gnome-bluetooth'.

@Ryan,

I have no idea if fluxbox provides any panel. But xfce does and you should be easily able to install bluez-gnome because it is a panel applet using GTK+ and is not dependent on GNOME (even if the names suggests so).

Ryan Rawdon (flieslikeabrick) wrote :

Ok, but my real/underlying question is "how do you do it from the command line without the hidd binary?"

There are dozens of other window managers and situations in which people would want to connect their usb mouse|keyboard|phone|headset|etc from the command line, and in fact there are many, many tutorials out there that step people through doing it on the command line.

On Tue, Feb 19, 2008 at 5:06 PM, Ryan Rawdon <email address hidden> wrote:
> in fact there are many, many tutorials out there
> that step people through doing it on the command line.

The same goes for dund, which is my interest here. Lots of tutorials
show how to do dial-up networking using the dund daemon. I'll put
together some info on the new "dbus" mechanisms in Hardy in the Ubuntu
wiki, but I'll need some pointers on what this dbus fanciness is.

:-Dustin

Onkar Shinde (onkarshinde) wrote :

@Ryan,

I hope you find answers to your questions here - http://wiki.bluez.org/

thecure (keith-k) wrote :

I have yet to get my mouse to work again without hidd since upgrading to Hardy. If nautilus handled obex locations correctly it would be much simpler. "Couldn't display obex://[00:07:61:8C:ED:8B]/ Nautilus cannot handle obex: locations."

I would bet that most people would like to click on the bluetooth icon and connect as opposed to searching the web for answers. This really keeps new users away from linux/ubuntu.

thecure (keith-k) wrote :

Bonded devices were removed after Hardy upgrade. I assume if my mouse was still shown as bonded it would still work. Removed my configurations and my blue tooth is visible and connectible but when I move my mouse and / or reset it I don't get a dialog box pop up. Any other suggestions?

Paul Leger (pleger) wrote :

Hi, (Again)

      I haven't achieved to connect my mouse bluetooth, I did all stages of Michael Favia, but i couldn't. My ubuntu dont shows me any message (I remember that once ubuntu showed "there is a device or mouse... do you always want to connect mouse? ... I said: "Yes", but it wasn't truth)

I need a solution, I don't know how?, but I need

Tom Imhof (tomimhof) wrote :

Hi, I have the same issue here with a Trust Bluetooth Mouse running on Hardy.
Waiting for a fix ...

Durand D'souza (durand1) wrote :

I got this problem too....It would be useful if an alternative to hidd and dund were linked.

Paul Leger (pleger) wrote :

It haven't fixed yet.
I'm sorry.... I still have the same problem.

Changed in bluez-utils:
status: Fix Released → Confirmed
Ricky Campbell (cyberdork33) wrote :

If the bluetooth stack is going to change how it operates that is fine, progress is progress, but it would be nice to know the method to connect input peripherals without using the browse dialog (that's how many people have been finding their peripherals. Nothing "just works" like it has been stated it should (at least not for me). The detailed information on the bluez.org site is geared toward programmers, and the typical user has no idea what to do with that. Is there a plan for an application to control scanning, bonding, etc for input devices? It seems like very backwards progress to remove a function and not replace it with some alternative method (that invloves something other than "moving your mouse around").

thecure (keith-k) wrote :

Not sure that the package was changed but I'm able to use my Dell mouse now. (Bluetooth preferences, clicking on input service, then add, then clicking on my mouse)

Ricky Campbell (cyberdork33) wrote :

well that sorta works. It might be unrelated to this bug though:
https://bugs.launchpad.net/ubuntu/+source/bluez-gnome/+bug/196787

Fabián Rodríguez (magicfab) wrote :

@thecure, I can confirm your method works in *both* Gutsy and Hardy standard Bluetooth applet (so, using Gnome). So, to connect a BT mouse hidd is not needed. This however does not explain (nor fix) the reported bug.

Fabián Rodríguez (magicfab) wrote :

I have updated the documentation to have info for pairing in 7.10 or 8.04:
https://help.ubuntu.com/community/BluetoothMouse

I also exceptionally changed this bug's description so other's don't have to read all comments to find it.

description: updated
thecure (keith-k) wrote :

Mouse is broken again this AM for me. (May or may not be related bug but other bluetooth mouse broken state duplicate and point to this bug.) Removing the trust and deleting from input service this time results in bluetooth mouse being seen under Browse Device but does not exist in select device after selecting add under input service. Back to not able to connect it myself without hidd. Anyone else experiencing this new break in the bluetooth? Dell mouse incidentally.

Ricky Campbell (cyberdork33) wrote :

I finally got my keyboard to work tonight at the commandline using the following method:
http://ubuntuforums.org/showthread.php?p=4486290

ixothym (ixothym) wrote :

I can confirm that the method described in the link from Ricky Campbell works for my Apple keyboard. Other attempts to connect to the keyboard using "bluetooth-properties" failed with the following messages (from "/var/log/daemon.log"), even if I deleted all old configuration files from bluez:

Mar 16 23:01:15 toxikum hcid[11699]: link_key_request (sba=00:0C:76:47:9D:DF, dba=00:0A:95:3A:3D:76)
Mar 16 23:01:15 toxikum input[12865]: Incoming connection on PSM 17
Mar 16 23:01:15 toxikum input[12865]: Incoming connection on PSM 19
Mar 16 23:01:16 toxikum input[12865]: Link encryption failed: Connection timed out (110)

ixothym (ixothym) wrote :

Just a small addition: after a reboot, my keyboard stopped working again. I have to reconnect it every time I reboot the machine. Any ideas? Btw: this used to work in Ubuntu 7.10 with hidd :-)

Ricky Campbell (cyberdork33) wrote :

yes the method I showed has to be used everytime you want to connect. It adds he keyboard as trusted but it never connects again. If someone can patch the current connection scheme in gnome-bluetooth it should work on startup.

This is very frustrating.

I changed to Ubuntu because the other distros i've tried, There was no way to make my bluetooth mouse work.On ubuntu, a single command (hidd --search), typed only one time, made it work.

Now i need to type all that commands from https://help.ubuntu.com/community/BluetoothMouse, and it will stop working every time again???

Ill keep 7.10 then...

Michael Favia (michaelfavia) wrote :

@christian, if you dont want to constructively add to the discussion please dont feel like you have to post a comment. This isnt digg. We are concerned with the proper operation of the bluetooth stack and welcome your feedback towards that goal.

@all, this is not the intended operative status which is why this is marked as a bug and considered a high priority. regarding the proper function of the bt stack, i am able to add (and keep on restarts) my mouse and keyboard via the instructions i laid out above which are roughly mirrored by: https://help.ubuntu.com/community/BluetoothMouse so i am unable to debug further personally sorry. Will report back any changes or improvements i see in the changelogs that are related. Good luck.

Ricky Campbell (cyberdork33) wrote :

I would gladly add any information you request about my Bluetooth adapter or the Wireless Apple Keyboard (White One) that I would like to connect via Bluetooth. I can verify that I can make it work, there is a lot of ugly commands to get to that point, plus, it does not last through a restart. If there is anything that would be helpful, or maybe you would like tested, please feel free to ask.

Elliot Murphy (statik) wrote :

Hi, I am not affected by this bug but I discovered how to fix it when I was looking into the missing pand binary problem. I have uploaded package to my PPA that includes the pand binary. https://launchpad.net/~statik/+archive
I'm not really sure how to generate a debdiff for this to be easily uploaded to the official repositories, but anyone who wants to can try the package out of this PPA and say if it works for you. I have installed the new package and confirmed that the /usr/bin/hidd used to be absent from my system and is present after installing this updated package.

Elliot Murphy (statik) wrote :

One other thing that I should mention is that the only thing I changed was to add --enable-hidd and --enable-pand to the DEB_CONFIGURE_EXTRA_FLAGS in debian/rules. I don't know if additional flags need to be added, it seems likely that this change was unintentional and it's possible that other configure flags need to be flipped on too.

Onkar Shinde (onkarshinde) wrote :

Hi all,

I myself don't have a bluetooth mouse/keyboard so I can't comment about the functionality. As per what I have heard the hidd, pand binaries are not needed anymore. But there doesn't seem to be a clear explanation as to how to make mouse/keyboard work with new methods.

Can anyone go through howtos on http://wiki.bluez.org and see if it works (using the new dbus method). if it works properly and doesn't give a problem after restart, then please post here the success story.

If it doesn't work for most of you then I think it makes sense to introduce old methods.

NOTE: I am not a developer. I am one of the users. But I will try my best to get this problem solved before release.

Tom Imhof (tomimhof) wrote :

Hello all,

just to let you know - Trust BT Mouse does not work out of the box with the new connection/pairing methods. Here is what I did on a fresh Hardy Beta Install:

1) Opened System -> Preferences -> Bluetooth Preferences and activated "Visible and connectable for other devices" with no timeout.
2) Opened the Services tab, selected Input Services and clicked the Add button
3) Turned on the mouse and actived the Connect button on the bottom of the device
RESULT: None - no mouse detected
4) Opened terminal and typed: hcitool scan
RESULT: None - no mouse detected
5) deinstalled bluez-utils and bluez-audio
6) installed bluez-utils 3.19 (Gutsy version)
7) Opened terminal and typed: hcitool scan
RESULT: Mouse is detected
8) in terminal typed: sudo hidd --connect ##:##:##:##:##:##
9) Updated bluez-utils with latest Hardy version using Upgrade Manager
10) Rebooted
RESULT: Mouse is now automatically detected as soon as I turn it on.

--> It seems that the new BT stack does not detect the device in the first place, but once it is detected (using an older version) and properly added to the config files it works flawlessly.

Same experience anybody?

Cheers
tom

wodan (carlo-griggio) wrote :

Thanks a lot Tom,

your suggestion works really fine with my Logitech DiNovo (Media Desktop Laser version) and it is very simple too!

One positive feedback for me!

Thank you so much,

wo

Ricky Campbell (cyberdork33) wrote :

@Onkar Shinde

I used the commands found at wiki.bluez.org and it connects my keyboard, but it does not last (I am just putting commands in the terminal though). http://ubuntuforums.org/showthread.php?p=4486290

@Tom Imhof

I can try this, but I seem to be getting the reverse problem you see. I add my device, and it is added to the list as being connected, it just does not work as an input device. (Nevermind the fact that trying to add it as an input device also causes the applet to crash).

Michael Favia (michaelfavia) wrote :

Ok to attempt to recreate i disconnected my keyboard, and deleted the trust. I can now not reconnect using the applet as it crashed with an out of memory error in a call to dbus (checking for a valid path for a setting iirc). This error is reported against gnome-bluetooth as a bug here (Bug #179399).

I dont know if there are otherwise any errors in the bluetooth stack so as a temporary workaround i installed the recompiled current package from Elliot and connected manually using "sudo hidd --search" with my device in pairing mode. It is now functional but obviously not the way it should be setup.

This leads me to the following shaky conclusion:

Except for the desired but optional inclusion of the old binaries (was pand or similar functionality available in the normal binary of bluez-utils?) the bluetooth stack seems functional and this is evidenced by our ability to connect via the hidd binary. once bug in the bluetooth-properties applet is fixed hopefully we will be able to register and maintain persistent bt connections using the new and suggested dbus method via the applet.

Ricky Campbell (cyberdork33) wrote :

I upgraded to bluez-gnome 0.25 and still have the same exact functionality. dbus calls in the terminal still connect the keyboard just fine.

Ricky Campbell (cyberdork33) wrote :

I've noticed that, in the process of inputting the dbus commands, the devices gets added in the "Input service" list like it should be. This does not usually happen.

Further tinkering shows that I can select the keyboard in the "Bonded devices" list and disconnect it and upon pressing a key on the keyboard it will try to connect but seemingly fails. issuing only the last command I previously posted (the actual connect command) gets the keyboard working again.

mike (thefannings) wrote :

@ Elliot Murphy

I have a Microsoft bluetooth mouse and dongle, when connecting via the gui I can connect but the mouse fails to work. The cursor moves 2-3 inches then freezes. I installed Elliots binaries and removed the mouse from the gui then ran hidd --search. My mouse is now connected and working. When looking in the gui the mouse is listed in bonded devices with a connector icon, looking under input devices nothing is listed. Previously to using the hidd command the mouse was listed in input devices and bonded devices. In bonded devices there was a info icon constantly and a connector icon would show briefly when moving the mouse.

Durand D'souza (durand1) wrote :

This only helps if you have problems connecting bluetooth peripherals but the is there a way to use the old functionality of the dund and hidd binaries for things like bluetooth internet and dial up networking? Thanks

The problem of missing "dund" seems te be fixed in bluez-utils_3.26-0ubuntu4. You can download it from http://launchpadlibrarian.net/13040805/bluez-utils_3.26-0ubuntu4_i386.deb .

I try this update tonight. Let's hope it has been fixed so I can use ActiveSync again with my cellphone and Evolution.

mike (thefannings) wrote :

I just updated to the latest (3.26-0ubuntu4) and it killed my mouse, hidd is still missing.

Well, I have a dund daemon with bluez-utils_3.26-0ubuntu4. But when I connect the cellphone with ActiveSync with Ubuntu, the PC freezes. The only button that works is the power button. Bluez-utils and ActiveSync works perfectly on Gutsy.

It seems that the bluez-utils package in the Hardy distribution is still buggy. I hope it can be solved on the final release. This issue is very important to me. If I can't use the bluetooth properly on Hardy, I stay on Gutsy. I just need it, otherwise i can't sync my cellphone data.

killerfrog (alexandre0984) wrote :

I do have the same problem too...

I can't connect my bluetooth mouse under Hardy. I was able without any problem under Gusty. I hope those who develop this very usefull utilty will fix this !

Onkar Shinde (onkarshinde) wrote :
Matti Lindell (mlind) wrote :

I really suggest enabling hidd and pand as well to get the binaries back, change (or lack of change) is causing too much hassle. Debian bluez-utils maintainer enabled those as well.

Onkar, would you mind pinging someone in #ubuntu-devel (irc.freenode.net) about this issue? Maybe we could get the missing bits back for RC.

yts2421 (hoopla2421) wrote :

He did not make one thing clear that is easy to overlook. You follow the directions and find that in the services tab that Input Service has already been checked and you see nothing below but,when you uncheck the box and then recheck the box it activates the pairing. Before I did this though I went into /etc/default/bluetooth and "Set the variable HIDD_ENABLED=1". I am not sue if it helped or not but, I do have my mouse back. SEE BELOW

#

on the Bluetooth applet and choose Preferences.
#

Under "Mode of operation" choose "Visible and connectable for other devices"
#

Change to the Services tab, there will be a list of Available services. On that list, click once on Input service.
#

Put your input device in "pair" or "connect" mode. This is usually done with a physical button on or under the device.
#

In the Input Devices section, click "Add". A new window will appear with the input devices visible (in this example, a mouse).

Daniel Holbach (dholbach) wrote :

Marcel: can you take a look at http://launchpadlibrarian.net/13505272/bluez-utils_3.26-0ubuntu6.debdiff and see if it makes sense?

This solution solved my problem too. If the Input service option is
already activated and the blutooth device (mouse) is not connected, then
the input dialog won't appear and it not possible to choose the
bluetooth device. So i had to un-check the "Input Service" in the
services tab first and check this option then the input devices dialog
appaears and the input bluetooth devices are listed in this dialog.
I think this behavior is not well documented.

yts2421 wrote:
> He did not make one thing clear that is easy to overlook. You follow the
> directions and find that in the services tab that Input Service has
> already been checked and you see nothing below but,when you uncheck the
> box and then recheck the box it activates the pairing. Before I did this
> though I went into /etc/default/bluetooth and "Set the variable
> HIDD_ENABLED=1". I am not sue if it helped or not but, I do have my
> mouse back. SEE BELOW
>
> #
>
> on the Bluetooth applet and choose Preferences.
> #
>
> Under "Mode of operation" choose "Visible and connectable for other devices"
> #
>
> Change to the Services tab, there will be a list of Available services. On that list, click once on Input service.
> #
>
> Put your input device in "pair" or "connect" mode. This is usually done with a physical button on or under the device.
> #
>
> In the Input Devices section, click "Add". A new window will appear with
> the input devices visible (in this example, a mouse).
>
>

Per Osbeck (perosb) wrote :

Hi,

I can connect my mouse perfectly with the bluetooth applet.

When it comes to the keyboard I just can't get it to work.

I see the keyboard under after clicking on "Add" in "Input services". When I try to connect to it, the bluetooth applet wants me to enter a passphrase. I can't do this with the bluetooth keyboard since it isn't connected. Doing it with a usb keyboard just closes down all property windows with the error:

process 6219: arguments to dbus_message_new_method_call() were incorrect, assertion "_dbus_check_is_valid_path (path)" failed in file dbus-message.c line 1074.
This is normally a bug in some application using the D-Bus library.

** ERROR **: Out of memory
aborting...

This was tested on a new install of hardy RC. Tried the same on new installed Fedora 9 (Preview) with the same result. Though Fedora had hidd available so doing "hidd --search" allowed me to connect without any passphrases.

Daniel Holbach (dholbach) wrote :

Steve: can you please take a look at it?

vzz (vuohiz) wrote :

I can connect my Logitech dinovo keyboard+mouse fine with gnome bluetooth applet on tray. However problem is this: If device is idle for exactly 30mins, it gets halfway disconnected, log prints out nm_hal_device_removed() at that point, but looking at bluetooth applet (with my ps/2 mouse) it says devices are still connected. Only way to reconnect is use disconnect button on applet, after that it connects again normally by moving mouse. So without wired devices reconnect would be impossible and even with wired mouse it's pretty annoying.

Per: I had some similar problems with bluetooth applet crashing when trying to enter passkeys with wired keyboard. You might try getting timing right, that is enter the passkey quickly with wired, wait a few sec and after that enter it with bluetooth keyboard (I noticed also it wouldn't accept if you enter bluetooth pass too quickly), even with applet already crashed, it eventually accepted the connection atleast for me.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez-utils - 3.26-0ubuntu6

---------------
bluez-utils (3.26-0ubuntu6) hardy; urgency=low

  * debian/rules
    - Enable hidd and pand as users are experiencing problem without those
    binaries. (LP: #191704, #192043)

 -- Onkar Shinde <email address hidden> Wed, 16 Apr 2008 17:41:18 +0530

Changed in bluez-utils:
status: Confirmed → Fix Released
Dustin Kirkland  (kirkland) wrote :

This problem has re-surfaced in Intrepid. The following binaries are missing again:
 * /usr/bin/dund
 * /usr/bin/hidd
 * /usr/bin/pand

:-Dustin

Changed in bluez-utils:
status: Fix Released → Confirmed

On 23/07/2008, Dustin Kirkland <email address hidden> wrote:
> This problem has re-surfaced in Intrepid. The following binaries are missing again:
> * /usr/bin/dund
> * /usr/bin/hidd
> * /usr/bin/pand
>
> :-Dustin
>
>
> ** Changed in: bluez-utils (Ubuntu)
>
> Status: Fix Released => Confirmed
>
>
> --
> hidd binary removed form bluez-utils package unable to connect as a result
> https://bugs.launchpad.net/bugs/191704
> You received this bug notification because you are a direct subscriber
> of the bug.
>
it wasn't ever fixed, was it?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez-utils - 3.36-1ubuntu1

---------------
bluez-utils (3.36-1ubuntu1) intrepid; urgency=low

  * Merge from Debian unstable. (LP: #211252)
  * Remaining Ubuntu changes:
    - Leave 002_hcid_conf_defaults delta to debian.
    - Check for upgrades before 3.30 and cleanup old service files
    - Introduce 3 new packages, bluez-network, bluez-serial, bluez-input.
    - Depend on lsb-base >= 3.2-14, providing status_of_proc()
    - Add the 'status' action to bluez-utils's init script.
    - New patch, 010_hciconfig-hciX, add hci interface to command in hciconfig
      manual page.
  * Ubuntu changes dropped:
    - Turn off hidd, dund, and pand to try the plugins again. (LP: #191704)

bluez-utils (3.36-1) unstable; urgency=medium

  * New upstream version
    + Use safe function versions for SDP client handling.
      (since 3.34)
  * Build-dep on libbluetooth >= 3.36
  * Remove obsolete pcmcia-cs dep
  * Remove old cruft:
    - bluez-pan from /etc/default/bluetooth
    - bluez-sdp from postinst
  * Install *-api.txt
  * Update S-V to 3.8.0, no changes needed
  * Call hid2hci in init.d restart action (Closes: #490980)
  * Fix startup/shutdown message for dund (Closes: #490851)
  * Build dfutool (Closes: #489038)
  * Fix lintian-catched errors:
    - change cupsys dep to cups
    - add #debhelper# to bluez-audio.preinst
  * Rephrase README.Debian as suggested in #477335

 -- Steve Kowalik <email address hidden> Mon, 11 Aug 2008 18:06:07 +1000

Changed in bluez-utils:
status: Confirmed → Fix Released
Ricky Campbell (cyberdork33) wrote :

hidd seems to again be missing...

bluez-utils 4.12-0ubuntu2

Mario Limonciello (superm1) wrote :

Hi Ricky:

This is currently intentional. Please use the new pairing wizard to connect your HID devices. If you find that you are having troubles with the pairing wizard, we can reintroduce the old compatibility binaries in a separate package, but that's a less than ideal situation. If you continue to have problems, please open a new bug against the "bluez" package.

Ricky Campbell (cyberdork33) wrote :

No it is still not working. I don't know why you would remove something useful from the repos when you do not know if the replacement for it will even work. It would be nice if there was some kind of transitional phase for this sort of thing.

I will open that bug report, though since the wizard is not giving any kind of output as to why "pairing has failed" I don't know that it will be helpful.

meba (jakub-rtfm) wrote :

Ricky: Exactly. "Pairing failed" and now what? Can you please point to the bug report you filed?

MrMEEE (mj-casalogic) wrote :

Currently, hidd is missing in the bluez-utils package... Even if I compile the package myself, with hidd support, it doesn't work as expected...

hidd gives me:
root@falcon:/var/log# hidd
 00:14:51:CE:46:A8 martins mus [0000:0000] connected
 00:1B:63:FD:3D:6F Apple Wireless Keyboard [0000:0000] connected

The 0000:0000 used to be the manufacture and model definitions

So there seems to be some problem with bluez, not fetching the id, this gives me problems getting me apple bluetooth wireless keyboard to work... The basic functionallity works.. but the "fn"-button doesn't... probably because the manufacture and model definitions aren't being reported correctly...

Paul Leger (pleger) wrote :

Hi,
       I have just installed the final version of ubuntu 8.10. Again, these (small) are missing. What is the idea about that? is there a technical for not put these binaries?. The wizard method to recognize my bluetooth mouse doesn't work very well because every time that i turn on the laptop i must configure my mouse.

        I need the command line, also, ubuntu is also linux, too. ubuntu is not windows with wizard methods.

some solution for that?

Ricky Campbell (cyberdork33) wrote :

The bug report for this is now here:
https://bugs.edge.launchpad.net/mactel-support/+bug/281580

As stated there, you have to install the bluez-compat package to get these now.

glass.dimly (jmjohn) wrote :

I'm late to this discussion, six years late, in fact. But I stumbled across this bug when trying to run "hidd."

What I needed was this: sudo apt-get install bluez-compat which added cli bluetooth tools.

Well, enough. Hope to help someone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions