bluez-audio: missing replaces: on bluez-utils

Bug #191304 reported by Steve Langasek on 2008-02-12
78
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
High
Tollef Fog Heen

Bug Description

Binary package hint: bluez-utils

The newly-merged bluez-audio package ships /usr/lib/bluetooth/bluetoothd-service-audio, which was in the bluez-utils package in gutsy. bluez-audio needs to have a Replaces: bluez-utils added.

Related branches

Steve Langasek (vorlon) on 2008-02-12
Changed in bluez-utils:
importance: Undecided → High
milestone: none → ubuntu-8.04-beta
status: New → Confirmed
Martin Pitt (pitti) wrote :

Replaces:/Conflicts:, not just Replaces:.

Changed in bluez-utils:
assignee: nobody → tfheen
Marcel Holtmann (holtmann) wrote :

I don't know who in the end decided to move bluetoothd-service-audio into its own package. That is totally stupid and makes no real sense. The audio service can exist without any ALSA or GStreamer plugin and could as so be perfectly part of bluez-utils package. Having separate bluez-alsa and bluez-gstreamer packages would have made sense in my eyes.

Tollef Fog Heen (tfheen) wrote :

It was done in Debian, for reasons beyond me, but I decided to merge it in in Ubuntu as well to make merges from Debian easier later on.

(And I have uploaded a fixed package for this bug just now.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez-utils - 3.26-0ubuntu2

---------------
bluez-utils (3.26-0ubuntu2) hardy; urgency=low

  * Add missing Conflicts and Replaces for bluez-audio. LP: #191304.

 -- Tollef Fog Heen <email address hidden> Wed, 13 Feb 2008 12:32:43 +0100

Changed in bluez-utils:
status: Confirmed → Fix Released
Marcel Holtmann (holtmann) wrote :

It makes sense to split bluez-alsa and bluez-gstreamer, because their dependency chain is big. However if you use ALSA you don't wanna have the dependencies on GStreamer and vice-versa. Also an embedded system with SCO over PCM (like the Nokia tablets) might wanna use only the audio service and don't wanna drag in the dependencies for any of these packages. The Debian people really need to start talking to me before they do these things :(

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers