no available bluetooth services

Bug #178525 reported by Henrik Brink on 2007-12-25
6
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: bluez-gnome

On Hardy Test 1 and 2 there are no bluetooth services in the bluetooth preferences dialog under the services tab, making it impossible to pair with my bluetooth mouse in a GUI like I did in Gutsy.

The services are however installed, and in a terminal, I had to manually do:

hidd --search

to get i to work.

Please let me know if I should provide you with some more information.

Related branches

description: updated
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Which specific version of bluez-gnome do you have installed? You can check via 'dpkg -l bluez-gnome'. I have 0.14-0ubuntu2 and have information in the services tab. Thanks in advance.

Changed in bluez-gnome:
assignee: nobody → brian-murray
status: New → Incomplete
Henrik Brink (henrikbrink) wrote :

I also have 0.14-0ubuntu2 of bluez-gnome...

There's also something else strange, although I dont know if its connected. When I reboot my computer now, the mouse is not trusted automatically, but when I activate it, it appears in the bonded devices list, but doesn't work. I really have to do sudo hidd --search every time I reboot.

Brian Murray (brian-murray) wrote :

Could you also add the full output of 'dpkg -l bluez*'? Thanks again.

Henrik Brink (henrikbrink) wrote :

Sure...

$ dpkg -l bluez*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-f/Unpacked/Failed-cfg/Half-inst/t-aWait/T-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Navn Version Beskrivelse
+++-==============-==============-============================================
ii bluez-cups 3.24-0ubuntu1 Bluetooth printer driver for CUPS
un bluez-firmware <ingen> (ingen tilgængelig beskrivelse)
ii bluez-gnome 0.14-0ubuntu2 Bluetooth utilities for GNOME
un bluez-pan <ingen> (ingen tilgængelig beskrivelse)
un bluez-passkey- <ingen> (ingen tilgængelig beskrivelse)
un bluez-sdp <ingen> (ingen tilgængelig beskrivelse)
ii bluez-utils 3.24-0ubuntu1 Bluetooth tools and daemons

Matti Lindell (mlind) wrote :

I can confirm this. Using hardy and bluez-gnome 0.14-0ubuntu2. Services were available in Gutsy.

Brian Murray (brian-murray) wrote :

I have the same versions of bluez-gnome and bluez-utils installed and do see services listed in the services tab. Looking at the bluez-utils package it provides files like '/etc/bluetooth/audio.service'. So I'm not quite certain what the issue is but will confirm the bug since mlind has the issue also.

Changed in bluez-gnome:
assignee: brian-murray → nobody
status: Incomplete → Confirmed
Matti Lindell (mlind) wrote :

bluez-utils 3.24-0ubuntu1 doesn't seem to install the .service files. I'll attach a debdiff which brings these files back again.

Steve, would you mind taking a look at the changes as you've have been providing us thebluez-utils updates lately?
Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez-utils - 3.24-0ubuntu2

---------------
bluez-utils (3.24-0ubuntu2) hardy; urgency=low

  * Install /etc/bluetooth/*.service files as well. (LP: #178525)

 -- Steve Kowalik <email address hidden> Wed, 09 Jan 2008 13:22:37 +1100

Changed in bluez-utils:
status: Confirmed → Fix Released
Onkar Shinde (onkarshinde) wrote :

The package does not contain any service files. Reopening.
I will probably attach a debdiff shortly.

Changed in bluez-utils:
status: Fix Released → Confirmed
Onkar Shinde (onkarshinde) wrote :

Please find attached the fix that should actually fix this bug and bug #191704.
Please note that I couldn't actually test the HID problem mentioned in the other bug as I don't have bluetooth input devices.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluez-utils - 3.26-0ubuntu3

---------------
bluez-utils (3.26-0ubuntu3) hardy; urgency=low

  * Add missing Ubuntu change in bluez-utils to install service files.
    (LP: #178525, #191704)

 -- Steve Kowalik <email address hidden> Fri, 15 Feb 2008 10:14:40 +1100

Changed in bluez-utils:
status: Confirmed → Fix Released

Fixed pacakges haven't hit the mirrors yet (soon?), in the meanwhile they're available from here:

https://launchpad.net/ubuntu/hardy/+source/bluez-utils

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers