Ubuntu

Gusty bluetooth OBEX Push (File receive)

Reported by Pete on 2007-10-16
28
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
Undecided
Unassigned

Bug Description

It seems there is a bug in Gusty that prevents it from receiving incoming OBEX push connections. I'm not sure which package the problem lies in, hence I've reported it for the 'bluetooth' metapackage.

A simple way to reproduce is to initiate an incoming obex push connection, for example try sending a file from a mobile phone. This seems to result in nothing more than a 'Connection refused' type error on the phone. Sending a file from the computer out works fine. In feisty it worked fine.

Verified by another person with different model of computer and phone, also running Kde. This may be kde/kbluetoothd specific, I am currently unable to verify this with Gnome.

phedders (paul+ubuntu) wrote :

Same problem here...
ii bluez-cups 3.19-0ubuntu3 Bluetooth printer driver for CUPS
rc bluez-gnome 0.14-0ubuntu2 Bluetooth utilities for GNOME
ii bluez-hcidump 1.39-1 Analyses Bluetooth HCI packets
ii bluez-utils 3.19-0ubuntu3 Bluetooth tools and daemons
ii kdebluetooth 1.0~beta8-0ubuntu5 KDE Bluetooth Framework
ii libbluetooth-dev 3.19-0ubuntu1 Development files for using the BlueZ Linux
ii libbluetooth2 3.19-0ubuntu1 Library to use the BlueZ Linux Bluetooth sta
ii libkbluetooth0 1.0~beta8-0ubuntu5 shared libs for kdebluetooth

Pete (pete123) wrote :

Good to have someone else confirm it. Is anyone using Gnome experiencing this problem also?

Changed in bluez-utils:
status: New → Confirmed
dmatt (martind) wrote :

I have the same problem with kdebluetooth. As a workaround I transferred files from mobile directly to USB key running Feisty Live CD. From the links provided by Origaman I suspect this will not be solved very soon. Could the Gutsy downgrade to Feisty kdebluetooth for the time beeing? Or can I downgrade kdebluetooth only on my computer somehow?

Martin (martin-zdila) wrote :

i have the same problem. in feisty it worked, gutsy just sucks :-(

Pete (pete123) wrote :

Its one of my main uses for bluetooth (as I'm unable to sync calender, contacts etc), shame it doesn't work under Gusty.

beccon (conrad-diskussion) wrote :

I have the same issue too: we tried two mobile phones an SonyEricsson K600i and a LG KG 800- no avail. :-(

But as I am able to access the internal file system of my mobile by klicking on the obex icon in kbluetooth everything is not as bad as it looked first (would be great anyway, if the issue was gone soon :-) ) The funny thing is that the obex file system didn't work before.

As this is my Notebook computer, I use the following services too
- use mobile as modem
- Bluetooth headset
- remote control function of the SonyEricsson phone to flip presentation charts (no, not in Powerpoint)

all work well - I wouldn't risk messing them up by experimenting. :-)

Conrad

Pete (pete123) wrote :

Of the many adapters I have tried with Gusty none work, with any device. All other functions I am able to try do however work. It seems to be a bug in kbluetooth, that has been around for a good while, see the link posted before: http://qa.mandriva.com/show_bug.cgi?id=31754 .

Dani Alonso (dalonso) wrote :

I have the same problem, just as described in this bug. By the way, I'm not using kubuntu but ubuntu itself, so I think it's not a problem in kbluetooth.

mohamnag (mohamnag) wrote :

I'm having kubuntu gusty and every thing updated up to moment but I have problems receiving files. sending and pairing works but receiving doesn't work. after finding my pc and selecting that to send the file, my phone says 'Unable to Connect'.

lizardmenke (lizardmenke) wrote :

I'm running Ubuntu gutsy and I can confirm the problem: Sending a file from the computer to, in my case, a mobile phone is No problem. But if I try to send a file from the phone to the computer, the phone can not connect or doesn't 'see' the computer at all.

lizardmenke (lizardmenke) wrote :

I don't know if it is relevant, but sind Gutsy Infra-red connection doesn't work anymore either.

Stephen Irons (stephen-irons) wrote :

I had to install package gnome-bluetooth. This gives you three things:

* Send To > Bluetooth option in Nautilus
* gnome-obex-send, a little UI to send a file to a Bluetooth device. I think the Send To > Bluetooth option uses this behind the scenes
* Applications > Accessories > Bluetooth File Sharing menu option, which runs
* gnome-obex-server

gnome-obex-server is what you want: it enables the OBEX file receive service.

It is a bad name: file sharing suggests to me that I am sharing my files via bluetooth.

It also is in a bad place: it should be one of the services in the gnome-bluetooth-applet that sits in the taskbar, not a separate application that makes a new icon on the taskbar.

I believe there are moves afoot to move both the Nautilus > Send To > Bluetooth and Applications > Accessories > Bluetooth File Sharing from the package gnome-bluetooth to package bluez-gnome where it belong (or at least to integrate the functionality there).

http://fedoraproject.org/wiki/Releases/FeatureBluetooth
https://bugs.launchpad.net/ubuntu/+source/bluez-gnome/+bug/180222

and a summer-of-code project to do this. Google cache only, I don't know what happened to the original link.
http://www.google.com/search?q=cache:JeW030y2J4sJ:code.google.com/soc/gnome/appinfo.html%3Fcsaid%3D9A663A0AC40813A9+holtmann+bluetooth+summer+of+code&hl=en&ct=clnk&cd=1

Matti Lindell (mlind) wrote :

Do you still have this issue in Hardy ?

Martin (martin-zdila) wrote :

It works for me now. Thanks for fixing!

Matti Lindell (mlind) on 2008-04-05
Changed in bluez-utils:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.