Bluetooth Error in Feisty Fawn

Bug #121421 reported by samad909 on 2007-06-20
16
Affects Status Importance Assigned to Milestone
bluez-utils (Ubuntu)
Undecided
Bluetooth

Bug Description

I have tried searching ubuntu forums and also asked for help in the forum and on freenode ubuntu chatroom. The problem is that when I do a hcitool scan after a little time it says Inquiry Failed:Connection Timed Out. I have tried lsusb and it lists my bluetooth dongle. Even a hcitool dev shows up my bluetooth dongle with a BT address but scanning is not possible at all. The error that comes up is "Inquiry Failed:Connection Timed Out".

Ralf Meyer (ranf) wrote :

Let's start with the "Minimal Information" from this page:
https://wiki.ubuntu.com/KernelTeamBugPolicies

samad909 (hacker-samad) wrote :
samad909 (hacker-samad) wrote :
samad909 (hacker-samad) wrote :
samad909 (hacker-samad) wrote :
Ralf Meyer (ranf) wrote :

Thanks.

Do you get something from:

grep Bluetooth /var/log/messages

yup it is attached

On 7/6/07, Ralf Meyer <email address hidden> wrote:
>
> Thanks.
>
> Do you get something from:
>
> grep Bluetooth /var/log/messages
>
> --
> Bluetooth Error in Feisty Fawn
> https://bugs.launchpad.net/bugs/121421
> You received this bug notification because you are a direct subscriber
> of the bug.
>

samad909 (hacker-samad) wrote :
samad909 (hacker-samad) wrote :

I am still waiting for a reponse/fix..

Ralf Meyer (ranf) wrote :

You said the bluetooth hardware is listed with "lsusb".

Please attach the output of:

sudo lsusb -v

Ralf Meyer (ranf) wrote :

subscribed the bluetooth team.

samad909 (hacker-samad) wrote :

uhh...what next?

Siavash Safi (siavash-safi) wrote :

Hi all

you only need to remove "discovto 0;" from '/etc/bluetooth/hcid.conf'!
Don't forget to restart the bluetooth services (/etc/init.d/bluetooth restart) so the changes will take effect!

good luck!

samad909 (hacker-samad) wrote :

ok thanks, I will check it and let you know

samad909 (hacker-samad) wrote :

well it does not work

same error again

I just commented that discovto line in the file you told me to and I have the same error
user@pc:~$ sudo hcitool scan
Scanning ...
Inquiry failed: Connection timed out

user@pc:~$ hcitool scan
Scanning ...
Inquiry failed: Connection timed out

samad909 (hacker-samad) wrote :

I restarted the bluetooth service too before attempting the stuff given above....any ideas anyone?

michelino (puccio) wrote :

I have the same problem: hcitool scan exit without any results:
michele@michele-p:~$ hcitool scan
Scanning ...
michele@michele-p:~$
I'm attaching all the information required

michelino (puccio) wrote :
michelino (puccio) wrote :
michelino (puccio) wrote :
michelino (puccio) wrote :
michelino (puccio) wrote :
michelino (puccio) wrote :
michelino (puccio) wrote :

some other information:
michele@michele-p:~$ hciconfig -a
hci0: Type: USB
        BD Address: 00:16:41:1B:97:A3 ACL MTU: 384:8 SCO MTU: 64:8
        UP RUNNING PSCAN
        RX bytes:5134 acl:0 sco:0 events:220 errors:0
        TX bytes:1647 acl:0 sco:0 commands:93 errors:0
        Features: 0xff 0xff 0x9f 0xfe 0x9b 0xf9 0x00 0x80
        Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3
        Link policy: RSWITCH HOLD SNIFF PARK
        Link mode: ACCEPT MASTER
        Name: 'michele-p-0'
        Class: 0x3e010c
        Service Classes: Networking, Rendering, Capturing, Object Transfer, Audio
        Device Class: Computer, Laptop
        HCI Ver: 1.2 (0x2) HCI Rev: 0x679 LMP Ver: 1.2 (0x2) LMP Subver: 0x679
        Manufacturer: Cambridge Silicon Radio (10)

attached the hcid.conf file.
Hope somebody can help me...
tahnks

samad909 (hacker-samad) wrote :

michelino...carry this on...I had to switch back to windows xp as I had to do alot of things via bluetooth...I will check back often...once it is fixed I will give ubuntu a shot again...till then I am using ubuntu on my server and xp on the desktop..

erwin (erwinatuli) wrote :

hi i'm havin exactly the same problem with samad909
hi,. great work ya all..

Evgeny Remizov (ram3ai) wrote :

try
sudo hciconfig hci0 reset

worked at least for me

Kriebz (kriebz) wrote :

This worked for me, too, but I have no idea why it's necessary. I've heard of some Broadcom chips not starting in the right mode, so maybe that's my problem. lsusb -v stanza for my little nugget/dongle is "0a5c:2039 Broadcom Corp. Bluetooth Device". I'd add something to the bluetooth init script by hand if I thought it wouldn't get overwritten.

samad909: come back to the fold!

Is this still an issue for you? Which Ubuntu version do you use? Thank you for telling us!

dino99 (9d9) wrote :

This version has expired

Changed in bluez-utils (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers