Ubuntu

Desktop item translations not shown

Reported by Timo Jyrinki on 2007-03-25
2
Affects Status Importance Assigned to Milestone
bluez-gnome (Ubuntu)
Medium
Timo Jyrinki

Bug Description

Binary package hint: bluez-gnome

I've installed the latest daily language packs that do include all the bluez-gnome translations, but the item in System/Preferences is still not translated. It seems there was earlier bug 92688 about the translations missing from Rosetta. They've been there now for over a week.

Maybe similar to bug 95215 in restricted-manager? Ie. missing X-Ubuntu-Gettext-Domain.

Related branches

Timo Jyrinki (timo-jyrinki) wrote :

Actually, I do _not_ even see the translations for applet/bluetooth-applet.desktop or properties/bluetooth-properties.desktop in Rosetta.

Daniel Holbach (dholbach) wrote :

I'm not sure what the problem is. After building bluez-gnome:

daniel@bert:~/bluez-gnome-0.6$ grep -r X-Ubuntu *
debian/bluez-gnome/usr/share/applications/bluetooth-properties.desktop:X-Ubuntu-Gettext-Domain=bluez-gnome
debian/bluez-gnome/etc/xdg/autostart/bluetooth-applet.desktop:X-Ubuntu-Gettext-Domain=bluez-gnome
daniel@bert:~/bluez-gnome-0.6$ ls po/*.pot
po/bluez-gnome.pot
daniel@bert:~/bluez-gnome-0.6$

It seems to be all good.

Changed in bluez-gnome:
status: Unconfirmed → Needs Info
assignee: nobody → bluetooth
importance: Undecided → Medium
Timo Jyrinki (timo-jyrinki) wrote :

Well... the translations for the desktop files are not included in the bluez-gnome.pot anyway, for some reason. I started comparing to another application, desktop-effects and how it's doing it. I found at least the following differences:
- it uses .desktop.in file, with "_" in front of Name and Comment fields
- it uses eg. @INTLTOOL_DESKTOP_RULE@ in Makefile.am that probably somehow helps in generating the .desktop file from the .desktop.in

I started doing a patch, but I really don't know exactly what I'm doing (I don't know cdbs, and I don't know this .desktop l10n stuff).

Changed in bluez-gnome:
status: Needs Info → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

This is a result of trying to mimick how desktop-effects is doing it. Ie. change to .in files, add underscores there, modify Makefile.am-files in applet and properties to include eg.:
+autostart_in_files = bluetooth-applet.desktop.in
+autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@

As just the Makefile.am is naturally not enough, I ran automake and then hand-edited the diff from old and new Makefile.in in both directories to include just these changes.

The diff is against bluez-gnome_0.6-1ubuntu1, ie. not the original tar ball. It compiles cleanly, and dpkg-buildpackage builds correctly, including the same files as before. The problem is that still the .desktop files don't show as translatable in bluez-gnome.pot, so they wouldn't be translatable in Rosetta either.

I'm putting this patch out here now because probably there are some people who actually know how this should be fixed :)

Timo Jyrinki (timo-jyrinki) wrote :

Ah! I forgot to change the patch that added the .desktop files to the POTFILES.in in the first place. A new patch is attached, seems to work. What do you think?

Of course, the 01-fix-POTFILES.in.patch should be changed and the rest of this diff should be made into eg. 02-fix_desktop_translations.

Timo Jyrinki (timo-jyrinki) wrote :

Well, here's that too, ie. a patch that changes the 01-fix-POTFILES.in.patch to use .desktop.in files and adds 02-fix_desktop_translations.patch that includes the rest of the changes. The only change to the 02.patch was to remove the removal of the .desktop files (they will be recreated from .desktop.in files anyway) since it somehow caused a problem when doing several dpkg-buildpackage:s and the debian build system tried to reverse the patch.

I now also tested with apt-get source bluez-gnome, applying this patch, putting an updated fi.po under po/directory and doing a package - now the System/Preferences/Bluetooth preference is translated to Finnish.

Timo Jyrinki (timo-jyrinki) wrote :

Here's another patch, that makes the tooltip of the icon and the title of the About window translatable. Also tested to be working.

With these two patches I'd be quite satisfied with the applet. Once/if they're in, I'll try to reach the upstream developers as well. I already tried to send my previous Finnish translation there, but only now noticed that their home page suggests to always mail the devel-list, not individual developers (I sent to the e-mail address found in debian/copyright).

Daniel Holbach (dholbach) wrote :

 bluez-gnome (0.6-1ubuntu2) feisty; urgency=low
 .
   * debian/patches/02_fix_desktop_translations.patch,
     debian/patches/03-make_tooltip_and_dialog_name_translatable.patch:
     - patches by Timo Jyrinki <email address hidden> to fix LP: #95796.

Changed in bluez-gnome:
status: Confirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Sorry for my complicated instructions, it went a bit wrong :) You should take 0.6-1ubuntu1 sources, then _apply_ with patch -p1 the second to last patch on top of it (modifies debian/patches), then _put_ the last patch (03) in debian/patches, and there you'd have the correct upload.

Changed in bluez-gnome:
status: Fix Released → Confirmed
Timo Jyrinki (timo-jyrinki) wrote :

To make it a bit simpler, just replace the current debian/patches directory with the contents of this .tar.gz. It contains the modified 01 patch, and the new 02 and 03 patches.

Daniel Holbach (dholbach) wrote :

if [ "debian/stamp-patched" = "reverse-patches" ]; then rm -f debian/stamp-patched; fi
patches: debian/patches/01-fix-POTFILES.in.patch debian/patches/02-fix_desktop_translations.patch debian/patches/02_fix_desktop_translations.patch debian/patches/03-make_tooltip_and_dialog_name_translatable.patch
Trying patch debian/patches/01-fix-POTFILES.in.patch at level 1 ... success.
Trying patch debian/patches/02-fix_desktop_translations.patch at level 1 ... success.
Trying patch debian/patches/02_fix_desktop_translations.patch at level 1 ... 0 ... 2 ... failure.
make: *** [debian/stamp-patched] Error 1

Changed in bluez-gnome:
assignee: bluetooth → timo-jyrinki
status: Confirmed → In Progress
Daniel Holbach (dholbach) wrote :

 bluez-gnome (0.6-1ubuntu3) feisty; urgency=low
 .
   * debian/patches/01-fix-POTFILES.in.patch
     debian/patches/02-fix_desktop_translations.patch
     debian/patches/03-make_tooltip_and_dialog_name_translatable.patch:
     - updated.
   * debian/patches/02_fix_desktop_translations.patch:
     - dropped, got renamed.

Changed in bluez-gnome:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers